aboutsummaryrefslogtreecommitdiff
path: root/devel/entity/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-28 14:03:34 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-28 14:03:34 +0000
commit4f1294058e7acf2251dd6cfb468745bd7038fa7b (patch)
tree958d3a896897396c76d565b1dd4882426186d8ef /devel/entity/Makefile
parenta82e50a994f167dc21ab5d3949e6fff858d51939 (diff)
downloadports-4f1294058e7acf2251dd6cfb468745bd7038fa7b.tar.gz
ports-4f1294058e7acf2251dd6cfb468745bd7038fa7b.zip
Notes
Diffstat (limited to 'devel/entity/Makefile')
-rw-r--r--devel/entity/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/entity/Makefile b/devel/entity/Makefile
new file mode 100644
index 000000000000..ce4536c65c6a
--- /dev/null
+++ b/devel/entity/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: entity
+# Date created: 15 June 2000
+# Whom: Jesse McConnell <jesse@cylant.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= entity
+PORTVERSION= 0.6.6
+CATEGORIES= devel
+MASTER_SITES= http://entity.evilplan.org/Download/files/all-versions/
+
+MAINTAINER= jesse@cylant.com
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+PREFIX= ${LOCALBASE}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-tcl=no \
+ --enable-python=no
+USE_GMAKE= yes
+USE_GTK= yes
+INSTALLS_SHLIB= yes
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib/entity/clib ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/share/entity
+ cd ${WRKSRC}/apps && \
+ pax -r -w `ls | ${GREP} -v Makefile` ${PREFIX}/share/entity
+
+.include <bsd.port.mk>