aboutsummaryrefslogtreecommitdiff
path: root/devel/eric/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-26 00:02:12 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-26 00:02:12 +0000
commitef23afaf5fdb01c4575e2bfcd128a217922b7769 (patch)
tree348e1013b99bd52d5eb7a937b39d2220a79a3fc9 /devel/eric/Makefile
parent8c0a52c1617e12612595ee3b12ae75d2835314e5 (diff)
downloadports-ef23afaf5fdb01c4575e2bfcd128a217922b7769.tar.gz
ports-ef23afaf5fdb01c4575e2bfcd128a217922b7769.zip
Notes
Diffstat (limited to 'devel/eric/Makefile')
-rw-r--r--devel/eric/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/eric/Makefile b/devel/eric/Makefile
new file mode 100644
index 000000000000..924de5385764
--- /dev/null
+++ b/devel/eric/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: eric
+# Date created: 20 January 2004
+# Whom: leafy <leafy@leafy.idv.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eric
+PORTVERSION= 3.3.1
+CATEGORIES= devel python
+MASTER_SITES= http://www.die-offenbachs.de/detlev/files/
+
+MAINTAINER= leafy@leafy.idv.tw
+COMMENT= A Python IDE implemented using PyQt and QScintilla
+
+BUILD_DEPENDS= ${X11BASE}/lib/libqscintilla.so:${PORTSDIR}/x11-toolkits/qscintilla\
+ ${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip\
+ ${LOCALBASE}/bin/pyuic:/${PORTSDIR}/x11-toolkits/py-qt
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+# dirty hack to fix plist if PREFIX != PYTHONBASE
+DESTDIR_LIBS= ${PYTHON_SITELIBDIR:S/${PYTHONBASE}/${PREFIX}/}
+
+do-install:
+ cd ${WRKSRC} && ${PYTHON_CMD} install.py -b ${PREFIX}/bin/ \
+ -d ${DESTDIR_LIBS}
+
+.include <bsd.port.mk>