aboutsummaryrefslogtreecommitdiff
path: root/devel/erlang-gpb
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-07-17 17:59:40 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-07-17 17:59:40 +0000
commit848ceb79401f23abc6e4dcc2ca158061de4e10fc (patch)
tree31073eceb5256b2113ece67abe5295a4f6a4403e /devel/erlang-gpb
parentce27632d3fab8eac374dcd322040d8c77c90c037 (diff)
Notes
Diffstat (limited to 'devel/erlang-gpb')
-rw-r--r--devel/erlang-gpb/Makefile12
-rw-r--r--devel/erlang-gpb/distinfo4
-rw-r--r--devel/erlang-gpb/files/protoc-erl.in3
-rw-r--r--devel/erlang-gpb/pkg-plist2
4 files changed, 17 insertions, 4 deletions
diff --git a/devel/erlang-gpb/Makefile b/devel/erlang-gpb/Makefile
index db296e683c55..fdfc3fb2081b 100644
--- a/devel/erlang-gpb/Makefile
+++ b/devel/erlang-gpb/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gpb
-PORTVERSION= 3.18.6
-PORTREVISION= 1
+PORTVERSION= 3.18.7
CATEGORIES= devel
PKGNAMEPREFIX= erlang-
@@ -11,9 +10,18 @@ COMMENT= Google Protobuf implementation for Erlang
LICENSE= LGPL21
+SUB_FILES+= protoc-erl
+SUB_LIST+= PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION}
+
USES= erlang:rebar
USE_GITHUB= yes
GH_ACCOUNT= tomas-abrahamsson
GH_PROJECT= gpb
+post-install:
+ @${MKDIR} ${STAGEDIR}${ERL_APP_ROOT}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/protoc-erl ${STAGEDIR}${ERL_APP_ROOT}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/protoc-erl ${STAGEDIR}${PREFIX}/bin
+
.include <bsd.port.mk>
diff --git a/devel/erlang-gpb/distinfo b/devel/erlang-gpb/distinfo
index 96ab9b161640..78f297c932c8 100644
--- a/devel/erlang-gpb/distinfo
+++ b/devel/erlang-gpb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tomas-abrahamsson-gpb-3.18.6_GH0.tar.gz) = f5163c35813c4460df5d33fe89d35d1e6d9d971c03abeeef933af38bf49f522a
-SIZE (tomas-abrahamsson-gpb-3.18.6_GH0.tar.gz) = 283698
+SHA256 (tomas-abrahamsson-gpb-3.18.7_GH0.tar.gz) = 7a5d824c165a0b0fd09e4c7317547d3ad122230779356312b5352a55b5332747
+SIZE (tomas-abrahamsson-gpb-3.18.7_GH0.tar.gz) = 283848
diff --git a/devel/erlang-gpb/files/protoc-erl.in b/devel/erlang-gpb/files/protoc-erl.in
new file mode 100644
index 000000000000..8aa6d07d37c2
--- /dev/null
+++ b/devel/erlang-gpb/files/protoc-erl.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec %%LOCALBASE%%/lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/bin/protoc-erl "$@"
diff --git a/devel/erlang-gpb/pkg-plist b/devel/erlang-gpb/pkg-plist
index e575dc251a88..bb82d3dd7234 100644
--- a/devel/erlang-gpb/pkg-plist
+++ b/devel/erlang-gpb/pkg-plist
@@ -1,3 +1,5 @@
+bin/protoc-erl
+lib/erlang/lib/gpb-%%VERSION%%/bin/protoc-erl
lib/erlang/lib/gpb-%%VERSION%%/ebin/gpb.app
lib/erlang/lib/gpb-%%VERSION%%/ebin/gpb.beam
lib/erlang/lib/gpb-%%VERSION%%/ebin/gpb_codegen.beam