aboutsummaryrefslogtreecommitdiff
path: root/devel/error/Makefile
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2001-06-22 22:16:31 +0000
committerDima Dorfman <dd@FreeBSD.org>2001-06-22 22:16:31 +0000
commit9516b65faac18e1b0a2813f7fa6774bec20ff60f (patch)
tree00867ec6c5fc083b093a32fdfa9083d54addaf74 /devel/error/Makefile
parentd0b9cb18ec28662d7312d653fc99300700894676 (diff)
Add error, a program to analyze diagnostic error output from compilers
and other processors. This was formerly in the base system, but was removed because it isn't entirely compatible with the toolchain in use. Nevertheless, at certain times it can still be useful. Reviewed by: roam
Notes
Notes: svn path=/head/; revision=44335
Diffstat (limited to 'devel/error/Makefile')
-rw-r--r--devel/error/Makefile73
1 files changed, 73 insertions, 0 deletions
diff --git a/devel/error/Makefile b/devel/error/Makefile
new file mode 100644
index 000000000000..ca3e135cc378
--- /dev/null
+++ b/devel/error/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: error
+# Date created: 16 June 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= error
+PORTVERSION= 20010616
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.unixfreak.org/~dima/distfiles/
+MASTER_SITE_SUBDIR= dd
+
+MAINTAINER= dd@FreeBSD.org
+
+MANSECTS= 1
+MAN1= error.1
+MANCOMPRESSED= maybe
+
+# MAN page COMPression SUFFIX
+.if !defined(NOMANCOMPRESS)
+MANCOMPSUFFIX= .gz
+.else
+MANCOMPSUFFIX=
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/error ${PREFIX}/bin/error
+.for __s in ${MANSECTS}
+.for __m in ${MAN${__s}:S/$/${MANCOMPSUFFIX}/}
+ @${INSTALL_MAN} ${WRKSRC}/${__m} ${PREFIX}/man/man${__s}/${__m}
+.endfor
+.endfor
+
+#
+# Ports build/install stuff stops here. Tarball creation stuff begins here.
+#
+.include <bsd.port.pre.mk>
+CVS_CMD?= cvs -z3
+CVS_DATE= Sun Jun 16 15:58:14 PDT 2001
+CVS_SITES?= anoncvs@anoncvs.openbsd.org:/cvs
+CVS_MODULE= src/usr.bin/error
+
+#
+# CVS checkout stuff mostly stolen from security/openssh-askpass port by
+# kris@freebsd.org
+#
+tarball:
+ @${MKDIR} ${DISTDIR}/${PKGNAME} && \
+ cd ${DISTDIR}/${PKGNAME}; \
+ for CVS_SITE in ${CVS_SITES}; do \
+ ${ECHO_MSG} ">> Attempting to check out from $${CVS_SITE}."; \
+ if ${CVS_CMD} -d $${CVS_SITE} co -D "${CVS_DATE}" \
+ ${CVS_MODULE}; then \
+ cd ${DISTDIR}; \
+ ${ECHO_MSG} ">> Creating dist tarball in ${DISTDIR}"; \
+ ${ECHO_MSG} ">> \"${PKGNAME}.tar.gz\"."; \
+ ${MV} ${PKGNAME}/${CVS_MODULE} \
+ ${PKGNAME}/${CVS_MODULE:H}/${PKGNAME}; \
+ ${TAR} -cz \
+ -X ${FILESDIR}/tarignore \
+ -f ${PKGNAME}.tar.gz \
+ -C ${PKGNAME}/${CVS_MODULE:H} \
+ ${PKGNAME}; \
+ exit; \
+ fi \
+ done; \
+ ${RMDIR} ${DISTDIR}/${PKGNAME}; \
+ ${ECHO_MSG} ">> CVS checkout failed."; \
+ exit 1;
+
+.include <bsd.port.post.mk>