aboutsummaryrefslogtreecommitdiff
path: root/devel/etoile-coreobject/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-11-24 18:13:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-11-24 18:13:00 +0000
commit5c4987ca2dad487b0d722a851ff4da4d108086b2 (patch)
treea371755b0af984e0fda945ed3a673baa64026eb4 /devel/etoile-coreobject/Makefile
parent7a5868e5cbfc037bb1470ec92a4490f31f937368 (diff)
downloadports-5c4987ca2dad487b0d722a851ff4da4d108086b2.tar.gz
ports-5c4987ca2dad487b0d722a851ff4da4d108086b2.zip
Notes
Diffstat (limited to 'devel/etoile-coreobject/Makefile')
-rw-r--r--devel/etoile-coreobject/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/etoile-coreobject/Makefile b/devel/etoile-coreobject/Makefile
new file mode 100644
index 000000000000..dcea4d4da442
--- /dev/null
+++ b/devel/etoile-coreobject/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: etoile-coreobject
+# Date created: 23 Nov 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= coreobject
+PORTVERSION= 0.4.0
+CATEGORIES= devel gnustep
+MASTER_SITES= http://download.gna.org/etoile/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project CoreObject framework
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+USE_GNUSTEP_LOCAL_LIBS+= EtoileFoundation:${FOUNDATION_PORT}
+USE_GNUSTEP_LOCAL_LIBS+= EtoileSerialize:${SERIALIZE_PORT}
+USE_PGSQL= yes
+
+DEFAULT_LIBVERSION= 0.4
+WRKSRC= ${WRKDIR}/Etoile-${PORTVERSION}
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/CoreObject
+DEFAULT_LIBVERSION2= 0.1
+PLIST_SUB+= LIBVERSION2=${DEFAULT_LIBVERSION2}
+PLIST_SUB+= MAJORLIBVERSION2=${DEFAULT_LIBVERSION2:C/([0-9]).*/\1/1}
+
+FOUNDATION_PORT?= devel/etoile-foundation
+SERIALIZE_PORT?= devel/etoile-serialize
+
+.include <bsd.port.mk>