aboutsummaryrefslogtreecommitdiff
path: root/devel/fastdep/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-30 12:52:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-30 12:52:39 +0000
commitaca8006da4cb6ae0ce231862e7591f01d163a893 (patch)
tree3c31478c12f7799984b8991ef6742034cd0e5e15 /devel/fastdep/Makefile
parenta76838b7701eff85df8d757223c9875251cbe643 (diff)
downloadports-aca8006da4cb6ae0ce231862e7591f01d163a893.tar.gz
ports-aca8006da4cb6ae0ce231862e7591f01d163a893.zip
Notes
Diffstat (limited to 'devel/fastdep/Makefile')
-rw-r--r--devel/fastdep/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/fastdep/Makefile b/devel/fastdep/Makefile
new file mode 100644
index 000000000000..95f7689d0cc0
--- /dev/null
+++ b/devel/fastdep/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: fastdep
+# Date created: Oct 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= fastdep
+PORTVERSION= 0.13
+CATEGORIES= devel
+MASTER_SITES= http://www.irule.be/bvh/c++/fastdep/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+ALL_TARGET= boot
+CFLAGS+= -I${LOCALBASE}/include
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|make|gmake|" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|CXXFLAGS=|CXXFLAGS+=|" ${WRKSRC}/Makefile.common
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fastdep ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>