aboutsummaryrefslogtreecommitdiff
path: root/devel/fb303
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-09 15:19:58 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-09 15:19:58 +0000
commitd2279bbc1e75ae2d3388b2b240e136de92e88029 (patch)
tree61f5245dbfeef3558a5a2b41675a4d9e90a0652d /devel/fb303
parent7bde5a0d1132ca0e5bf60d3fbbd6c6f82190051f (diff)
Notes
Diffstat (limited to 'devel/fb303')
-rw-r--r--devel/fb303/Makefile21
-rw-r--r--devel/fb303/distinfo4
-rw-r--r--devel/fb303/files/extra_patch-cpp__Makefile.am11
-rw-r--r--devel/fb303/files/patch-cpp__FacebookBase.cpp20
-rw-r--r--devel/fb303/pkg-plist2
5 files changed, 49 insertions, 9 deletions
diff --git a/devel/fb303/Makefile b/devel/fb303/Makefile
index bfd137aeec5b..6895d94d2207 100644
--- a/devel/fb303/Makefile
+++ b/devel/fb303/Makefile
@@ -3,7 +3,6 @@
PORTNAME= fb303
PORTVERSION= ${THRIFT_PORTVERSION}
-PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= APACHE
@@ -15,22 +14,32 @@ COMMENT= Facebook Bassline
LICENSE= AL2
-LIB_DEPENDS= boost_system:${PORTSDIR}/devel/boost-libs \
- thrift:${PORTSDIR}/devel/thrift
+LIB_DEPENDS= libthrift.so:${PORTSDIR}/devel/thrift-cpp
+BUILD_DEPENDS= thrift:${PORTSDIR}/devel/thrift
ACLOCAL_ARGS= -I ./aclocal
AUTOMAKE_ARGS= -a
CONFIGURE_ARGS= PY_PREFIX="${PREFIX}"
-USE_AUTOTOOLS= aclocal automake autoconf
-USE_GMAKE= yes
-USES= perl5
+USE_AUTOTOOLS= autoconf autoheader:env aclocal automake
+
+USES= gmake perl5 compiler
USE_PERL5= run
USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/contrib/fb303
PLIST_SUB+= PORTVERSION="${PORTVERSION}" PYTHON_VER="${PYTHON_VER}"
+CONFIGURE_ARGS+= --without-php
+
NO_STAGE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang
+USE_CXXSTD= c++11
+EXTRA_PATCHES+= ${FILESDIR}/extra_patch-cpp__Makefile.am
+.endif
+
post-build:
(cd ${WRKSRC} && ${LOCALBASE}/bin/thrift --gen perl ${WRKSRC}/if/fb303.thrift)
diff --git a/devel/fb303/distinfo b/devel/fb303/distinfo
index 0d094f7f86bf..79547cf7b134 100644
--- a/devel/fb303/distinfo
+++ b/devel/fb303/distinfo
@@ -1,2 +1,2 @@
-SHA256 (thrift-0.9.0.tar.gz) = 71d129c49a2616069d9e7a93268cdba59518f77b3c41e763e09537cb3f3f0aac
-SIZE (thrift-0.9.0.tar.gz) = 2794605
+SHA256 (thrift-0.9.1.tar.gz) = ac175080c8cac567b0331e394f23ac306472c071628396db2850cb00c41b0017
+SIZE (thrift-0.9.1.tar.gz) = 3402353
diff --git a/devel/fb303/files/extra_patch-cpp__Makefile.am b/devel/fb303/files/extra_patch-cpp__Makefile.am
new file mode 100644
index 000000000000..a92c8d68df62
--- /dev/null
+++ b/devel/fb303/files/extra_patch-cpp__Makefile.am
@@ -0,0 +1,11 @@
+--- ./cpp/Makefile.am.orig 2013-08-15 18:04:29.000000000 +0400
++++ ./cpp/Makefile.am 2013-10-17 19:36:43.000000000 +0400
+@@ -37,7 +37,7 @@
+ # USE flags AM_CXXFLAGS, AM_CFLAGS, AM_CPPFLAGS, AM_LDFLAGS, LDADD in this section.
+
+ AM_CPPFLAGS = -I..
+-AM_CPPFLAGS += -Igen-cpp
++AM_CPPFLAGS += -Igen-cpp -std=c++11
+ AM_CPPFLAGS += -I$(thrift_home)/include/thrift
+ AM_CPPFLAGS += $(BOOST_CPPFLAGS)
+ AM_CPPFLAGS += $(FB_CPPFLAGS) $(DEBUG_CPPFLAGS)
diff --git a/devel/fb303/files/patch-cpp__FacebookBase.cpp b/devel/fb303/files/patch-cpp__FacebookBase.cpp
new file mode 100644
index 000000000000..37901fa03688
--- /dev/null
+++ b/devel/fb303/files/patch-cpp__FacebookBase.cpp
@@ -0,0 +1,20 @@
+--- ./cpp/FacebookBase.cpp.orig 2013-08-15 18:04:29.000000000 +0400
++++ ./cpp/FacebookBase.cpp 2013-10-17 19:36:22.000000000 +0400
+@@ -27,7 +27,7 @@
+ aliveSince_ = (int64_t) time(NULL);
+ }
+
+-inline void FacebookBase::getName(std::string& _return) {
++void FacebookBase::getName(std::string& _return) {
+ _return = name_;
+ }
+
+@@ -118,7 +118,7 @@
+ return rv;
+ }
+
+-inline int64_t FacebookBase::aliveSince() {
++int64_t FacebookBase::aliveSince() {
+ return aliveSince_;
+ }
+
diff --git a/devel/fb303/pkg-plist b/devel/fb303/pkg-plist
index 76daa51b9e6f..da7c970c4a83 100644
--- a/devel/fb303/pkg-plist
+++ b/devel/fb303/pkg-plist
@@ -21,7 +21,7 @@ lib/libfb303.a
%%PYTHON_SITELIBDIR%%/fb303_scripts/__init__.pyc
%%PYTHON_SITELIBDIR%%/fb303_scripts/fb303_simple_mgmt.py
%%PYTHON_SITELIBDIR%%/fb303_scripts/fb303_simple_mgmt.pyc
-%%PYTHON_SITELIBDIR%%/thrift-%%PORTVERSION%%-py%%PYTHON_VER%%.egg-info
+%%PYTHON_SITELIBDIR%%/thrift_fb303-1.0.0_dev-py%%PYTHON_VER%%.egg-info
%%DATADIR%%/if/fb303.thrift
@dirrm %%DATADIR%%/if
@dirrm %%DATADIR%%