aboutsummaryrefslogtreecommitdiff
path: root/devel/fb303
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-25 18:23:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-25 18:23:56 +0000
commit3844174133370af328552398ae11d341b8024d82 (patch)
treea009f5d200b4d14956d3ab9cf951227cad13d27d /devel/fb303
parentf4084141e3418c52e41969c93e0eeb2b4d4b55d0 (diff)
downloadports-3844174133370af328552398ae11d341b8024d82.tar.gz
ports-3844174133370af328552398ae11d341b8024d82.zip
Notes
Diffstat (limited to 'devel/fb303')
-rw-r--r--devel/fb303/Makefile38
-rw-r--r--devel/fb303/distinfo3
-rw-r--r--devel/fb303/pkg-descr4
-rw-r--r--devel/fb303/pkg-plist29
4 files changed, 74 insertions, 0 deletions
diff --git a/devel/fb303/Makefile b/devel/fb303/Makefile
new file mode 100644
index 000000000000..30d3ce37a5e6
--- /dev/null
+++ b/devel/fb303/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: fb303
+# Date created: 2009-08-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fb303
+PORTVERSION= 20090622
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= bms
+DISTNAME= thrift-${PORTVERSION}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= The Facebook Bassline
+
+LIB_DEPENDS= boost_system:${PORTSDIR}/devel/boost-libs \
+ thrift:${PORTSDIR}/devel/thrift
+
+ACLOCAL_ARGS= -I ./aclocal
+AUTOMAKE_ARGS= -a
+CONFIGURE_ARGS= PY_PREFIX="${PREFIX}"
+PLIST_SUB+= PYTHON_VERSION_SHORTNAME="${PYTHON_VERSION_SHORTNAME}"
+PYTHON_VERSION_SHORTNAME= ${PYTHON_VERSION:S/thon//}
+USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:262
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/contrib/fb303
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+IGNORE= not supported
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/fb303/distinfo b/devel/fb303/distinfo
new file mode 100644
index 000000000000..d8e77a16d2a8
--- /dev/null
+++ b/devel/fb303/distinfo
@@ -0,0 +1,3 @@
+MD5 (thrift-20090622.tar.bz2) = f24951cb4bc19cb8841c84f62badce34
+SHA256 (thrift-20090622.tar.bz2) = 832faf51971cf8857cacade7b00996719be382992d924ca3263ee07af2c6ee36
+SIZE (thrift-20090622.tar.bz2) = 517465
diff --git a/devel/fb303/pkg-descr b/devel/fb303/pkg-descr
new file mode 100644
index 000000000000..705dae07a9c9
--- /dev/null
+++ b/devel/fb303/pkg-descr
@@ -0,0 +1,4 @@
+A standard interface to monitoring, dynamic options and
+configuration, uptime reports, activity, etc.
+
+WWW: http://incubator.apache.org/thrift/
diff --git a/devel/fb303/pkg-plist b/devel/fb303/pkg-plist
new file mode 100644
index 000000000000..7188d183d602
--- /dev/null
+++ b/devel/fb303/pkg-plist
@@ -0,0 +1,29 @@
+@comment $FreeBSD$
+%%DATADIR%%/if/fb303.thrift
+%%PYTHON_SITELIBDIR%%/fb303-1.0-%%PYTHON_VERSION_SHORTNAME%%.egg-info
+%%PYTHON_SITELIBDIR%%/fb303/FacebookBase.py
+%%PYTHON_SITELIBDIR%%/fb303/FacebookBase.pyc
+%%PYTHON_SITELIBDIR%%/fb303/FacebookService.py
+%%PYTHON_SITELIBDIR%%/fb303/FacebookService.pyc
+%%PYTHON_SITELIBDIR%%/fb303/__init__.py
+%%PYTHON_SITELIBDIR%%/fb303/__init__.pyc
+%%PYTHON_SITELIBDIR%%/fb303/constants.py
+%%PYTHON_SITELIBDIR%%/fb303/constants.pyc
+%%PYTHON_SITELIBDIR%%/fb303/ttypes.py
+%%PYTHON_SITELIBDIR%%/fb303/ttypes.pyc
+%%PYTHON_SITELIBDIR%%/fb303_scripts/__init__.py
+%%PYTHON_SITELIBDIR%%/fb303_scripts/__init__.pyc
+%%PYTHON_SITELIBDIR%%/fb303_scripts/fb303_simple_mgmt.py
+%%PYTHON_SITELIBDIR%%/fb303_scripts/fb303_simple_mgmt.pyc
+include/thrift/fb303/FacebookBase.h
+include/thrift/fb303/FacebookService.h
+include/thrift/fb303/ServiceTracker.h
+include/thrift/fb303/fb303_constants.h
+include/thrift/fb303/fb303_types.h
+lib/libfb303.a
+@dirrmtry include/thrift/fb303
+@dirrmtry include/thrift
+@dirrmtry %%PYTHON_SITELIBDIR%%/fb303_scripts
+@dirrmtry %%PYTHON_SITELIBDIR%%/fb303
+@dirrmtry %%DATADIR%%/if
+@dirrmtry %%DATADIR%%