aboutsummaryrefslogtreecommitdiff
path: root/devel/fc++
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-27 19:11:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-27 19:11:56 +0000
commit037f1b62252a1fe9352b19384cd456c0df804847 (patch)
tree835154c827c5d0dcbafd3a5d6582fe06b60c36fb /devel/fc++
parent528bc62a9ea806061c022e23a0e5ddeb09ef3fb8 (diff)
downloadports-037f1b62252a1fe9352b19384cd456c0df804847.tar.gz
ports-037f1b62252a1fe9352b19384cd456c0df804847.zip
Notes
Diffstat (limited to 'devel/fc++')
-rw-r--r--devel/fc++/Makefile20
-rw-r--r--devel/fc++/pkg-descr2
-rw-r--r--devel/fc++/pkg-plist2
3 files changed, 12 insertions, 12 deletions
diff --git a/devel/fc++/Makefile b/devel/fc++/Makefile
index d7d242e3d348..cab0e5d30c29 100644
--- a/devel/fc++/Makefile
+++ b/devel/fc++/Makefile
@@ -1,27 +1,25 @@
-# ex:ts=8
-# New ports collection makefile for: fc++
-# Date created: Oct 10, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= fc++
PORTVERSION= 1.5
CATEGORIES= devel
-MASTER_SITES= http://www.cc.gatech.edu/~yannis/fc++/
-DISTNAME= FC++.${PORTVERSION}
+MASTER_SITES= http://people.cs.umass.edu/~yannis/fc++/
+DISTNAME= ${PORTNAME:U}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Functional Programming in C++
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-10-20
+OPTIONS_DEFINE= DOCS
NO_BUILD= yes
do-install:
@${MKDIR} ${PREFIX}/include/fc++
- ${CP} ${WRKSRC}/*.h ${PREFIX}/include/fc++
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/fc++
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/changes.html ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/devel/fc++/pkg-descr b/devel/fc++/pkg-descr
index b9224652d547..440657aa8180 100644
--- a/devel/fc++/pkg-descr
+++ b/devel/fc++/pkg-descr
@@ -18,4 +18,4 @@ functions (like map, compose, etc.), a reference-counting facility that can be
used to replace C++ pointers, many common logical and arithmetic operators in
a form that can be used with higher-order functions, and more.
-WWW: http://www.cc.gatech.edu/~yannis/fc++/
+WWW: http://people.cs.umass.edu/~yannis/fc++/
diff --git a/devel/fc++/pkg-plist b/devel/fc++/pkg-plist
index a7c544a964cf..d03576a29c64 100644
--- a/devel/fc++/pkg-plist
+++ b/devel/fc++/pkg-plist
@@ -12,4 +12,6 @@ include/fc++/ref_count.h
include/fc++/reuse.h
include/fc++/signature.h
include/fc++/smart.h
+%%PORTDOCS%%%%DOCSDIR%%/changes.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/fc++