aboutsummaryrefslogtreecommitdiff
path: root/devel/fhist/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2000-01-05 11:00:05 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2000-01-05 11:00:05 +0000
commitd3a5d6236312241932a7fae59576900436fbd918 (patch)
tree409d1587faf9b3b9254a092d7f9eedd5cae73328 /devel/fhist/Makefile
parent8f9bd2a1695bea4a0a2c51eef831421c09d935c1 (diff)
downloadports-d3a5d6236312241932a7fae59576900436fbd918.tar.gz
ports-d3a5d6236312241932a7fae59576900436fbd918.zip
Notes
Diffstat (limited to 'devel/fhist/Makefile')
-rw-r--r--devel/fhist/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/devel/fhist/Makefile b/devel/fhist/Makefile
index 8bb682e3bcc5..c1041bf3b782 100644
--- a/devel/fhist/Makefile
+++ b/devel/fhist/Makefile
@@ -1,29 +1,35 @@
# New ports collection makefile for: fhist
-# Version required: 1.1
-# Date created: Apr 23 1998
-# Whom: <koshy@india.hp.com>
+# Version required: 1.6
+# Date created: Jan 05 2000
+# Whom: <jkoshy@freebsd.org>
#
# $FreeBSD$
#
-DISTNAME= fhist.1.1
-PKGNAME= fhist-1.1
+DISTNAME= fhist-1.6
CATEGORIES= devel
-MASTER_SITES= ftp://archie.au/unix/Aegis/ \
- http://www.canb.auug.org.au/~millerp/ \
+MASTER_SITES= http://www.canb.auug.org.au/~millerp/ \
ftp://ftp.agso.gov.au/pub/Aegis/ \
ftp://ftp.u-aizu.ac.jp/pub/misc/tools/Aegis/ \
http://gd.tuwien.ac.at/softeng/Aegis/
-MAINTAINER= koshy@india.hp.com
+MAINTAINER= jkoshy@freebsd.org
MAN1= fcomp.1 fhist.1 fmerge.1
+ALL_TARGET= binaries
+INSTALL_TARGET= install-bin
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --includedir=${PREFIX}/include
+
+post-extract:
+ cd ${WRKSRC}/lib/en/man1 && ${LN} -s ${WRKSRC}/etc/*.so .
post-install:
.for file in fhist fcomp fmerge
strip ${PREFIX}/bin/${file}
+ (cd ${WRKSRC}/lib/en/man1; soelim ${file}.1 > tmp; \
+ ${INSTALL_MAN} tmp ${PREFIX}/man/man1/${file}.1)
.endfor
.include <bsd.port.mk>