aboutsummaryrefslogtreecommitdiff
path: root/devel/flux/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 18:36:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 18:36:39 +0000
commitc2e96a6fd15ffeb729ad724a29f33c91d1eafc84 (patch)
tree5163ba03df5b625ecccf34756ce8597ed008cfd5 /devel/flux/Makefile
parent82098a30f3f2c8a57f6f5d88e7c5b0f4898eed3c (diff)
downloadports-c2e96a6fd15ffeb729ad724a29f33c91d1eafc84.tar.gz
ports-c2e96a6fd15ffeb729ad724a29f33c91d1eafc84.zip
Notes
Diffstat (limited to 'devel/flux/Makefile')
-rw-r--r--devel/flux/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/flux/Makefile b/devel/flux/Makefile
index c727e756f957..db773d5b7543 100644
--- a/devel/flux/Makefile
+++ b/devel/flux/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= ftp://ftp.copyleft.no/projects/fluxlib/ \
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER=14
USE_LIBTOOL= yes
@@ -21,19 +22,19 @@ REGEX= "s@EXTRA_DIST \+@EXTRA_DIST @g"
pre-configure:
.for M in examples include src util
- @${PERL} -pi -e ${REGEX} ${WRKSRC}/${M}/Makefile.am
+ @${REINPLACE_CMD} -e ${REGEX} ${WRKSRC}/${M}/Makefile.am
.endfor
.for M in build cgi cipher comm fifobuf fstring log mem misc mt nvtp ph proc \
random smtp sock tn url xml
- @${PERL} -pi -e ${REGEX} ${WRKSRC}/src/${M}/Makefile.am
+ @${REINPLACE_CMD} -e ${REGEX} ${WRKSRC}/src/${M}/Makefile.am
.endfor
.for M in framework/application framework/application/src test
- @${PERL} -pi -e ${REGEX} ${WRKSRC}/util/${M}/Makefile.am
+ @${REINPLACE_CMD} -e ${REGEX} ${WRKSRC}/util/${M}/Makefile.am
.endfor
.for M in smtp
- @${PERL} -pi -e ${REGEX} ${WRKSRC}/examples/${M}/Makefile.am
+ @${REINPLACE_CMD} -e ${REGEX} ${WRKSRC}/examples/${M}/Makefile.am
.endfor
- ${PERL} -pi -e "s@autoheader,@${AUTOHEADER},@g" ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e "s@autoheader,@${AUTOHEADER},@g" ${WRKSRC}/aclocal.m4
post-install:
.if !defined(NOPORTDOCS)