aboutsummaryrefslogtreecommitdiff
path: root/devel/flux
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-07 05:17:18 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-07 05:17:18 +0000
commit04dfaa68e3d492c7ea34bdd656a1230abcf97f37 (patch)
treef19c93b44fd888b73b1236e47a9a1adc3329247e /devel/flux
parent1c59599ed63e0f61770bd8b5be930d54804dc920 (diff)
downloadports-04dfaa68e3d492c7ea34bdd656a1230abcf97f37.tar.gz
ports-04dfaa68e3d492c7ea34bdd656a1230abcf97f37.zip
Notes
Diffstat (limited to 'devel/flux')
-rw-r--r--devel/flux/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/devel/flux/Makefile b/devel/flux/Makefile
index b09bfb87e758..c727e756f957 100644
--- a/devel/flux/Makefile
+++ b/devel/flux/Makefile
@@ -17,6 +17,23 @@ USE_GMAKE= yes
USE_AUTOMAKE_VER=14
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+REGEX= "s@EXTRA_DIST \+@EXTRA_DIST @g"
+
+pre-configure:
+.for M in examples include src util
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/${M}/Makefile.am
+.endfor
+.for M in build cgi cipher comm fifobuf fstring log mem misc mt nvtp ph proc \
+ random smtp sock tn url xml
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/src/${M}/Makefile.am
+.endfor
+.for M in framework/application framework/application/src test
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/util/${M}/Makefile.am
+.endfor
+.for M in smtp
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/examples/${M}/Makefile.am
+.endfor
+ ${PERL} -pi -e "s@autoheader,@${AUTOHEADER},@g" ${WRKSRC}/aclocal.m4
post-install:
.if !defined(NOPORTDOCS)