aboutsummaryrefslogtreecommitdiff
path: root/devel/flyspray
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-20 20:47:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-20 20:47:01 +0000
commita398973b7268c184e85e6954364cc6657b38da8a (patch)
treeb1d5af2105210de4dd0fcdcc671af0bdef785dbc /devel/flyspray
parentd7424b369cb3e879730af9cc1eecc768d3e81336 (diff)
Notes
Diffstat (limited to 'devel/flyspray')
-rw-r--r--devel/flyspray/Makefile30
-rw-r--r--devel/flyspray/distinfo4
-rw-r--r--devel/flyspray/files/patch-header.php18
-rw-r--r--devel/flyspray/pkg-message30
-rw-r--r--devel/flyspray/pkg-plist97
5 files changed, 119 insertions, 60 deletions
diff --git a/devel/flyspray/Makefile b/devel/flyspray/Makefile
index 0cc6a2331de0..e17d612b70ac 100644
--- a/devel/flyspray/Makefile
+++ b/devel/flyspray/Makefile
@@ -6,34 +6,36 @@
#
PORTNAME= flyspray
-PORTVERSION= 0.9.4
+PORTVERSION= 0.9.5
CATEGORIES= devel
MASTER_SITES= http://flyspray.rocks.cc/files/
MAINTAINER= nick@foobar.org
COMMENT= A simple, easy-to-use web based bug tracking system
-.if defined(WITH_APACHE2)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache2/libphp4.so:${PORTSDIR}/www/mod_php4
-.else
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
-.endif
+RUN_DEPENDS= ${LOCALBASE}/share/adodb/adodb.inc.php:${PORTSDIR}/databases/adodb
+
+USE_PHP= mysql pcre session
+WANT_PHP_WEB= yes
+
+NO_BUILD= yes
-NO_BUILD= yes
+DBDIR= /var/db
-DOC_FILES= AUTHORS BUGS CHANGELOG COPYING INSTALL README TODO UPGRADING flyspray-${PORTVERSION}.sql
+DOC_FILES= AUTHORS BUGS CHANGELOG COPYING INSTALL README TODO UPGRADING sql/flyspray-${PORTVERSION}.mysql
+FLYSPRAY_FILES= favicon.ico functions.inc.php functions.js index.php lang scripts themes regexp.php sql/upgrade_0.9.4_to_0.9.5-mysql.php
do-install:
${MKDIR} ${PREFIX}/share/${PORTNAME}
${CHMOD} 755 ${PREFIX}/share/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/config.inc.php ${PREFIX}/share/${PORTNAME}/config.inc.php-dist
+ ${INSTALL_DATA} ${WRKSRC}/header.php ${PREFIX}/share/${PORTNAME}/header.php-dist
cd ${WRKSRC} && \
- tar cf - favicon.ico functions.inc.php functions.js header.php index.php lang scripts themes | \
+ tar cf - ${FLYSPRAY_FILES} | \
(cd ${PREFIX}/share/${PORTNAME} && tar -xf -)
- ${LN} -s /var/db/${PORTNAME}/attachments ${PREFIX}/share/${PORTNAME}/attachments
- ${MKDIR} /var/db/${PORTNAME}/attachments
- ${CHMOD} 750 /var/db/${PORTNAME}/attachments
- ${CHOWN} www:www /var/db/${PORTNAME}/attachments
+ ${LN} -s ${DBDIR}/${PORTNAME}/attachments ${PREFIX}/share/${PORTNAME}/attachments
+ ${MKDIR} ${DBDIR}/${PORTNAME}/attachments
+ ${CHMOD} 750 ${DBDIR}/${PORTNAME}/attachments
+ ${CHOWN} www:www ${DBDIR}/${PORTNAME}/attachments
post-install: install-doc
@${CAT} ${PKGMESSAGE}
diff --git a/devel/flyspray/distinfo b/devel/flyspray/distinfo
index 719fff98deed..d2e90b55fbf9 100644
--- a/devel/flyspray/distinfo
+++ b/devel/flyspray/distinfo
@@ -1,2 +1,2 @@
-MD5 (flyspray-0.9.4.tar.gz) = c42e69dc6f3fac707ec9ddf900e7f62b
-SIZE (flyspray-0.9.4.tar.gz) = 112418
+MD5 (flyspray-0.9.5.tar.gz) = efb1c68721f43aca3b47076b5da27442
+SIZE (flyspray-0.9.5.tar.gz) = 134612
diff --git a/devel/flyspray/files/patch-header.php b/devel/flyspray/files/patch-header.php
new file mode 100644
index 000000000000..465790fe1731
--- /dev/null
+++ b/devel/flyspray/files/patch-header.php
@@ -0,0 +1,18 @@
+--- header.php.orig Fri Feb 20 02:49:20 2004
++++ header.php Fri Aug 20 12:34:04 2004
+@@ -2,13 +2,13 @@
+
+ // Directory with Flyspray scripts. It's the directory where this file is
+ // located.
+-$basedir = '/var/www/flyspray';
++$basedir = '/usr/local/share/flyspray';
+
+ // Flyspray uses ADODB for database access. You will need to install
+ // it somewhere on your server for Flyspray to function. It can be installed
+ // inside the Flyspray directory if you wish. The next line needs to be the
+ // correct path to your adodb.inc.php file.
+-include_once ( "/usr/share/adodb/adodb.inc.php" );
++include_once ( "/usr/local/share/adodb/adodb.inc.php" );
+
+ // Modify this next line to reflect the correct path to your Flyspray
+ // functions.inc.php file.
diff --git a/devel/flyspray/pkg-message b/devel/flyspray/pkg-message
index 0d2b8736f7af..b6127e72507d 100644
--- a/devel/flyspray/pkg-message
+++ b/devel/flyspray/pkg-message
@@ -3,20 +3,24 @@
Configuration Instructions for Flyspray
=======================================
-1) Create a mysql database for Flyspray to use. Here is one way to
-do that, from the command line, entering your mysql root password when
+1) Create a mysql database for Flyspray to use. Here is one way to do that,
+from the unix/linux command line, entering your mysql root password when
prompted:
# mysqladmin -u root -p create flyspray
-2) Import the Flyspray database tables into your new empty
-database. Here is the command line method; be sure to enter your mysql root
+2) Import the Flyspray database tables into your new empty database. Here is
+the unix/linux command line method; be sure to enter your mysql root
password when prompted:
# mysql -u root -p flyspray < flyspray-version.sql
-3) Copy the config.inc.php-dist file to config.inc.php and edit it to suit
-your database setup. Examples are provided in the file.
+3) Edit the header.php file to suit your database setup. Examples are
+provided in the file. You will need to set your database type to an ADODB
+supported database, your database username and password, and the host the
+database server runs on. You will also need to enter the location of the
+adodb.inc.php file and functions.inc.php file. Consider changing the cookie
+salt value as well.
4) Insert the following configuration command into your httpd.conf:
@@ -25,15 +29,23 @@ your database setup. Examples are provided in the file.
5) Point your browser to http://yourserver.com/flyspray/ and you should
see Flyspray! Login as 'super', with the password 'super'.
-6) Create youself a new user, place them into the Admin group.
+6) Create youself a new user, and put this user into the Admin group.
7) CHANGE THE PASSWORD FOR THE super/super ACCOUNT by clicking the
'Change Password' link near the top of the page. You might like to disable
the account entirely, or it will appear in the list of members to be assigned
tasks.
-8) Close the sample task, and begin adding your own.
+8) Click on the admin links to set up your Options and lists.
-9) Report any bugs you find back to http://flyspray.rocks.cc/bts/
+9) Close the sample task, and begin adding your own.
+
+10) Report any bugs you find back to http://flyspray.rocks.cc/bts/ or the
+mailing list linked from the Flyspray homepage.
+
+11) If you are upgrading from flyspray 0.9.4, please use your browser to
+open the URL:
+
+http://yourserver.com/flyspray/sql/upgrade_0.9.4_to_0.9.5-mysql.php
##
diff --git a/devel/flyspray/pkg-plist b/devel/flyspray/pkg-plist
index c1473a6e09be..be8e77d5ce04 100644
--- a/devel/flyspray/pkg-plist
+++ b/devel/flyspray/pkg-plist
@@ -1,10 +1,10 @@
share/flyspray/attachments
-share/flyspray/config.inc.php-dist
share/flyspray/favicon.ico
share/flyspray/functions.inc.php
share/flyspray/functions.js
-share/flyspray/header.php
+share/flyspray/header.php-dist
share/flyspray/index.php
+share/flyspray/regexp.php
share/flyspray/lang/de/admin.php
share/flyspray/lang/de/authenticate.php
share/flyspray/lang/de/chpass.php
@@ -15,6 +15,7 @@ share/flyspray/lang/de/loginbox.php
share/flyspray/lang/de/main.php
share/flyspray/lang/de/modify.php
share/flyspray/lang/de/newgroup.php
+share/flyspray/lang/de/newproject.php
share/flyspray/lang/de/newtask.php
share/flyspray/lang/de/newuser.php
share/flyspray/lang/de/register.php
@@ -30,52 +31,75 @@ share/flyspray/lang/en/loginbox.php
share/flyspray/lang/en/main.php
share/flyspray/lang/en/modify.php
share/flyspray/lang/en/newgroup.php
+share/flyspray/lang/en/newproject.php
share/flyspray/lang/en/newtask.php
share/flyspray/lang/en/newuser.php
share/flyspray/lang/en/register.php
share/flyspray/lang/en/severity.php
share/flyspray/lang/en/status.php
-share/flyspray/lang/fr/admin.php
-share/flyspray/lang/fr/authenticate.php
-share/flyspray/lang/fr/chpass.php
-share/flyspray/lang/fr/details.php
-share/flyspray/lang/fr/functions.inc.php
-share/flyspray/lang/fr/index.php
-share/flyspray/lang/fr/loginbox.php
-share/flyspray/lang/fr/main.php
-share/flyspray/lang/fr/modify.php
-share/flyspray/lang/fr/newgroup.php
-share/flyspray/lang/fr/newtask.php
-share/flyspray/lang/fr/newuser.php
-share/flyspray/lang/fr/register.php
-share/flyspray/lang/fr/severity.php
-share/flyspray/lang/fr/status.php
-share/flyspray/lang/nl/admin.php
-share/flyspray/lang/nl/authenticate.php
-share/flyspray/lang/nl/chpass.php
-share/flyspray/lang/nl/details.php
-share/flyspray/lang/nl/functions.inc.php
-share/flyspray/lang/nl/index.php
-share/flyspray/lang/nl/loginbox.php
-share/flyspray/lang/nl/main.php
-share/flyspray/lang/nl/modify.php
-share/flyspray/lang/nl/newgroup.php
-share/flyspray/lang/nl/newtask.php
-share/flyspray/lang/nl/newuser.php
-share/flyspray/lang/nl/register.php
-share/flyspray/lang/nl/severity.php
-share/flyspray/lang/nl/status.php
+share/flyspray/lang/it/newgroup.php
+share/flyspray/lang/it/index.php
+share/flyspray/lang/it/severity.php
+share/flyspray/lang/it/newtask.php
+share/flyspray/lang/it/authenticate.php
+share/flyspray/lang/it/newproject.php
+share/flyspray/lang/it/functions.inc.php
+share/flyspray/lang/it/loginbox.php
+share/flyspray/lang/it/chpass.php
+share/flyspray/lang/it/status.php
+share/flyspray/lang/it/main.php
+share/flyspray/lang/it/register.php
+share/flyspray/lang/it/details.php
+share/flyspray/lang/it/modify.php
+share/flyspray/lang/it/newuser.php
+share/flyspray/lang/it/admin.php
+share/flyspray/lang/pl/newgroup.php
+share/flyspray/lang/pl/index.php
+share/flyspray/lang/pl/severity.php
+share/flyspray/lang/pl/newtask.php
+share/flyspray/lang/pl/authenticate.php
+share/flyspray/lang/pl/functions.inc.php
+share/flyspray/lang/pl/newproject.php
+share/flyspray/lang/pl/loginbox.php
+share/flyspray/lang/pl/chpass.php
+share/flyspray/lang/pl/status.php
+share/flyspray/lang/pl/register.php
+share/flyspray/lang/pl/main.php
+share/flyspray/lang/pl/details.php
+share/flyspray/lang/pl/modify.php
+share/flyspray/lang/pl/newuser.php
+share/flyspray/lang/pl/admin.php
+share/flyspray/lang/ptbr/newgroup.php
+share/flyspray/lang/ptbr/index.php
+share/flyspray/lang/ptbr/severity.php
+share/flyspray/lang/ptbr/newtask.php
+share/flyspray/lang/ptbr/authenticate.php
+share/flyspray/lang/ptbr/newproject.php
+share/flyspray/lang/ptbr/functions.inc.php
+share/flyspray/lang/ptbr/loginbox.php
+share/flyspray/lang/ptbr/chpass.php
+share/flyspray/lang/ptbr/status.php
+share/flyspray/lang/ptbr/register.php
+share/flyspray/lang/ptbr/main.php
+share/flyspray/lang/ptbr/readme.txt
+share/flyspray/lang/ptbr/details.php
+share/flyspray/lang/ptbr/modify.php
+share/flyspray/lang/ptbr/newuser.php
+share/flyspray/lang/ptbr/admin.php
share/flyspray/scripts/admin.php
share/flyspray/scripts/authenticate.php
share/flyspray/scripts/chpass.php
+share/flyspray/scripts/chproject.php
share/flyspray/scripts/details.php
share/flyspray/scripts/index.php
share/flyspray/scripts/loginbox.php
share/flyspray/scripts/modify.php
share/flyspray/scripts/newgroup.php
+share/flyspray/scripts/newproject.php
share/flyspray/scripts/newtask.php
share/flyspray/scripts/newuser.php
share/flyspray/scripts/register.php
+share/flyspray/sql/upgrade_0.9.4_to_0.9.5-mysql.php
share/flyspray/themes/Bluey/button.png
share/flyspray/themes/Bluey/index.html
share/flyspray/themes/Bluey/percent-0.png
@@ -109,6 +133,7 @@ share/flyspray/themes/Woodgrain/percent-70.png
share/flyspray/themes/Woodgrain/percent-80.png
share/flyspray/themes/Woodgrain/percent-90.png
share/flyspray/themes/Woodgrain/theme.css
+share/flyspray/themes/Woodgrain/title.png
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
@@ -117,17 +142,19 @@ share/flyspray/themes/Woodgrain/theme.css
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
-%%PORTDOCS%%%%DOCSDIR%%/flyspray-0.9.4.sql
+%%PORTDOCS%%%%DOCSDIR%%/flyspray-0.9.5.mysql
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/flyspray/lang/en
@dirrm share/flyspray/lang/de
-@dirrm share/flyspray/lang/fr
-@dirrm share/flyspray/lang/nl
+@dirrm share/flyspray/lang/it
+@dirrm share/flyspray/lang/pl
+@dirrm share/flyspray/lang/ptbr
@dirrm share/flyspray/lang
@dirrm share/flyspray/themes/Bluey
@dirrm share/flyspray/themes/Woodgrain
@dirrm share/flyspray/themes
@dirrm share/flyspray/scripts
+@dirrm share/flyspray/sql
@dirrm share/flyspray
@unexec rmdir /var/db/flyspray/attachments 2>/dev/null || true
@unexec rmdir /var/db/flyspray 2>/dev/null || true