aboutsummaryrefslogtreecommitdiff
path: root/devel/fnorb
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-09-04 14:20:31 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-09-04 14:20:31 +0000
commit558caa64deefdade9ec80bfc17eaa43bb72a0760 (patch)
tree26044741036a75e204d22429a35a194f81dc2d8a /devel/fnorb
parentbfa9be96b2f17de58037d4146ca5c9e12e3a0bb1 (diff)
downloadports-558caa64deefdade9ec80bfc17eaa43bb72a0760.tar.gz
ports-558caa64deefdade9ec80bfc17eaa43bb72a0760.zip
Notes
Diffstat (limited to 'devel/fnorb')
-rw-r--r--devel/fnorb/Makefile33
-rw-r--r--devel/fnorb/files/patch-aa2
-rw-r--r--devel/fnorb/pkg-descr2
-rw-r--r--devel/fnorb/pkg-plist110
4 files changed, 74 insertions, 73 deletions
diff --git a/devel/fnorb/Makefile b/devel/fnorb/Makefile
index ce0f6cfcf65f..5a691bb5a6ff 100644
--- a/devel/fnorb/Makefile
+++ b/devel/fnorb/Makefile
@@ -7,13 +7,15 @@
PORTNAME= fnorb
PORTVERSION= 1.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel python
MASTER_SITES= http://www.fnorb.org/download/ \
ftp://ftp.dstc.edu.au/DSTC/fnorb/
MAINTAINER= wjv@FreeBSD.org
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
NO_CDROM= Free for academic, research and non-commercial purposes only
WRKSRC= ${WRKDIR}/Fnorb-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src
@@ -22,15 +24,14 @@ USE_PYTHON= yes
ALL_TARGET=
CPIO= cpio --quiet -pdum -R
-FNORB_DIR= ${PYTHON_SITELIBDIR}/Fnorb
-FNORB_EGDIR= ${PREFIX}/share/examples/fnorb
-FNORB_DOCDIR= ${PREFIX}/share/doc/fnorb
+FNORB_DIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/Fnorb
+EXAMPLESDIR= ${PREFIX}/share/examples/fnorb
FNORB_BINS= fnaming fnendian fnfeed fngen fnidl fnifr fnior fnlogger \
fnmetrics fnmkior fnoptions fnping
do-configure:
- @ (cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
- Makefile.pre.in boot)
+ @ cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ Makefile.pre.in boot
post-build:
@ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -f ${WRKSRC}
@@ -38,25 +39,25 @@ post-build:
post-install:
@ ${MKDIR} ${FNORB_DIR}/script
- @ (cd ${WRKSRC} && find *.py *.pyc *.pyo compiler cos orb parser \
+ @ cd ${WRKSRC} && find *.py *.pyc *.pyo compiler cos orb parser \
script/*.py script/*.pyc script/*.pyo \! -name \*.orig \
- | ${CPIO} ${BINOWN}:${BINGRP} ${FNORB_DIR})
+ | ${CPIO} ${BINOWN}:${BINGRP} ${FNORB_DIR}
@ ${MKDIR} ${PREFIX}/bin
.for fnscript in ${FNORB_BINS}
@ ${INSTALL_SCRIPT} ${WRKSRC}/script/${fnscript} ${PREFIX}/bin
.endfor
@ ${INSTALL_DATA} ${WRKSRC}/etc/fnorb.cfg \
${PREFIX}/etc/fnorb.cfg.sample
- @ ${MKDIR} ${FNORB_EGDIR}
- @ (cd ${WRKSRC}/examples && find * \
- | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${FNORB_EGDIR})
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${FNORB_DOCDIR}
- @ (cd ${WRKSRC}/doc && find . \
- | ${CPIO} ${MANOWN}:${MANGRP} ${FNORB_DOCDIR})
- @ (${CHMOD} -R u-x ${FNORB_DOCDIR} && ${CHMOD} -R u+X ${FNORB_DOCDIR})
+ @ ${MKDIR} ${EXAMPLESDIR}
+ @ cd ${WRKSRC}/examples && find * \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+ @ ${MKDIR} ${DOCSDIR}
+ @ cd ${WRKSRC}/doc && find . \
+ | ${CPIO} ${MANOWN}:${MANGRP} ${DOCSDIR}
+ @ ${CHMOD} -R u-x ${DOCSDIR} && ${CHMOD} -R u+X ${DOCSDIR}
.for file in ANNOUNCE CHANGES README LICENSE.HTML
- @ ${INSTALL_MAN} ${WRKSRC}/${file} ${FNORB_DOCDIR}
+ @ ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/devel/fnorb/files/patch-aa b/devel/fnorb/files/patch-aa
index a3b8da3ceb5a..477164e4779f 100644
--- a/devel/fnorb/files/patch-aa
+++ b/devel/fnorb/files/patch-aa
@@ -3,7 +3,7 @@ release of Fnorb. (Caveat: There may be more broken calls.)
Thanks to Mike Meyer <mwm@mired.org>, Brad Chapman <chapmanb@arches.uga.edu>.
--- Johann <johann@egenetics.com>
+-- Johann <wjv@FreeBSD.org>
--- orb/IIOPConnection.py.orig Mon Apr 3 16:08:34 2000
diff --git a/devel/fnorb/pkg-descr b/devel/fnorb/pkg-descr
index baed440f6ffb..9e97b1b5a468 100644
--- a/devel/fnorb/pkg-descr
+++ b/devel/fnorb/pkg-descr
@@ -17,4 +17,4 @@ site for licensing updates or further information.
WWW: http://www.fnorb.org/
--- Johann Visagie <johann@egenetics.com>
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/devel/fnorb/pkg-plist b/devel/fnorb/pkg-plist
index 3932fbc5c425..825aaef99ae2 100644
--- a/devel/fnorb/pkg-plist
+++ b/devel/fnorb/pkg-plist
@@ -80,6 +80,54 @@
%%PORTDOCS%%share/doc/fnorb/Fnorb-Guide/up_motif_gr.gif
%%PORTDOCS%%share/doc/fnorb/LICENSE.HTML
%%PORTDOCS%%share/doc/fnorb/README
+%%PORTDOCS%%share/examples/fnorb/hello-world/HelloWorld.idl
+%%PORTDOCS%%share/examples/fnorb/hello-world/README
+%%PORTDOCS%%share/examples/fnorb/hello-world/client.py
+%%PORTDOCS%%share/examples/fnorb/hello-world/client.pyc
+%%PORTDOCS%%share/examples/fnorb/hello-world/client.pyo
+%%PORTDOCS%%share/examples/fnorb/hello-world/server.py
+%%PORTDOCS%%share/examples/fnorb/hello-world/server.pyc
+%%PORTDOCS%%share/examples/fnorb/hello-world/server.pyo
+%%PORTDOCS%%share/examples/fnorb/misc/Example.idl
+%%PORTDOCS%%share/examples/fnorb/misc/README
+%%PORTDOCS%%share/examples/fnorb/misc/client.py
+%%PORTDOCS%%share/examples/fnorb/misc/client.pyc
+%%PORTDOCS%%share/examples/fnorb/misc/client.pyo
+%%PORTDOCS%%share/examples/fnorb/misc/server.py
+%%PORTDOCS%%share/examples/fnorb/misc/server.pyc
+%%PORTDOCS%%share/examples/fnorb/misc/server.pyo
+%%PORTDOCS%%share/examples/fnorb/naming/README
+%%PORTDOCS%%share/examples/fnorb/naming/Thermometer.idl
+%%PORTDOCS%%share/examples/fnorb/naming/client.py
+%%PORTDOCS%%share/examples/fnorb/naming/client.pyc
+%%PORTDOCS%%share/examples/fnorb/naming/client.pyo
+%%PORTDOCS%%share/examples/fnorb/naming/server.py
+%%PORTDOCS%%share/examples/fnorb/naming/server.pyc
+%%PORTDOCS%%share/examples/fnorb/naming/server.pyo
+%%PORTDOCS%%share/examples/fnorb/threaded/HelloWorld.idl
+%%PORTDOCS%%share/examples/fnorb/threaded/README
+%%PORTDOCS%%share/examples/fnorb/threaded/client.py
+%%PORTDOCS%%share/examples/fnorb/threaded/client.pyc
+%%PORTDOCS%%share/examples/fnorb/threaded/client.pyo
+%%PORTDOCS%%share/examples/fnorb/threaded/server.py
+%%PORTDOCS%%share/examples/fnorb/threaded/server.pyc
+%%PORTDOCS%%share/examples/fnorb/threaded/server.pyo
+%%PORTDOCS%%share/examples/fnorb/tkinter/README
+%%PORTDOCS%%share/examples/fnorb/tkinter/TicToc.idl
+%%PORTDOCS%%share/examples/fnorb/tkinter/client.py
+%%PORTDOCS%%share/examples/fnorb/tkinter/client.pyc
+%%PORTDOCS%%share/examples/fnorb/tkinter/client.pyo
+%%PORTDOCS%%share/examples/fnorb/tkinter/server.py
+%%PORTDOCS%%share/examples/fnorb/tkinter/server.pyc
+%%PORTDOCS%%share/examples/fnorb/tkinter/server.pyo
+%%PORTDOCS%%share/examples/fnorb/unions/README
+%%PORTDOCS%%share/examples/fnorb/unions/Unions.idl
+%%PORTDOCS%%share/examples/fnorb/unions/client.py
+%%PORTDOCS%%share/examples/fnorb/unions/client.pyc
+%%PORTDOCS%%share/examples/fnorb/unions/client.pyo
+%%PORTDOCS%%share/examples/fnorb/unions/server.py
+%%PORTDOCS%%share/examples/fnorb/unions/server.pyc
+%%PORTDOCS%%share/examples/fnorb/unions/server.pyo
bin/fnaming
bin/fnendian
bin/fnfeed
@@ -304,61 +352,6 @@ lib/%%PYTHON_VERSION%%/site-packages/Fnorb/script/fnidl.pyc
lib/%%PYTHON_VERSION%%/site-packages/Fnorb/script/fnidl.pyo
lib/%%PYTHON_VERSION%%/site-packages/bisonmodule.so
lib/%%PYTHON_VERSION%%/site-packages/cdrmodule.so
-share/examples/fnorb/hello-world/HelloWorld.idl
-share/examples/fnorb/hello-world/README
-share/examples/fnorb/hello-world/client.py
-share/examples/fnorb/hello-world/client.pyc
-share/examples/fnorb/hello-world/client.pyo
-share/examples/fnorb/hello-world/server.py
-share/examples/fnorb/hello-world/server.pyc
-share/examples/fnorb/hello-world/server.pyo
-share/examples/fnorb/misc/Example.idl
-share/examples/fnorb/misc/README
-share/examples/fnorb/misc/client.py
-share/examples/fnorb/misc/client.pyc
-share/examples/fnorb/misc/client.pyo
-share/examples/fnorb/misc/server.py
-share/examples/fnorb/misc/server.pyc
-share/examples/fnorb/misc/server.pyo
-share/examples/fnorb/naming/README
-share/examples/fnorb/naming/Thermometer.idl
-share/examples/fnorb/naming/client.py
-share/examples/fnorb/naming/client.pyc
-share/examples/fnorb/naming/client.pyo
-share/examples/fnorb/naming/server.py
-share/examples/fnorb/naming/server.pyc
-share/examples/fnorb/naming/server.pyo
-share/examples/fnorb/threaded/HelloWorld.idl
-share/examples/fnorb/threaded/README
-share/examples/fnorb/threaded/client.py
-share/examples/fnorb/threaded/client.pyc
-share/examples/fnorb/threaded/client.pyo
-share/examples/fnorb/threaded/server.py
-share/examples/fnorb/threaded/server.pyc
-share/examples/fnorb/threaded/server.pyo
-share/examples/fnorb/tkinter/README
-share/examples/fnorb/tkinter/TicToc.idl
-share/examples/fnorb/tkinter/client.py
-share/examples/fnorb/tkinter/client.pyc
-share/examples/fnorb/tkinter/client.pyo
-share/examples/fnorb/tkinter/server.py
-share/examples/fnorb/tkinter/server.pyc
-share/examples/fnorb/tkinter/server.pyo
-share/examples/fnorb/unions/README
-share/examples/fnorb/unions/Unions.idl
-share/examples/fnorb/unions/client.py
-share/examples/fnorb/unions/client.pyc
-share/examples/fnorb/unions/client.pyo
-share/examples/fnorb/unions/server.py
-share/examples/fnorb/unions/server.pyc
-share/examples/fnorb/unions/server.pyo
-@dirrm share/examples/fnorb/unions
-@dirrm share/examples/fnorb/tkinter
-@dirrm share/examples/fnorb/threaded
-@dirrm share/examples/fnorb/naming
-@dirrm share/examples/fnorb/misc
-@dirrm share/examples/fnorb/hello-world
-@dirrm share/examples/fnorb
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/script
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/parser
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/orb
@@ -371,5 +364,12 @@ share/examples/fnorb/unions/server.pyo
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/cos
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/compiler
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb
+%%PORTDOCS%%@dirrm share/examples/fnorb/unions
+%%PORTDOCS%%@dirrm share/examples/fnorb/tkinter
+%%PORTDOCS%%@dirrm share/examples/fnorb/threaded
+%%PORTDOCS%%@dirrm share/examples/fnorb/naming
+%%PORTDOCS%%@dirrm share/examples/fnorb/misc
+%%PORTDOCS%%@dirrm share/examples/fnorb/hello-world
+%%PORTDOCS%%@dirrm share/examples/fnorb
%%PORTDOCS%%@dirrm share/doc/fnorb/Fnorb-Guide
%%PORTDOCS%%@dirrm share/doc/fnorb