aboutsummaryrefslogtreecommitdiff
path: root/devel/fnorb
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-11-08 12:52:04 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-11-08 12:52:04 +0000
commit1ba9ed7c4487c36ceb2667b0050b0ca436552e75 (patch)
tree28e92486412e3ca4985ae89b0428cb4ae6371e2b /devel/fnorb
parent87e6d3060f05f5181c92f2e1485e0521badce2e1 (diff)
downloadports-1ba9ed7c4487c36ceb2667b0050b0ca436552e75.tar.gz
ports-1ba9ed7c4487c36ceb2667b0050b0ca436552e75.zip
Notes
Diffstat (limited to 'devel/fnorb')
-rw-r--r--devel/fnorb/Makefile2
-rw-r--r--devel/fnorb/files/patch-aa20
2 files changed, 21 insertions, 1 deletions
diff --git a/devel/fnorb/Makefile b/devel/fnorb/Makefile
index 624c2cf251ed..e9fd0d2434de 100644
--- a/devel/fnorb/Makefile
+++ b/devel/fnorb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fnorb
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= http://www.fnorb.org/download/ \
ftp://ftp.dstc.edu.au/DSTC/fnorb/
diff --git a/devel/fnorb/files/patch-aa b/devel/fnorb/files/patch-aa
new file mode 100644
index 000000000000..a3f429d9609b
--- /dev/null
+++ b/devel/fnorb/files/patch-aa
@@ -0,0 +1,20 @@
+Allow the port to work with Python 2.0. This should be fixed in the next
+release of Fnorb. (Caveat: There may be more broken calls to
+socket.connect.)
+
+Thanks to Mike Meyer <mwm@mired.org> for submitting this.
+
+-- Johann <johann@egenetics.com>
+
+
+--- ../orb/IIOPConnection.py.orig Mon Apr 3 16:08:34 2000
++++ ../orb/IIOPConnection.py Mon Nov 6 11:12:49 2000
+@@ -88,7 +88,7 @@
+ # Create a socket and connect to the remote object.
+ try:
+ self.__socket = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
+- self.__socket.connect(host, port)
++ self.__socket.connect((host, port))
+
+ # Set the socket by default to NON-blocking mode.
+ self.__socket.setblocking(0)