aboutsummaryrefslogtreecommitdiff
path: root/devel/fnorb
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-24 15:14:05 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-24 15:14:05 +0000
commitd9d21683ae3b2f905f2508705943c6a81f3b821b (patch)
tree15037fb4196ceba0122883f0d8d9b7af7d1603ea /devel/fnorb
parentb6cb7406493ab3a7df8268e80840c871ed356127 (diff)
downloadports-d9d21683ae3b2f905f2508705943c6a81f3b821b.tar.gz
ports-d9d21683ae3b2f905f2508705943c6a81f3b821b.zip
Notes
Diffstat (limited to 'devel/fnorb')
-rw-r--r--devel/fnorb/Makefile35
-rw-r--r--devel/fnorb/files/patch-aa12
-rw-r--r--devel/fnorb/pkg-plist85
3 files changed, 26 insertions, 106 deletions
diff --git a/devel/fnorb/Makefile b/devel/fnorb/Makefile
index 67a1f187e25b..19e10d1e19cc 100644
--- a/devel/fnorb/Makefile
+++ b/devel/fnorb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fnorb
PORTVERSION= 1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel python
MASTER_SITES= http://www.fnorb.org/download/ \
ftp://ftp.dstc.edu.au/DSTC/fnorb/
@@ -15,36 +15,39 @@ MASTER_SITES= http://www.fnorb.org/download/ \
MAINTAINER= johann@egenetics.com
NO_CDROM= Free for academic, research and non-commercial purposes only
-WRKSRC= ${WRKDIR}/Fnorb-${PORTVERSION}/src
+WRKSRC= ${WRKDIR}/Fnorb-${PORTVERSION}
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
USE_PYTHON= yes
ALL_TARGET=
-do-configure:
- @ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
- Makefile.pre.in boot)
-
+CPIO= cpio --quiet -pdum -R
FNORB_DIR= ${PYTHON_SITELIBDIR}/Fnorb
FNORB_SHAREDIR= ${PREFIX}/share/fnorb
FNORB_DOCDIR= ${PREFIX}/share/doc/fnorb
+do-configure:
+ @ (cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ Makefile.pre.in boot)
+
post-install:
@ ${MKDIR} ${FNORB_DIR}
- @ (cd ${WRKSRC}/../ && find *.py compiler cos orb parser \
- | cpio --quiet -pdum -R ${BINOWN}:${BINGRP} ${FNORB_DIR})
- @ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${FNORB_DIR}
- @ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${FNORB_DIR}
+ @ (cd ${WRKSRC} && find *.py compiler cos orb parser \! -name \*.orig \
+ | ${CPIO} ${BINOWN}:${BINGRP} ${FNORB_DIR})
+ @ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -f ${FNORB_DIR}
+ @ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -f ${FNORB_DIR}
@ ${MKDIR} ${FNORB_SHAREDIR}
- @ (cd ${WRKSRC}/../ && find script examples \! -name \*.bat \
- | cpio --quiet -pdum -R ${SHAREOWN}:${SHAREGRP} ${FNORB_SHAREDIR})
- @ ${INSTALL_DATA} ${WRKSRC}/../etc/fnorb.cfg \
+ @ (cd ${WRKSRC} && find script examples \! -name \*.bat \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${FNORB_SHAREDIR})
+ @ ${INSTALL_DATA} ${WRKSRC}/etc/fnorb.cfg \
${PREFIX}/etc/fnorb.cfg.sample
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${FNORB_DOCDIR}
- @ (cd ${WRKSRC}/../doc && find . \
- | cpio --quiet -pdum -R ${MANOWN}:${MANGRP} ${FNORB_DOCDIR})
+ @ (cd ${WRKSRC}/doc && find . \
+ | ${CPIO} ${MANOWN}:${MANGRP} ${FNORB_DOCDIR})
@ (${CHMOD} -R u-x ${FNORB_DOCDIR} && ${CHMOD} -R u+X ${FNORB_DOCDIR})
.for file in ANNOUNCE CHANGES README LICENSE.HTML
- @ ${INSTALL_MAN} ${WRKSRC}/../${file} ${FNORB_DOCDIR}
+ @ ${INSTALL_MAN} ${WRKSRC}/${file} ${FNORB_DOCDIR}
.endfor
.endif
diff --git a/devel/fnorb/files/patch-aa b/devel/fnorb/files/patch-aa
index e88e22c99830..a3b8da3ceb5a 100644
--- a/devel/fnorb/files/patch-aa
+++ b/devel/fnorb/files/patch-aa
@@ -6,8 +6,8 @@ Thanks to Mike Meyer <mwm@mired.org>, Brad Chapman <chapmanb@arches.uga.edu>.
-- Johann <johann@egenetics.com>
---- ../orb/IIOPConnection.py.orig Mon Apr 3 16:08:34 2000
-+++ ../orb/IIOPConnection.py Mon Nov 6 11:12:49 2000
+--- orb/IIOPConnection.py.orig Mon Apr 3 16:08:34 2000
++++ orb/IIOPConnection.py Mon Nov 6 11:12:49 2000
@@ -88,7 +88,7 @@
# Create a socket and connect to the remote object.
try:
@@ -17,8 +17,8 @@ Thanks to Mike Meyer <mwm@mired.org>, Brad Chapman <chapmanb@arches.uga.edu>.
# Set the socket by default to NON-blocking mode.
self.__socket.setblocking(0)
---- ../orb/IIOPAcceptor.py.orig Mon Apr 3 16:08:34 2000
-+++ ../orb/IIOPAcceptor.py Wed Nov 8 15:06:29 2000
+--- orb/IIOPAcceptor.py.orig Mon Apr 3 16:08:34 2000
++++ orb/IIOPAcceptor.py Wed Nov 8 15:06:29 2000
@@ -65,7 +65,7 @@
try:
# Create a socket on which to listen for connection requests.
@@ -28,8 +28,8 @@ Thanks to Mike Meyer <mwm@mired.org>, Brad Chapman <chapmanb@arches.uga.edu>.
self.__socket.listen(5)
# Get the host name, the IP address and the port number of the
---- ../orb/Nudger.py.orig Mon Apr 3 16:08:34 2000
-+++ ../orb/Nudger.py Wed Nov 8 15:06:50 2000
+--- orb/Nudger.py.orig Mon Apr 3 16:08:34 2000
++++ orb/Nudger.py Wed Nov 8 15:06:50 2000
@@ -54,7 +54,7 @@
try:
# Create a socket on which to listen for connection requests.
diff --git a/devel/fnorb/pkg-plist b/devel/fnorb/pkg-plist
index 5b77f4f621d6..234f2f6223cd 100644
--- a/devel/fnorb/pkg-plist
+++ b/devel/fnorb/pkg-plist
@@ -201,88 +201,6 @@ lib/%%PYTHON_VERSION%%/site-packages/Fnorb/parser/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/Fnorb/parser/__init__.pyo
lib/%%PYTHON_VERSION%%/site-packages/bisonmodule.so
lib/%%PYTHON_VERSION%%/site-packages/cdrmodule.so
-share/doc/fnorb/ANNOUNCE
-share/doc/fnorb/CHANGES
-share/doc/fnorb/Fnorb-Guide.pdf
-share/doc/fnorb/Fnorb-Guide.ps
-share/doc/fnorb/Fnorb-Guide/Fnorb-Guide.css
-share/doc/fnorb/Fnorb-Guide/Fnorb-Guide.html
-share/doc/fnorb/Fnorb-Guide/contents_motif.gif
-share/doc/fnorb/Fnorb-Guide/cross_ref_motif.gif
-share/doc/fnorb/Fnorb-Guide/img1.gif
-share/doc/fnorb/Fnorb-Guide/index.html
-share/doc/fnorb/Fnorb-Guide/next_motif.gif
-share/doc/fnorb/Fnorb-Guide/next_motif_gr.gif
-share/doc/fnorb/Fnorb-Guide/node1.html
-share/doc/fnorb/Fnorb-Guide/node10.html
-share/doc/fnorb/Fnorb-Guide/node11.html
-share/doc/fnorb/Fnorb-Guide/node12.html
-share/doc/fnorb/Fnorb-Guide/node13.html
-share/doc/fnorb/Fnorb-Guide/node14.html
-share/doc/fnorb/Fnorb-Guide/node15.html
-share/doc/fnorb/Fnorb-Guide/node16.html
-share/doc/fnorb/Fnorb-Guide/node17.html
-share/doc/fnorb/Fnorb-Guide/node18.html
-share/doc/fnorb/Fnorb-Guide/node19.html
-share/doc/fnorb/Fnorb-Guide/node2.html
-share/doc/fnorb/Fnorb-Guide/node20.html
-share/doc/fnorb/Fnorb-Guide/node21.html
-share/doc/fnorb/Fnorb-Guide/node22.html
-share/doc/fnorb/Fnorb-Guide/node23.html
-share/doc/fnorb/Fnorb-Guide/node24.html
-share/doc/fnorb/Fnorb-Guide/node25.html
-share/doc/fnorb/Fnorb-Guide/node26.html
-share/doc/fnorb/Fnorb-Guide/node27.html
-share/doc/fnorb/Fnorb-Guide/node28.html
-share/doc/fnorb/Fnorb-Guide/node29.html
-share/doc/fnorb/Fnorb-Guide/node3.html
-share/doc/fnorb/Fnorb-Guide/node30.html
-share/doc/fnorb/Fnorb-Guide/node31.html
-share/doc/fnorb/Fnorb-Guide/node32.html
-share/doc/fnorb/Fnorb-Guide/node33.html
-share/doc/fnorb/Fnorb-Guide/node34.html
-share/doc/fnorb/Fnorb-Guide/node35.html
-share/doc/fnorb/Fnorb-Guide/node36.html
-share/doc/fnorb/Fnorb-Guide/node37.html
-share/doc/fnorb/Fnorb-Guide/node38.html
-share/doc/fnorb/Fnorb-Guide/node39.html
-share/doc/fnorb/Fnorb-Guide/node4.html
-share/doc/fnorb/Fnorb-Guide/node40.html
-share/doc/fnorb/Fnorb-Guide/node41.html
-share/doc/fnorb/Fnorb-Guide/node42.html
-share/doc/fnorb/Fnorb-Guide/node43.html
-share/doc/fnorb/Fnorb-Guide/node44.html
-share/doc/fnorb/Fnorb-Guide/node45.html
-share/doc/fnorb/Fnorb-Guide/node46.html
-share/doc/fnorb/Fnorb-Guide/node47.html
-share/doc/fnorb/Fnorb-Guide/node48.html
-share/doc/fnorb/Fnorb-Guide/node49.html
-share/doc/fnorb/Fnorb-Guide/node5.html
-share/doc/fnorb/Fnorb-Guide/node50.html
-share/doc/fnorb/Fnorb-Guide/node51.html
-share/doc/fnorb/Fnorb-Guide/node52.html
-share/doc/fnorb/Fnorb-Guide/node53.html
-share/doc/fnorb/Fnorb-Guide/node54.html
-share/doc/fnorb/Fnorb-Guide/node55.html
-share/doc/fnorb/Fnorb-Guide/node56.html
-share/doc/fnorb/Fnorb-Guide/node57.html
-share/doc/fnorb/Fnorb-Guide/node58.html
-share/doc/fnorb/Fnorb-Guide/node59.html
-share/doc/fnorb/Fnorb-Guide/node6.html
-share/doc/fnorb/Fnorb-Guide/node60.html
-share/doc/fnorb/Fnorb-Guide/node61.html
-share/doc/fnorb/Fnorb-Guide/node62.html
-share/doc/fnorb/Fnorb-Guide/node63.html
-share/doc/fnorb/Fnorb-Guide/node64.html
-share/doc/fnorb/Fnorb-Guide/node7.html
-share/doc/fnorb/Fnorb-Guide/node8.html
-share/doc/fnorb/Fnorb-Guide/node9.html
-share/doc/fnorb/Fnorb-Guide/previous_motif.gif
-share/doc/fnorb/Fnorb-Guide/previous_motif_gr.gif
-share/doc/fnorb/Fnorb-Guide/up_motif.gif
-share/doc/fnorb/Fnorb-Guide/up_motif_gr.gif
-share/doc/fnorb/LICENSE.HTML
-share/doc/fnorb/README
share/fnorb/examples/hello-world/HelloWorld.idl
share/fnorb/examples/hello-world/README
share/fnorb/examples/hello-world/client.py
@@ -331,8 +249,6 @@ share/fnorb/script/fnping
@dirrm share/fnorb/examples/hello-world
@dirrm share/fnorb/examples
@dirrm share/fnorb
-@dirrm share/doc/fnorb/Fnorb-Guide
-@dirrm share/doc/fnorb
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/parser
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/orb
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/cos/naming/CosNaming_skel
@@ -344,3 +260,4 @@ share/fnorb/script/fnping
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/cos
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb/compiler
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Fnorb
+@unexec rm -rf %D/share/doc/fnorb 2>/dev/null || true