aboutsummaryrefslogtreecommitdiff
path: root/devel/fpc-fcl-base
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-06-21 15:47:50 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-06-21 15:47:50 +0000
commit8610755749997ceadc6fb78fc220681320de4548 (patch)
treec2c4635e8d29370124cd3a837ebbc1f271ae83a5 /devel/fpc-fcl-base
parent6811138265d4a31d93dbb79baf1ba77cbb1e4bc4 (diff)
downloadports-8610755749997ceadc6fb78fc220681320de4548.tar.gz
ports-8610755749997ceadc6fb78fc220681320de4548.zip
Notes
Diffstat (limited to 'devel/fpc-fcl-base')
-rw-r--r--devel/fpc-fcl-base/Makefile32
-rw-r--r--devel/fpc-fcl-base/fpc-fcl/Makefile32
2 files changed, 64 insertions, 0 deletions
diff --git a/devel/fpc-fcl-base/Makefile b/devel/fpc-fcl-base/Makefile
new file mode 100644
index 000000000000..4525490761b9
--- /dev/null
+++ b/devel/fpc-fcl-base/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Free Pascal Compiler
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel lang
+PKGNAMESUFFIX= -fcl
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal Component Library
+
+RUN_DEPENDS= ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
+ ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
+ ${UNITSDIR}/md5/Package.fpc:${PORTSDIR}/security/fpc-md5 \
+ ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
+ ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
+ ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
+ ${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
+ ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
+ ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
+ ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
+ ${UNITSDIR}/regexpr/Package.fpc:${PORTSDIR}/devel/fpc-regexpr \
+ ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite
+
+UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/fpc-fcl-base/fpc-fcl/Makefile b/devel/fpc-fcl-base/fpc-fcl/Makefile
new file mode 100644
index 000000000000..4525490761b9
--- /dev/null
+++ b/devel/fpc-fcl-base/fpc-fcl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Free Pascal Compiler
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel lang
+PKGNAMESUFFIX= -fcl
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal Component Library
+
+RUN_DEPENDS= ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
+ ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
+ ${UNITSDIR}/md5/Package.fpc:${PORTSDIR}/security/fpc-md5 \
+ ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
+ ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
+ ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
+ ${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
+ ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
+ ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
+ ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
+ ${UNITSDIR}/regexpr/Package.fpc:${PORTSDIR}/devel/fpc-regexpr \
+ ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite
+
+UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"