aboutsummaryrefslogtreecommitdiff
path: root/devel/fpc-fcl-db/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-24 11:21:27 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-24 11:21:27 +0000
commit995ae8b1bdfe5e9d356eae060097bee70cbccbc8 (patch)
tree716cad45f74530d35aed61fcde093f63ed88f722 /devel/fpc-fcl-db/Makefile
parentc9b2d130fe2e03dd698820038b20cd1be036dc3c (diff)
downloadports-995ae8b1bdfe5e9d356eae060097bee70cbccbc8.tar.gz
ports-995ae8b1bdfe5e9d356eae060097bee70cbccbc8.zip
Notes
Diffstat (limited to 'devel/fpc-fcl-db/Makefile')
-rw-r--r--devel/fpc-fcl-db/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/devel/fpc-fcl-db/Makefile b/devel/fpc-fcl-db/Makefile
index 4525490761b9..1ff0de093226 100644
--- a/devel/fpc-fcl-db/Makefile
+++ b/devel/fpc-fcl-db/Makefile
@@ -8,10 +8,11 @@
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl
-MAINTAINER= acardenas@bsd.org.pe
+MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal Component Library
-RUN_DEPENDS= ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
${UNITSDIR}/md5/Package.fpc:${PORTSDIR}/security/fpc-md5 \
@@ -28,5 +29,13 @@ RUN_DEPENDS= ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${PORTNAME}/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR} ${PORTNAME}/rtl ${PORTNAME}/packages/base
+OPT=-CX -Fi../ -Fu${PREFIX}/lib/${PORTNAME}/${PORTVERSION}/units/${BUILDNAME}/*
+HAVE_EXAMPLES= true
+
+post-extract:
+ @cd ${WRKDIR}/${PORTNAME} && \
+ ${FIND} * -type d -name .svn | ${XARGS} ${RM} -rf
.include "${MASTERDIR}/Makefile"