aboutsummaryrefslogtreecommitdiff
path: root/devel/fpc-gdbint/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 00:55:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 00:55:09 +0000
commit56229123c20d3b7fe89cc798051678a02b0f7805 (patch)
tree153922acdccb848086ddd575382fcfc22797f67e /devel/fpc-gdbint/Makefile
parentbb803091c2edae2aeadd85ad56d5f2a364e966f4 (diff)
downloadports-56229123c20d3b7fe89cc798051678a02b0f7805.tar.gz
ports-56229123c20d3b7fe89cc798051678a02b0f7805.zip
Notes
Diffstat (limited to 'devel/fpc-gdbint/Makefile')
-rw-r--r--devel/fpc-gdbint/Makefile76
1 files changed, 76 insertions, 0 deletions
diff --git a/devel/fpc-gdbint/Makefile b/devel/fpc-gdbint/Makefile
new file mode 100644
index 000000000000..a2b58fa965a0
--- /dev/null
+++ b/devel/fpc-gdbint/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: Free Pascal Compiler
+# Date created: 28 November 2001
+# Whom: John Merryweather Cooper et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdbint
+PORTVERSION= 1.0.10
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= fpc-${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal unit providing interface to gdb
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+.endif
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack sources distribution
+ @${MKDIR} ${WRKSRC}/sources
+ @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
+# further extract base sources
+#
+# gdbint sources
+ @${TAR} zxf ${WRKSRC}/sources/unitsgdbintsrc.tar.gz \
+ --directory ${WRKSRC}
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
+ "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/gdbint && \
+ ${GMAKE} ${MAKE_ENV} all
+
+do-install:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/gdbint && \
+ ${GMAKE} ${MAKE_ENV} install
+
+.include <bsd.port.post.mk>