aboutsummaryrefslogtreecommitdiff
path: root/devel/ftjam
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-12 04:46:09 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-12 04:46:09 +0000
commitcae0169f50adec3177d424f16dea34a66c4ce2be (patch)
tree467e732636eeaf369b40eaf4d03126d989ed5324 /devel/ftjam
parent47de33f01788af0a35db414c3189e5c6513a76d6 (diff)
downloadports-cae0169f50adec3177d424f16dea34a66c4ce2be.tar.gz
ports-cae0169f50adec3177d424f16dea34a66c4ce2be.zip
Notes
Diffstat (limited to 'devel/ftjam')
-rw-r--r--devel/ftjam/Makefile51
-rw-r--r--devel/ftjam/distinfo2
-rw-r--r--devel/ftjam/pkg-descr20
3 files changed, 73 insertions, 0 deletions
diff --git a/devel/ftjam/Makefile b/devel/ftjam/Makefile
new file mode 100644
index 000000000000..f4d7fa82c2b1
--- /dev/null
+++ b/devel/ftjam/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: FTJam
+# Date created: Wed Oct 12 03:26:39 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftjam
+PORTVERSION= 2.3.5
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freetype
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Small build tool that can be used as a replacement for make(1)
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+INSTALL_WRKSRC= ${WRKSRC}/bin.freebsd
+
+.ifndef(NOPORTDOCS)
+PORTDOCS= \
+ Jam.html \
+ Jambase.html \
+ Jamfile.html \
+ Porting \
+ README \
+ RELNOTES \
+ jam.c
+.endif
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-configure:
+ @${REINPLACE_CMD} -E \
+ -e 's|^(CC[[:space:]]*=).*$$|\1${CC}|' \
+ -e 's|^(CFLAGS[[:space:]]*=).*$$|\1${CFLAGS}|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for file in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+. endfor
+.endif
+ @${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/jam ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/ftjam/distinfo b/devel/ftjam/distinfo
new file mode 100644
index 000000000000..b4eb0682d647
--- /dev/null
+++ b/devel/ftjam/distinfo
@@ -0,0 +1,2 @@
+MD5 (ftjam-2.3.5.tar.bz2) = 98d72533874ff8b8dac63f553c62dc5e
+SIZE (ftjam-2.3.5.tar.bz2) = 124721
diff --git a/devel/ftjam/pkg-descr b/devel/ftjam/pkg-descr
new file mode 100644
index 000000000000..7848c4b4c760
--- /dev/null
+++ b/devel/ftjam/pkg-descr
@@ -0,0 +1,20 @@
+[ excerpt from developer's www site ]
+
+Jam is a small open-source build tool that can be used as a replacement
+for Make. Even though Jam is a lot simpler to use than Make, it is
+far more powerful and easy to master. It already works on a large
+variety of platforms (Unix, Windows, OS/2, VMS, MacOS, BeOS, etc..),
+it is trivial to port, and its design is sufficiently clear to allow
+any average programmer to extend it with advanced features at will.
+
+The main differences between Jam and Make are the following:
+
+- Jam uses "Jamfiles" instead of "Makefiles".
+- Jamfiles do not normally contain toolset-specific rules or actions.
+ They're thus portable among distinct compilers
+- Jamfiles are a lot simpler than Makefiles to write and understand,
+ while providing the same functionality, and much, much more !!
+
+WWW: http://freetype.sourceforge.net/jam/
+
+-- lioux@FreeBSD.org