aboutsummaryrefslogtreecommitdiff
path: root/devel/g-wrap
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-03-03 20:54:51 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-03-03 20:54:51 +0000
commit2f4d5d8fac2b46f30a4950c3bb425a1e8554d678 (patch)
treeffeb67cca7066ee1a44ad2b871b2e7dafd9c9dfc /devel/g-wrap
parent4a6f5358f7fd828d69050f89a41b002c4e0bde35 (diff)
downloadports-2f4d5d8fac2b46f30a4950c3bb425a1e8554d678.tar.gz
ports-2f4d5d8fac2b46f30a4950c3bb425a1e8554d678.zip
Notes
Diffstat (limited to 'devel/g-wrap')
-rw-r--r--devel/g-wrap/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/g-wrap/Makefile b/devel/g-wrap/Makefile
index 2e3687f03ee2..feffd828e19d 100644
--- a/devel/g-wrap/Makefile
+++ b/devel/g-wrap/Makefile
@@ -5,6 +5,7 @@
#
# $FreeBSD$
# $MCom: ports/devel/g-wrap/Makefile,v 1.6 2006/12/24 18:45:08 ahze Exp $
+#
PORTNAME= g-wrap
PORTVERSION= 1.9.6
@@ -31,6 +32,8 @@ USE_GNOME= glib20 gnomehack
post-patch:
@${REINPLACE_CMD} -e 's|"glib"|"glib-2.0"|' \
${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|(GUILE_CFLAGS) $$(LIBFFI_CFLAGS)|(LIBFFI_CFLAGS) $$(GUILE_CFLAGS)|g'
pre-install:
@${REINPLACE_CMD} -e 's|libffi||' ${WRKSRC}/${MAKEFILE}
@@ -38,7 +41,8 @@ pre-install:
post-install:
${MKDIR} ${PREFIX}/include/g-wrap/ffi
.for f in ffi.h ffitarget.h
- ${INSTALL_DATA} ${WRKSRC}/libffi/include/${f} ${PREFIX}/include/g-wrap/ffi
+ ${INSTALL_DATA} ${WRKSRC}/libffi/include/${f} \
+ ${PREFIX}/include/g-wrap/ffi
.endfor
.include <bsd.port.mk>