aboutsummaryrefslogtreecommitdiff
path: root/devel/gamin
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-02-12 17:03:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-02-12 17:03:59 +0000
commit79bed2eee88ba36eb14333ac0704113b97ef3603 (patch)
treebd8c24779ea6291be28b7639bd1a63be5c36d8d0 /devel/gamin
parentd9a883673321f7545eaa1de8446b7e660e598297 (diff)
downloadports-79bed2eee88ba36eb14333ac0704113b97ef3603.tar.gz
ports-79bed2eee88ba36eb14333ac0704113b97ef3603.zip
Notes
Diffstat (limited to 'devel/gamin')
-rw-r--r--devel/gamin/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/devel/gamin/Makefile b/devel/gamin/Makefile
index 960721705e42..d56f4af553e0 100644
--- a/devel/gamin/Makefile
+++ b/devel/gamin/Makefile
@@ -30,7 +30,8 @@ CONFLICTS= fam-[0-9]*
GNU_CONFIGURE= yes
.if !defined(GAMIN_SLAVE)
-OPTIONS= GAM_POLLER "Use gamin's poller instead of kqueue's" off
+OPTIONS= GAM_POLLER "Use gamin's poller instead of kqueue's" off \
+ LIBINOTIFY "Use libinotify as the FAM backend" off
.endif
.include <bsd.port.pre.mk>
@@ -39,6 +40,14 @@ OPTIONS= GAM_POLLER "Use gamin's poller instead of kqueue's" off
.if defined(WITH_GAM_POLLER)
CPPFLAGS+= -DUSE_GAMIN_POLLER=1
.endif
+
+.if defined(WITH_LIBINOTIFY)
+CONFIGURE_ARGS+=--enable-inotify
+LDFLAGS+= -L${LOCALBASE}/lib -linotify
+LIB_DEPENDS+= inotify.0:${PORTSDIR}/devel/libinotify
+.else
+CONFIGURE_ARGS+=--disable-inotify
+.endif
.endif
post-patch: