aboutsummaryrefslogtreecommitdiff
path: root/devel/gauche-gaunit/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-09 21:02:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-09 21:02:31 +0000
commit70c0c1e823600a4c9c07d2e39ba75deb30cc57d7 (patch)
tree968826f38db4cbf2909d040a057230316decfbbb /devel/gauche-gaunit/Makefile
parente43b9275f894e540c8a45daeba562c88275453f5 (diff)
Notes
Diffstat (limited to 'devel/gauche-gaunit/Makefile')
-rw-r--r--devel/gauche-gaunit/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/gauche-gaunit/Makefile b/devel/gauche-gaunit/Makefile
new file mode 100644
index 000000000000..b1d36785abdd
--- /dev/null
+++ b/devel/gauche-gaunit/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: GaUnit
+# Date created: 8 May 2004
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+
+PORTNAME= gaunit
+PORTVERSION= 0.0.5
+CATEGORIES= devel scheme
+MASTER_SITES= http://www.cozmixng.org/~kou/download/
+PKGNAMEPREFIX= gauche-
+
+MAINTAINER= fuyuki@hadaly.org
+COMMENT= An unit testing framework in Gauche
+
+BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README.* Tutorial.*
+.endif
+
+do-install:
+ cd ${WRKSRC}; ${LOCALBASE}/bin/gosh install/install.scm
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/sample/* ${EXAMPLESDIR}
+
+test:
+ cd ${WRKSRC}; ${LOCALBASE}/bin/gosh -I. test/run-test.scm
+
+.include <bsd.port.mk>