aboutsummaryrefslogtreecommitdiff
path: root/devel/gauche-gaunit
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-09 21:02:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-09 21:02:31 +0000
commit70c0c1e823600a4c9c07d2e39ba75deb30cc57d7 (patch)
tree968826f38db4cbf2909d040a057230316decfbbb /devel/gauche-gaunit
parente43b9275f894e540c8a45daeba562c88275453f5 (diff)
downloadports-70c0c1e823600a4c9c07d2e39ba75deb30cc57d7.tar.gz
ports-70c0c1e823600a4c9c07d2e39ba75deb30cc57d7.zip
Notes
Diffstat (limited to 'devel/gauche-gaunit')
-rw-r--r--devel/gauche-gaunit/Makefile41
-rw-r--r--devel/gauche-gaunit/distinfo2
-rw-r--r--devel/gauche-gaunit/pkg-descr3
-rw-r--r--devel/gauche-gaunit/pkg-plist16
4 files changed, 62 insertions, 0 deletions
diff --git a/devel/gauche-gaunit/Makefile b/devel/gauche-gaunit/Makefile
new file mode 100644
index 000000000000..b1d36785abdd
--- /dev/null
+++ b/devel/gauche-gaunit/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: GaUnit
+# Date created: 8 May 2004
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+
+PORTNAME= gaunit
+PORTVERSION= 0.0.5
+CATEGORIES= devel scheme
+MASTER_SITES= http://www.cozmixng.org/~kou/download/
+PKGNAMEPREFIX= gauche-
+
+MAINTAINER= fuyuki@hadaly.org
+COMMENT= An unit testing framework in Gauche
+
+BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README.* Tutorial.*
+.endif
+
+do-install:
+ cd ${WRKSRC}; ${LOCALBASE}/bin/gosh install/install.scm
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/sample/* ${EXAMPLESDIR}
+
+test:
+ cd ${WRKSRC}; ${LOCALBASE}/bin/gosh -I. test/run-test.scm
+
+.include <bsd.port.mk>
diff --git a/devel/gauche-gaunit/distinfo b/devel/gauche-gaunit/distinfo
new file mode 100644
index 000000000000..af9139e1e37d
--- /dev/null
+++ b/devel/gauche-gaunit/distinfo
@@ -0,0 +1,2 @@
+MD5 (gaunit-0.0.5.tar.gz) = d9ab2d304f755d1d29230ca8993e4abb
+SIZE (gaunit-0.0.5.tar.gz) = 25914
diff --git a/devel/gauche-gaunit/pkg-descr b/devel/gauche-gaunit/pkg-descr
new file mode 100644
index 000000000000..b63414672de4
--- /dev/null
+++ b/devel/gauche-gaunit/pkg-descr
@@ -0,0 +1,3 @@
+This is an unit testing framework in the Gauche Scheme interpreter.
+
+WWW: http://www.cozmixng.org/~kou/gauche/gaunit
diff --git a/devel/gauche-gaunit/pkg-plist b/devel/gauche-gaunit/pkg-plist
new file mode 100644
index 000000000000..c7bc93b5afcc
--- /dev/null
+++ b/devel/gauche-gaunit/pkg-plist
@@ -0,0 +1,16 @@
+share/gauche/site/lib/test/assertions.scm
+share/gauche/site/lib/test/autorunner.scm
+share/gauche/site/lib/test/ui.scm
+share/gauche/site/lib/test/ui/gtk.scm
+share/gauche/site/lib/test/ui/text.scm
+share/gauche/site/lib/test/unit.scm
+@unexec rmdir %D/share/gauche/site/lib/test/ui 2>/dev/null || true
+@unexec rmdir %D/share/gauche/site/lib/test 2>/dev/null || true
+@unexec rmdir %D/share/doc/gauche 2>/dev/null || true
+%%EXAMPLESDIR%%/site-lisp/run-test.el
+%%EXAMPLESDIR%%/symbolic_differentiation/symdiff.scm
+%%EXAMPLESDIR%%/symbolic_differentiation/test-symdiff.scm
+@dirrm %%EXAMPLESDIR%%/symbolic_differentiation
+@dirrm %%EXAMPLESDIR%%/site-lisp
+@dirrm %%EXAMPLESDIR%%
+@unexec rmdir %D/share/examples/gauche 2>/dev/null || true