aboutsummaryrefslogtreecommitdiff
path: root/devel/gcc-arm-embedded
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-21 23:52:37 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-21 23:52:37 +0000
commit0e9d79c998164f81d1bcc1061bce68afdd0b5756 (patch)
tree43e3e96b51c1b5ffe0081b680c450409ce4bb954 /devel/gcc-arm-embedded
parenteda8841921812fa20a8d592b45e5d8d64ede883d (diff)
downloadports-0e9d79c998164f81d1bcc1061bce68afdd0b5756.tar.gz
ports-0e9d79c998164f81d1bcc1061bce68afdd0b5756.zip
Mark as broken on aarch64, and, where appropriate, armvX.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=473009
Diffstat (limited to 'devel/gcc-arm-embedded')
-rw-r--r--devel/gcc-arm-embedded/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/devel/gcc-arm-embedded/Makefile b/devel/gcc-arm-embedded/Makefile
index 9ab67fcb1efa..bef687fc12e7 100644
--- a/devel/gcc-arm-embedded/Makefile
+++ b/devel/gcc-arm-embedded/Makefile
@@ -13,7 +13,17 @@ COMMENT= Complete gcc-based toolcahin for embedded ARM development
LICENSE= GPLv2 LGPL20 LGPL21 GPLv3 LGPL3
LICENSE_COMB= multi
+BROKEN_aarch64= fails to build
BROKEN_powerpc64= does not build: __adjust.c: internal compiler error: Segmentation fault
+NOT_FOR_ARCHS= arm armeb armv6 armv7 \
+ mips mips64 mips64el mipsel mipsn32
+NOT_FOR_ARCHS_REASON= Very slow to build on emulator
+
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr \
+ libmpc.so:math/mpc \
+ libisl.so:devel/isl
OPTIONS_DEFINE= PYGDB EXAMPLES HTML PDF DOCS SYMLINK
OPTIONS_DEFAULT=PYGDB SYMLINK
@@ -28,16 +38,6 @@ PYGDB_USES= python:2.7
OPTIONS_SUB= yes
-NOT_FOR_ARCHS= arm armeb armv6 armv7 \
- mips mips64 mips64el mipsel mipsn32
-NOT_FOR_ARCHS_REASON= Very slow to build on emulator
-
-LIB_DEPENDS= libexpat.so:textproc/expat2 \
- libgmp.so:math/gmp \
- libmpfr.so:math/mpfr \
- libmpc.so:math/mpc \
- libisl.so:devel/isl
-
USES= bison compiler cpe gmake gettext-runtime iconv makeinfo tar:bzip2
GNU_CONFIGURE= yes