aboutsummaryrefslogtreecommitdiff
path: root/devel/gcc-arm-embedded
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-08-09 15:36:27 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-08-09 15:36:27 +0000
commit0f0d53f3421ca6f3ea0b716831a814d1899da109 (patch)
treef31a3d2fc3a895f34bf4352290679f4d27ada23e /devel/gcc-arm-embedded
parent8e3b0ad1c328ca8cbbfedda9990c6eee243ced39 (diff)
downloadports-0f0d53f3421ca6f3ea0b716831a814d1899da109.tar.gz
ports-0f0d53f3421ca6f3ea0b716831a814d1899da109.zip
devel/gcc-arm-embedded: Remove unnecessary LIB_DEPENDS on libelf
Also: - added missing plist entries - add missing gettext-runtime to USES - corrected minor spelling mistake PR: 220782 Submitted by: Jonathan Chen <jonc@chen.org.nz> Approved by: portmgr (maintainer timeout, 2 weeks) MFH: 2017Q3
Notes
Notes: svn path=/head/; revision=447629
Diffstat (limited to 'devel/gcc-arm-embedded')
-rw-r--r--devel/gcc-arm-embedded/Makefile9
-rw-r--r--devel/gcc-arm-embedded/pkg-plist2
2 files changed, 6 insertions, 5 deletions
diff --git a/devel/gcc-arm-embedded/Makefile b/devel/gcc-arm-embedded/Makefile
index adcc85026803..2bc415d5fce2 100644
--- a/devel/gcc-arm-embedded/Makefile
+++ b/devel/gcc-arm-embedded/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gcc-arm-embedded
PORTVERSION= 6.3.20170628
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://developer.arm.com/-/media/Files/downloads/gnu-rm/6-2017q2/
DISTNAME= ${ORIGINAL_PACKAGE_NAME}-src
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= PYGDB EXAMPLES HTML PDF DOCS
OPTIONS_DEFAULT=PYGDB
HTML_DESC= Install HTML documentation
PDF_DESC= Install PDF documentation (requires TeX, it is huge)
-PYGDB_DESC= Build and install pyhon-enabled gdb in addition to standard one
+PYGDB_DESC= Build and install python-enabled gdb in addition to standard one
PDF_USE= TEX=base:build,tex:build,dvipsk:build
PDF_BUILD_DEPENDS= texi2dvi:print/texinfo
@@ -35,10 +35,9 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libmpc.so:math/mpc \
- libisl.so:devel/isl \
- libelf.so:devel/libelf
+ libisl.so:devel/isl
-USES= bison compiler cpe gmake iconv makeinfo tar:bzip2
+USES= bison compiler cpe gmake gettext-runtime iconv makeinfo tar:bzip2
GNU_CONFIGURE= yes
diff --git a/devel/gcc-arm-embedded/pkg-plist b/devel/gcc-arm-embedded/pkg-plist
index adba882fbd85..3e328190f9fe 100644
--- a/devel/gcc-arm-embedded/pkg-plist
+++ b/devel/gcc-arm-embedded/pkg-plist
@@ -2640,6 +2640,8 @@ gcc-arm-embedded-%%FULL_VERSION%%/share/gcc-%%TARGET%%/libstdcxx/__init__.py
gcc-arm-embedded-%%FULL_VERSION%%/share/gcc-%%TARGET%%/libstdcxx/v6/__init__.py
gcc-arm-embedded-%%FULL_VERSION%%/share/gcc-%%TARGET%%/libstdcxx/v6/printers.py
gcc-arm-embedded-%%FULL_VERSION%%/share/gcc-%%TARGET%%/libstdcxx/v6/xmethods.py
+%%PYGDB%%%%PORTDOCS%%%%DOCSDIR%%/man/man1/%%TARGET%%-gcov-dump.1.gz
+%%PYGDB%%%%PORTDOCS%%%%DOCSDIR%%/man/man1/%%TARGET%%-gcov-tool.1.gz
%%PYGDB%%%%PORTDOCS%%%%DOCSDIR%%/man/man1/%%TARGET%%-gdb.1-py.gz
%%PYGDB%%%%PORTDOCS%%%%DOCSDIR%%/man/man1/%%TARGET%%-gdbserver.1-py.gz
%%PYGDB%%%%PORTDOCS%%%%DOCSDIR%%/man/man5/%%TARGET%%-gdbinit.5-py.gz