aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
commitae52bc80895a23ddbe33b86e75a9cf331ae32ba9 (patch)
tree5538a7d3541f6d56e4bbab9c6329f5b9db64dafb /devel/gconf2
parent7934df773e0cc2a9924de75dd7cad9cc3d79d4ee (diff)
downloadports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.tar.gz
ports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.zip
Notes
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile4
-rw-r--r--devel/gconf2/distinfo6
-rw-r--r--devel/gconf2/files/patch-ab11
-rw-r--r--devel/gconf2/files/patch-gconf_default.path.in11
-rw-r--r--devel/gconf2/files/patch-gconf_gconfd.c62
-rw-r--r--devel/gconf2/files/patch-gconf_gconftool.c16
6 files changed, 16 insertions, 94 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index ed6f8d8cd495..250fbed4fe6e 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -3,11 +3,11 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gconf2/Makefile,v 1.102 2008/09/23 04:54:38 marcus Exp $
+# $MCom: ports/devel/gconf2/Makefile,v 1.106 2009/03/18 00:42:34 kwm Exp $
#
PORTNAME= gconf2
-PORTVERSION= 2.24.0
+PORTVERSION= 2.26.0
PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= GNOME
diff --git a/devel/gconf2/distinfo b/devel/gconf2/distinfo
index f3cebd9eea58..4330c8a589a6 100644
--- a/devel/gconf2/distinfo
+++ b/devel/gconf2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/GConf-2.24.0.tar.bz2) = 4971d96f5ba94fe4a69396267bd5afe8
-SHA256 (gnome2/GConf-2.24.0.tar.bz2) = 990003904ee13b2fd98a61d55fa4d0fcb30fb233454a036bb9465f42d1acbb1b
-SIZE (gnome2/GConf-2.24.0.tar.bz2) = 1467817
+MD5 (gnome2/GConf-2.26.0.tar.bz2) = b010f0de356ea093c6a73778b13de956
+SHA256 (gnome2/GConf-2.26.0.tar.bz2) = 2b9fe741f84d78d7c4f18835728facce81f7db656c2c37f669ee61785911da10
+SIZE (gnome2/GConf-2.26.0.tar.bz2) = 1490741
diff --git a/devel/gconf2/files/patch-ab b/devel/gconf2/files/patch-ab
deleted file mode 100644
index 6f25900e7de2..000000000000
--- a/devel/gconf2/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Sun Aug 4 22:38:39 2002
-+++ Makefile.in Sun Aug 4 22:39:52 2002
-@@ -35,7 +35,7 @@
- DESTDIR =
-
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/pkgconfig
- pkgincludedir = $(includedir)/@PACKAGE@
-
- top_builddir = .
diff --git a/devel/gconf2/files/patch-gconf_default.path.in b/devel/gconf2/files/patch-gconf_default.path.in
new file mode 100644
index 000000000000..0b60822c7c27
--- /dev/null
+++ b/devel/gconf2/files/patch-gconf_default.path.in
@@ -0,0 +1,11 @@
+--- gconf/default.path.in.orig 2009-03-06 17:10:54.000000000 -0500
++++ gconf/default.path.in 2009-03-06 17:11:25.000000000 -0500
+@@ -21,7 +21,7 @@ include "$(HOME)/.gconf.path"
+ xml:readwrite:$(HOME)/.gconf
+
+ # Location for system-wide settings that are set by the defaults mechanism
+-xml:readonly:/etc/gconf/gconf.xml.system
++xml:readonly:@sysgconfdir@/gconf.xml.system
+
+ # To read in any defaults settings that the Sys Admin may have created
+ # prior to a desktop system upgrade. The SysAdmin can stick default values
diff --git a/devel/gconf2/files/patch-gconf_gconfd.c b/devel/gconf2/files/patch-gconf_gconfd.c
deleted file mode 100644
index 31a6470a42e5..000000000000
--- a/devel/gconf2/files/patch-gconf_gconfd.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- gconf/gconfd.c.orig 2008-05-10 08:34:31.000000000 -0400
-+++ gconf/gconfd.c 2008-08-16 14:08:05.000000000 -0400
-@@ -123,12 +123,6 @@ static void gconf_handle_segv (int signu
-
- static gboolean in_shutdown = FALSE;
-
--/*
-- * Flag indicating we received a SIGHUP and we should reaload
-- * all sources during the next periodic_cleanup()
-- */
--static gboolean need_db_reload = FALSE;
--
- /*
- * CORBA goo
- */
-@@ -408,6 +402,18 @@ gconf_server_load_sources(void)
- }
- }
-
-+static void
-+reload_db (void)
-+{
-+ gconf_log (GCL_INFO, _("SIGHUP received, reloading all databases"));
-+
-+ logfile_save ();
-+ shutdown_databases ();
-+ init_databases ();
-+ gconf_server_load_sources ();
-+ logfile_read ();
-+}
-+
- /*
- * Signal handlers should not log debug messages as this code is non-reentrant.
- * Please avoid calling gconf_log in this function.
-@@ -471,8 +477,7 @@ signal_handler (int signo)
- case SIGHUP:
- --in_fatal;
-
-- /* reload sources during next periodic_cleanup() */
-- need_db_reload = TRUE;
-+ reload_db ();
- break;
- #endif
-
-@@ -828,17 +833,6 @@ static gboolean need_log_cleanup = FALSE
- static gboolean
- periodic_cleanup_timeout(gpointer data)
- {
-- if (need_db_reload)
-- {
-- gconf_log (GCL_INFO, _("SIGHUP received, reloading all databases"));
--
-- need_db_reload = FALSE;
-- logfile_save ();
-- shutdown_databases ();
-- init_databases ();
-- gconf_server_load_sources ();
-- logfile_read ();
-- }
-
- gconf_log (GCL_DEBUG, "Performing periodic cleanup, expiring cache cruft");
-
diff --git a/devel/gconf2/files/patch-gconf_gconftool.c b/devel/gconf2/files/patch-gconf_gconftool.c
deleted file mode 100644
index f3c3d2fb0867..000000000000
--- a/devel/gconf2/files/patch-gconf_gconftool.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- gconf/gconftool.c.orig Fri Mar 2 17:10:13 2007
-+++ gconf/gconftool.c Tue Mar 6 12:01:04 2007
-@@ -3781,6 +3781,13 @@ do_makefile_install(GConfEngine* conf, c
- }
-
- retval |= do_sync (conf);
-+
-+ /*
-+ * Send all the gconfd-2 processes a SIGHUP so that they reload the
-+ * databases and pick up the added/removed schemas.
-+ */
-+ system("/usr/bin/killall -SIGHUP gconfd-2 >/dev/null 2>&1");
-+
- return retval;
- }
-