aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 15:31:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 15:31:46 +0000
commit548387be8002521e3aa9b0c8ae2b343d9d3520eb (patch)
treeec7ba00fd2a8b535baa75d1a42a0f7d7096519e9 /devel/gconf2
parentbcbf81722c6ee8e04ddbb164394bf1905b2a3fa4 (diff)
downloadports-548387be8002521e3aa9b0c8ae2b343d9d3520eb.tar.gz
ports-548387be8002521e3aa9b0c8ae2b343d9d3520eb.zip
Notes
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 2506a83c51ea..377dbf81fc76 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= ORBit-2.0:${PORTSDIR}/devel/ORBit2 \
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-db3-includes=${LOCALBASE}/include \
@@ -31,12 +32,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
post-install:
@${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/apps