aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
commit610ae5681637c1051a0c17b54e29d97f53da2f3a (patch)
treec231a1eb74b07e444fa7363012cb84bf23d83ce0 /devel/gconf2
parent15b6544926b07a98710eeb765baf03e3fc9a195c (diff)
Notes
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile9
-rw-r--r--devel/gconf2/distinfo6
-rw-r--r--devel/gconf2/files/patch-gconf_gconfd.c26
-rw-r--r--devel/gconf2/pkg-plist13
4 files changed, 33 insertions, 21 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 540ece1a10c5..f9127163f048 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -3,12 +3,12 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gconf2/Makefile,v 1.96 2008/03/10 16:25:56 ahze Exp $
+# $MCom: ports/devel/gconf2/Makefile,v 1.102 2008/09/23 04:54:38 marcus Exp $
#
PORTNAME= gconf2
-PORTVERSION= 2.22.0
-PORTREVISION?= 1
+PORTVERSION= 2.24.0
+PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/GConf/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -22,6 +22,9 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ polkit.2:${PORTSDIR}/sysutils/policykit
+
USE_GMAKE= yes
USE_GETTEXT= yes
USE_GNOME= gnomehier gnomehack orbit2 gtk20 libxml2 ltverhack \
diff --git a/devel/gconf2/distinfo b/devel/gconf2/distinfo
index 69fd7f190c62..f3cebd9eea58 100644
--- a/devel/gconf2/distinfo
+++ b/devel/gconf2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/GConf-2.22.0.tar.bz2) = a56c043afeb1052abaf45407409b0331
-SHA256 (gnome2/GConf-2.22.0.tar.bz2) = 54e40cf047eb431cdf994f763ae840107ed6e9b8f9521b2b2eb07c7a55f92ce0
-SIZE (gnome2/GConf-2.22.0.tar.bz2) = 1416685
+MD5 (gnome2/GConf-2.24.0.tar.bz2) = 4971d96f5ba94fe4a69396267bd5afe8
+SHA256 (gnome2/GConf-2.24.0.tar.bz2) = 990003904ee13b2fd98a61d55fa4d0fcb30fb233454a036bb9465f42d1acbb1b
+SIZE (gnome2/GConf-2.24.0.tar.bz2) = 1467817
diff --git a/devel/gconf2/files/patch-gconf_gconfd.c b/devel/gconf2/files/patch-gconf_gconfd.c
index ef551cb28e81..31a6470a42e5 100644
--- a/devel/gconf2/files/patch-gconf_gconfd.c
+++ b/devel/gconf2/files/patch-gconf_gconfd.c
@@ -1,6 +1,6 @@
---- gconf/gconfd.c.orig Fri May 5 12:40:23 2006
-+++ gconf/gconfd.c Fri May 5 12:41:43 2006
-@@ -124,12 +124,6 @@
+--- gconf/gconfd.c.orig 2008-05-10 08:34:31.000000000 -0400
++++ gconf/gconfd.c 2008-08-16 14:08:05.000000000 -0400
+@@ -123,12 +123,6 @@ static void gconf_handle_segv (int signu
static gboolean in_shutdown = FALSE;
@@ -13,10 +13,11 @@
/*
* CORBA goo
*/
-@@ -410,6 +404,18 @@
+@@ -408,6 +402,18 @@ gconf_server_load_sources(void)
+ }
}
- static void
++static void
+reload_db (void)
+{
+ gconf_log (GCL_INFO, _("SIGHUP received, reloading all databases"));
@@ -28,22 +29,20 @@
+ logfile_read ();
+}
+
-+static void
- signal_handler (int signo)
- {
- static gint in_fatal = 0;
-@@ -482,8 +488,8 @@
+ /*
+ * Signal handlers should not log debug messages as this code is non-reentrant.
+ * Please avoid calling gconf_log in this function.
+@@ -471,8 +477,7 @@ signal_handler (int signo)
case SIGHUP:
--in_fatal;
- /* reload sources during next periodic_cleanup() */
- need_db_reload = TRUE;
-+ /* reload sources immediately */
+ reload_db ();
break;
#endif
-@@ -864,18 +870,6 @@
+@@ -828,17 +833,6 @@ static gboolean need_log_cleanup = FALSE
static gboolean
periodic_cleanup_timeout(gpointer data)
{
@@ -58,7 +57,6 @@
- gconf_server_load_sources ();
- logfile_read ();
- }
--
+
gconf_log (GCL_DEBUG, "Performing periodic cleanup, expiring cache cruft");
- drop_old_clients ();
diff --git a/devel/gconf2/pkg-plist b/devel/gconf2/pkg-plist
index fc96aad3d6fd..85be04736253 100644
--- a/devel/gconf2/pkg-plist
+++ b/devel/gconf2/pkg-plist
@@ -1,5 +1,6 @@
bin/gconf-merge-tree
bin/gconftool-2
+etc/dbus-1/system.d/org.gnome.GConf.Defaults.conf
%%LDAP%%etc/gconf/2/evoldap.conf
etc/gconf/2/path
include/gconf/2/gconf/gconf-changeset.h
@@ -11,6 +12,7 @@ include/gconf/2/gconf/gconf-listeners.h
include/gconf/2/gconf/gconf-schema.h
include/gconf/2/gconf/gconf-value.h
include/gconf/2/gconf/gconf.h
+libexec/gconf-defaults-mechanism
%%LDAP%%lib/GConf/2/libgconfbackend-evoldap.a
%%LDAP%%lib/GConf/2/libgconfbackend-evoldap.la
%%LDAP%%lib/GConf/2/libgconfbackend-evoldap.so
@@ -29,6 +31,9 @@ libexec/gconf-sanity-check-2
libexec/gconfd-2
%%LDAP%%share/GConf/schema/evoldap.schema
share/aclocal/gconf-2.m4
+share/PolicyKit/policy/org.gnome.gconf.defaults.policy
+share/dbus-1/system-services/org.gnome.GConf.Defaults.service
+share/dbus-1/services/org.gnome.GConf.service
share/locale/am/LC_MESSAGES/GConf2.mo
share/locale/ar/LC_MESSAGES/GConf2.mo
share/locale/as/LC_MESSAGES/GConf2.mo
@@ -65,10 +70,12 @@ share/locale/is/LC_MESSAGES/GConf2.mo
share/locale/it/LC_MESSAGES/GConf2.mo
share/locale/ja/LC_MESSAGES/GConf2.mo
share/locale/ka/LC_MESSAGES/GConf2.mo
+share/locale/kn/LC_MESSAGES/GConf2.mo
share/locale/ko/LC_MESSAGES/GConf2.mo
share/locale/ku/LC_MESSAGES/GConf2.mo
share/locale/lt/LC_MESSAGES/GConf2.mo
share/locale/lv/LC_MESSAGES/GConf2.mo
+share/locale/mai/LC_MESSAGES/GConf2.mo
share/locale/mg/LC_MESSAGES/GConf2.mo
share/locale/mk/LC_MESSAGES/GConf2.mo
share/locale/ml/LC_MESSAGES/GConf2.mo
@@ -93,7 +100,7 @@ share/locale/sk/LC_MESSAGES/GConf2.mo
share/locale/sl/LC_MESSAGES/GConf2.mo
share/locale/sq/LC_MESSAGES/GConf2.mo
share/locale/sr/LC_MESSAGES/GConf2.mo
-share/locale/sr@Latn/LC_MESSAGES/GConf2.mo
+share/locale/sr@latin/LC_MESSAGES/GConf2.mo
share/locale/sv/LC_MESSAGES/GConf2.mo
share/locale/ta/LC_MESSAGES/GConf2.mo
share/locale/te/LC_MESSAGES/GConf2.mo
@@ -122,6 +129,8 @@ share/sgml/gconf/gconf-1.0.dtd
@dirrmtry share/locale/xh
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@@ -132,6 +141,8 @@ share/sgml/gconf/gconf-1.0.dtd
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
@dirrmtry share/locale/dz/LC_MESSAGES