aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
commit951c257ea3655de6e80c26a36c18c69ee8047ea8 (patch)
tree249b59a23d9c6fae8db5e5639385f6273d237705 /devel/gconf2
parent91926e92b73e3751382216a16044c5d8b24ad126 (diff)
downloadports-951c257ea3655de6e80c26a36c18c69ee8047ea8.tar.gz
ports-951c257ea3655de6e80c26a36c18c69ee8047ea8.zip
Notes
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile4
-rw-r--r--devel/gconf2/distinfo6
-rw-r--r--devel/gconf2/files/patch-gconf_gconftool.c22
3 files changed, 10 insertions, 22 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index e19c0c39120a..e6f4e96d3181 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -3,11 +3,11 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gconf2/Makefile,v 1.79 2006/10/05 18:09:30 mezz Exp $
+# $MCom: ports/devel/gconf2/Makefile,v 1.81 2007/03/06 17:05:38 marcus Exp $
#
PORTNAME= gconf2
-PORTVERSION= 2.16.1
+PORTVERSION= 2.18.0.1
PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
diff --git a/devel/gconf2/distinfo b/devel/gconf2/distinfo
index ab70108a17ce..2c95436169b1 100644
--- a/devel/gconf2/distinfo
+++ b/devel/gconf2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/GConf-2.16.1.tar.bz2) = 60d2da294195abb8cac81b6ecceb7e5e
-SHA256 (gnome2/GConf-2.16.1.tar.bz2) = accedbd57f497be040055761b1553108a919cdde00986230434b9fe3925a6200
-SIZE (gnome2/GConf-2.16.1.tar.bz2) = 1321109
+MD5 (gnome2/GConf-2.18.0.1.tar.bz2) = aa0e0a0729fb021bab72b4166fd392f9
+SHA256 (gnome2/GConf-2.18.0.1.tar.bz2) = 58a738f34078de9b3906460a297e751e80a0846e4f3bf33e1884216d0da42bf1
+SIZE (gnome2/GConf-2.18.0.1.tar.bz2) = 1347765
diff --git a/devel/gconf2/files/patch-gconf_gconftool.c b/devel/gconf2/files/patch-gconf_gconftool.c
index c47e5e426927..f3c3d2fb0867 100644
--- a/devel/gconf2/files/patch-gconf_gconftool.c
+++ b/devel/gconf2/files/patch-gconf_gconftool.c
@@ -1,20 +1,9 @@
---- gconf/gconftool.c.orig Fri May 5 12:36:01 2006
-+++ gconf/gconftool.c Fri May 5 12:39:29 2006
-@@ -3724,6 +3724,8 @@
- static int
- do_makefile_install(GConfEngine* conf, const gchar** args, gboolean unload)
- {
-+ int sync_result;
-+
- if (args == NULL)
- {
- g_printerr (_("Must specify some schema files to install\n"));
-@@ -3738,7 +3740,15 @@
- ++args;
+--- gconf/gconftool.c.orig Fri Mar 2 17:10:13 2007
++++ gconf/gconftool.c Tue Mar 6 12:01:04 2007
+@@ -3781,6 +3781,13 @@ do_makefile_install(GConfEngine* conf, c
}
-- return do_sync (conf);
-+ sync_result = do_sync (conf);
+ retval |= do_sync (conf);
+
+ /*
+ * Send all the gconfd-2 processes a SIGHUP so that they reload the
@@ -22,7 +11,6 @@
+ */
+ system("/usr/bin/killall -SIGHUP gconfd-2 >/dev/null 2>&1");
+
-+ return sync_result;
+ return retval;
}
- typedef enum {