aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
commit9c0caae1c20155b432bb0feb074a8fd9cc1c12bc (patch)
tree534d0190982c831de589344c3003940ec6f2d6b1 /devel/gconf2
parent27d17afba2c21f490ea8472d7aa37495e02e3ed8 (diff)
downloadports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.tar.gz
ports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.zip
Notes
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile9
-rw-r--r--devel/gconf2/distinfo2
-rw-r--r--devel/gconf2/files/patch-backends::bdb-backend.c17
-rw-r--r--devel/gconf2/files/patch-configure18
-rw-r--r--devel/gconf2/files/patch-gconf::gconf-internals.c15
-rw-r--r--devel/gconf2/pkg-descr22
-rw-r--r--devel/gconf2/pkg-plist6
7 files changed, 34 insertions, 55 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 315d0857452a..05342793c398 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gconf2
-PORTVERSION= 2.2.1
+PORTVERSION= 2.4.0.1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/GConf/2.2
+MASTER_SITE_SUBDIR= sources/GConf/2.4
DISTNAME= GConf-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,10 +20,11 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gnomehier orbit2 libxml2 gtk20
+USE_GNOME= gnomehack gnomehier orbit2 gtk20 libxml2 linc
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/gconf2/distinfo b/devel/gconf2/distinfo
index 6485444046b3..41fb7d07650f 100644
--- a/devel/gconf2/distinfo
+++ b/devel/gconf2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/GConf-2.2.1.tar.bz2) = 3788a2e63f200478caf2b16059327076
+MD5 (gnome2/GConf-2.4.0.1.tar.bz2) = 2f7548d0bad24d7c4beba54d0ec98a20
diff --git a/devel/gconf2/files/patch-backends::bdb-backend.c b/devel/gconf2/files/patch-backends::bdb-backend.c
deleted file mode 100644
index 9c7fa1e3fdd4..000000000000
--- a/devel/gconf2/files/patch-backends::bdb-backend.c
+++ /dev/null
@@ -1,17 +0,0 @@
-
-$FreeBSD$
-
---- backends/bdb-backend.c 2002/02/15 19:10:46 1.1
-+++ backends/bdb-backend.c 2002/02/15 19:11:25
-@@ -29,10 +29,9 @@
- #include <gconf/gconf-internals.h>
- #include <gconf/gconf.h>
-
-+#include "config.h"
- #include "bdb.h"
- #include "dir-utils.h"
--
--#include <db.h>
-
- #include <stdio.h>
- #include <time.h>
diff --git a/devel/gconf2/files/patch-configure b/devel/gconf2/files/patch-configure
index b4a36bc497de..b41b752d81f0 100644
--- a/devel/gconf2/files/patch-configure
+++ b/devel/gconf2/files/patch-configure
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- configure.orig Fri Apr 26 12:18:08 2002
-+++ configure Fri Apr 26 12:18:36 2002
-@@ -6797,6 +6797,7 @@
+--- configure.orig Sat May 3 13:11:21 2003
++++ configure Sun Jun 15 01:22:52 2003
+@@ -8029,6 +8029,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -11,12 +8,3 @@ $FreeBSD$
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -7513,7 +7514,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-
-- for db3libs in "-ldb-3.3" "-ldb-3.2" "-ldb-3.1" "-ldb-3"; do
-+ for db3libs in "-ldb-3.3" "-ldb-3.2" "-ldb-3.1" "-ldb-3" "-ldb3"; do
- if test "x${with_db3_libs}" != "x"; then
- LIBS="$LIBS -L$with_db3_libs $db3libs"
- else
diff --git a/devel/gconf2/files/patch-gconf::gconf-internals.c b/devel/gconf2/files/patch-gconf::gconf-internals.c
deleted file mode 100644
index cc04f6913284..000000000000
--- a/devel/gconf2/files/patch-gconf::gconf-internals.c
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- gconf/gconf-internals.c 2002/02/15 19:13:07 1.1
-+++ gconf/gconf-internals.c 2002/02/15 19:13:32
-@@ -26,6 +26,9 @@
- #include <string.h>
- #include <sys/stat.h>
- #include <sys/types.h>
-+#include <sys/socket.h>
-+#include <netinet/in.h>
-+#include <arpa/inet.h>
- #include <unistd.h>
- #include <stdlib.h>
- #include <stdio.h>
diff --git a/devel/gconf2/pkg-descr b/devel/gconf2/pkg-descr
index c4f8b27a2d51..0658ef70fa28 100644
--- a/devel/gconf2/pkg-descr
+++ b/devel/gconf2/pkg-descr
@@ -1,4 +1,22 @@
-GConf is a configuration database system for the GNOME desktop,
-functionally similar to the Windows registry but lots better :-)
+GConf attempts to leapfrog the registry concept. It's a library which provides
+a simple configuration data storage interface to applications, and also an
+architecture that tries to make things easy for system administrators.
+
+Here are some of the features of GConf:
+
+ * Replaceable backend architecture.
+
+ * Configuration key documentation. Applications can install documentation
+ along with their configuration data, explaining the possible settings and
+ the effect of each configuration key.
+
+ * Data change notification service. If configuration data is changed, all
+ interested applications are notified. The notification service works
+ across the network, affecting all login sessions for a single user.
+
+ * The client API is very abstract.
+
+ * GConf does proper locking so that the configuration data doesn't get
+ corrupted when multiple applications try to use it.
WWW: http://www.gnome.org/projects/gconf/
diff --git a/devel/gconf2/pkg-plist b/devel/gconf2/pkg-plist
index 9057dc4c4ae5..cc70f2842c6a 100644
--- a/devel/gconf2/pkg-plist
+++ b/devel/gconf2/pkg-plist
@@ -22,8 +22,10 @@ share/locale/ar/LC_MESSAGES/GConf2.mo
share/locale/az/LC_MESSAGES/GConf2.mo
share/locale/be/LC_MESSAGES/GConf2.mo
share/locale/bg/LC_MESSAGES/GConf2.mo
+share/locale/bn/LC_MESSAGES/GConf2.mo
share/locale/ca/LC_MESSAGES/GConf2.mo
share/locale/cs/LC_MESSAGES/GConf2.mo
+share/locale/cy/LC_MESSAGES/GConf2.mo
share/locale/da/LC_MESSAGES/GConf2.mo
share/locale/de/LC_MESSAGES/GConf2.mo
share/locale/el/LC_MESSAGES/GConf2.mo
@@ -36,6 +38,7 @@ share/locale/ga/LC_MESSAGES/GConf2.mo
share/locale/gl/LC_MESSAGES/GConf2.mo
share/locale/hi/LC_MESSAGES/GConf2.mo
share/locale/hu/LC_MESSAGES/GConf2.mo
+share/locale/id/LC_MESSAGES/GConf2.mo
share/locale/it/LC_MESSAGES/GConf2.mo
share/locale/ja/LC_MESSAGES/GConf2.mo
share/locale/ko/LC_MESSAGES/GConf2.mo
@@ -54,6 +57,7 @@ share/locale/ro/LC_MESSAGES/GConf2.mo
share/locale/ru/LC_MESSAGES/GConf2.mo
share/locale/sk/LC_MESSAGES/GConf2.mo
share/locale/sl/LC_MESSAGES/GConf2.mo
+share/locale/sq/LC_MESSAGES/GConf2.mo
share/locale/sr/LC_MESSAGES/GConf2.mo
share/locale/sr@Latn/LC_MESSAGES/GConf2.mo
share/locale/sv/LC_MESSAGES/GConf2.mo
@@ -64,8 +68,8 @@ share/locale/yi/LC_MESSAGES/GConf2.mo
share/locale/zh_CN/LC_MESSAGES/GConf2.mo
share/locale/zh_TW/LC_MESSAGES/GConf2.mo
share/sgml/gconf/gconf-1.0.dtd
-@dirrm share/sgml/gconf
@dirrm share/doc/gconf
+@dirrm share/sgml/gconf
@dirrm lib/GConf/2
@dirrm include/gconf/2/gconf
@dirrm include/gconf/2