aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /devel/gconf2
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
Notes
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile17
-rw-r--r--devel/gconf2/distinfo6
-rw-r--r--devel/gconf2/files/patch-gsettings_gconfsettingsbackend.c9
-rw-r--r--devel/gconf2/pkg-plist13
4 files changed, 37 insertions, 8 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index ce1fb0e060e8..9443a9a741e6 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -3,12 +3,12 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gconf2/Makefile,v 1.111 2010/04/01 15:59:40 kwm Exp $
+# $MCom: ports/devel/gconf2/Makefile,v 1.124 2010/11/15 22:14:03 kwm Exp $
#
PORTNAME= gconf2
-PORTVERSION= 2.28.1
-PORTREVISION?= 1
+PORTVERSION= 2.32.0
+PORTREVISION?= 2
CATEGORIES= devel gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/GConf/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -20,6 +20,9 @@ COMMENT= A configuration database system for GNOME
USE_BZIP2= yes
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
.if !defined(REFERENCE_PORT)
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
@@ -28,7 +31,7 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
USE_GMAKE= yes
USE_GETTEXT= yes
USE_GNOME= gnomehier gnomehack orbit2 gtk20 libxml2 ltverhack \
- referencehack intlhack
+ referencehack intlhack dconf
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
@@ -37,7 +40,8 @@ CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= gconftool-2.1
+MAN1= gconftool-2.1 gsettings-data-convert.1 \
+ gsettings-schema-convert.1
OPTIONS= LDAP "Enable LDAP support" off
@@ -52,6 +56,9 @@ CONFIGURE_ARGS+=--without-openldap
PLIST_SUB+= LDAP="@comment "
.endif
+post-install:
+ -${LOCALBASE}/bin/gio-querymodules ${PREFIX}/lib/gio/modules
+
.include <bsd.port.post.mk>
.endif
diff --git a/devel/gconf2/distinfo b/devel/gconf2/distinfo
index d216af850702..b7d4f13db58d 100644
--- a/devel/gconf2/distinfo
+++ b/devel/gconf2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/GConf-2.28.1.tar.bz2) = 27663faf0af4f6a6d534de9270f6d24a
-SHA256 (gnome2/GConf-2.28.1.tar.bz2) = 53c477f9086057b0c84816a1c979e01537b862fbcacb6af4b62f8cffec4b3000
-SIZE (gnome2/GConf-2.28.1.tar.bz2) = 1476141
+MD5 (gnome2/GConf-2.32.0.tar.bz2) = b161da6a1ab090b649aed3111003b0bb
+SHA256 (gnome2/GConf-2.32.0.tar.bz2) = 54dd1dd7f49928a9cc42574bef6ef0481753770fc19986dc2004bbb7fac977a0
+SIZE (gnome2/GConf-2.32.0.tar.bz2) = 1541688
diff --git a/devel/gconf2/files/patch-gsettings_gconfsettingsbackend.c b/devel/gconf2/files/patch-gsettings_gconfsettingsbackend.c
new file mode 100644
index 000000000000..9742e9e91d2a
--- /dev/null
+++ b/devel/gconf2/files/patch-gsettings_gconfsettingsbackend.c
@@ -0,0 +1,9 @@
+--- gsettings/gconfsettingsbackend.c.orig 2010-11-14 12:54:57.000000000 -0500
++++ gsettings/gconfsettingsbackend.c 2010-11-14 12:55:08.000000000 -0500
+@@ -924,5 +924,5 @@ gconf_settings_backend_register (GIOModu
+ g_io_extension_point_implement (G_SETTINGS_BACKEND_EXTENSION_POINT_NAME,
+ GCONF_TYPE_SETTINGS_BACKEND,
+ "gconf",
+- -1);
++ 10);
+ }
diff --git a/devel/gconf2/pkg-plist b/devel/gconf2/pkg-plist
index eb8bec29974a..010cc2f6ca21 100644
--- a/devel/gconf2/pkg-plist
+++ b/devel/gconf2/pkg-plist
@@ -1,8 +1,11 @@
bin/gconf-merge-tree
bin/gconftool-2
+bin/gsettings-data-convert
+bin/gsettings-schema-convert
etc/dbus-1/system.d/org.gnome.GConf.Defaults.conf
%%LDAP%%etc/gconf/2/evoldap.conf
etc/gconf/2/path
+etc/xdg/autostart/gsettings-data-convert.desktop
include/gconf/2/gconf/gconf-changeset.h
include/gconf/2/gconf/gconf-client.h
include/gconf/2/gconf/gconf-engine.h
@@ -22,6 +25,10 @@ lib/GConf/2/libgconfbackend-oldxml.so
lib/GConf/2/libgconfbackend-xml.a
lib/GConf/2/libgconfbackend-xml.la
lib/GConf/2/libgconfbackend-xml.so
+lib/girepository-1.0/GConf-2.0.typelib
+lib/gio/modules/libgsettingsgconfbackend.a
+lib/gio/modules/libgsettingsgconfbackend.la
+lib/gio/modules/libgsettingsgconfbackend.so
lib/libgconf-2.a
lib/libgconf-2.la
lib/libgconf-2.so
@@ -33,6 +40,7 @@ libexec/gconfd-2
share/aclocal/gconf-2.m4
share/dbus-1/system-services/org.gnome.GConf.Defaults.service
share/dbus-1/services/org.gnome.GConf.service
+share/gir-1.0/GConf-2.0.gir
share/locale/am/LC_MESSAGES/GConf2.mo
share/locale/ar/LC_MESSAGES/GConf2.mo
share/locale/as/LC_MESSAGES/GConf2.mo
@@ -67,6 +75,7 @@ share/locale/he/LC_MESSAGES/GConf2.mo
share/locale/hi/LC_MESSAGES/GConf2.mo
share/locale/hr/LC_MESSAGES/GConf2.mo
share/locale/hu/LC_MESSAGES/GConf2.mo
+share/locale/hy/LC_MESSAGES/GConf2.mo
share/locale/id/LC_MESSAGES/GConf2.mo
share/locale/is/LC_MESSAGES/GConf2.mo
share/locale/it/LC_MESSAGES/GConf2.mo
@@ -148,6 +157,8 @@ share/sgml/gconf/gconf-1.0.dtd
@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
@dirrmtry share/locale/en@shaw/LC_MESSAGES
@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES
@@ -160,3 +171,5 @@ share/sgml/gconf/gconf-1.0.dtd
@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
+@exec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true
+@unexec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true