aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /devel/gconf2
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
downloadports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.tar.gz
ports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.zip
Notes
Diffstat (limited to 'devel/gconf2')
-rw-r--r--devel/gconf2/Makefile15
-rw-r--r--devel/gconf2/distinfo4
-rw-r--r--devel/gconf2/files/patch-configure10
-rw-r--r--devel/gconf2/pkg-descr28
-rw-r--r--devel/gconf2/pkg-install16
-rw-r--r--devel/gconf2/pkg-plist43
6 files changed, 79 insertions, 37 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 0683c72397e2..846df9bc8bc6 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gconf2
-PORTVERSION= 2.4.0.1
-PORTREVISION= 1
+PORTVERSION= 2.6.0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/GConf/2.4
+MASTER_SITE_SUBDIR= sources/GConf/2.6
DISTNAME= GConf-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,17 +19,17 @@ COMMENT= A configuration database system for GNOME
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomehier orbit2 gtk20 libxml2 linc
+USE_GNOME= gnomehack lthack gnomehier orbit2 gtk20 libxml2 linc
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=13
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAN1= gconftool-2.1
+
post-install:
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/apps
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/schemas/apps
- @${MKDIR} ${PREFIX}/etc/gconf/schemas
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>
diff --git a/devel/gconf2/distinfo b/devel/gconf2/distinfo
index bc16309ebbcc..a49004abc172 100644
--- a/devel/gconf2/distinfo
+++ b/devel/gconf2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/GConf-2.4.0.1.tar.bz2) = 2f7548d0bad24d7c4beba54d0ec98a20
-SIZE (gnome2/GConf-2.4.0.1.tar.bz2) = 1288876
+MD5 (gnome2/GConf-2.6.0.tar.bz2) = 241ca25941e5bfa0f71725c30e17ab6e
+SIZE (gnome2/GConf-2.6.0.tar.bz2) = 1428714
diff --git a/devel/gconf2/files/patch-configure b/devel/gconf2/files/patch-configure
deleted file mode 100644
index b41b752d81f0..000000000000
--- a/devel/gconf2/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sat May 3 13:11:21 2003
-+++ configure Sun Jun 15 01:22:52 2003
-@@ -8029,6 +8029,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/gconf2/pkg-descr b/devel/gconf2/pkg-descr
index 0658ef70fa28..010cc810ef32 100644
--- a/devel/gconf2/pkg-descr
+++ b/devel/gconf2/pkg-descr
@@ -1,22 +1,18 @@
-GConf attempts to leapfrog the registry concept. It's a library which provides
-a simple configuration data storage interface to applications, and also an
-architecture that tries to make things easy for system administrators.
+GConf extends the concept of a configuration registry. It provides
+a simple way for applications and administrators to store data;
+often GConf is used to store preferences for applications.
-Here are some of the features of GConf:
+Some of the features of GConf are:
+GConf provides:
- * Replaceable backend architecture.
+ * Documentation for each configuration key, so that administrators
+ can better modify the value.
- * Configuration key documentation. Applications can install documentation
- along with their configuration data, explaining the possible settings and
- the effect of each configuration key.
+ * Notifications to interested applications when configuration data
+ is changed. The notification service works across networks,
+ affecting all login sessions for a single user.
- * Data change notification service. If configuration data is changed, all
- interested applications are notified. The notification service works
- across the network, affecting all login sessions for a single user.
-
- * The client API is very abstract.
-
- * GConf does proper locking so that the configuration data doesn't get
- corrupted when multiple applications try to use it.
+ * Proper locking so that configuration data doesn't get corrupted
+ when accessed by multiple applications at the same time.
WWW: http://www.gnome.org/projects/gconf/
diff --git a/devel/gconf2/pkg-install b/devel/gconf2/pkg-install
new file mode 100644
index 000000000000..13898d569f3a
--- /dev/null
+++ b/devel/gconf2/pkg-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+PATH=/bin:/usr/bin:/usr/sbin
+
+case $2 in
+POST-INSTALL)
+ dirs="etc/gconf/gconf.xml.defaults/apps \
+ etc/gconf/gconf.xml.defaults/schemas/apps \
+ etc/gconf/schemas"
+ for i in ${dirs}; do
+ mkdir -p ${PKG_PREFIX}/${i}
+ done
+ ;;
+esac
+
+exit 0
diff --git a/devel/gconf2/pkg-plist b/devel/gconf2/pkg-plist
index cc70f2842c6a..adf99d563086 100644
--- a/devel/gconf2/pkg-plist
+++ b/devel/gconf2/pkg-plist
@@ -1,3 +1,4 @@
+bin/gconf-merge-tree
bin/gconftool-2
etc/gconf/2/path
include/gconf/2/gconf/gconf-changeset.h
@@ -9,6 +10,7 @@ include/gconf/2/gconf/gconf-listeners.h
include/gconf/2/gconf/gconf-schema.h
include/gconf/2/gconf/gconf-value.h
include/gconf/2/gconf/gconf.h
+lib/GConf/2/libgconfbackend-oldxml.so
lib/GConf/2/libgconfbackend-xml.so
lib/libgconf-2.a
lib/libgconf-2.so
@@ -17,6 +19,41 @@ libdata/pkgconfig/gconf-2.0.pc
libexec/gconf-sanity-check-2
libexec/gconfd-2
share/aclocal/gconf-2.m4
+share/doc/gconf/GConfClient.html
+share/doc/gconf/ch01.html
+share/doc/gconf/ch01s02.html
+share/doc/gconf/ch02.html
+share/doc/gconf/ch02s02.html
+share/doc/gconf/ch02s03.html
+share/doc/gconf/ch02s04.html
+share/doc/gconf/ch06.html
+share/doc/gconf/ch06s02.html
+share/doc/gconf/ch06s03.html
+share/doc/gconf/ch07.html
+share/doc/gconf/conventions.html
+share/doc/gconf/gconf-client-reference.html
+share/doc/gconf/gconf-client.html
+share/doc/gconf/gconf-gconf-backend.html
+share/doc/gconf/gconf-gconf-changeset.html
+share/doc/gconf/gconf-gconf-engine.html
+share/doc/gconf/gconf-gconf-error.html
+share/doc/gconf/gconf-gconf-internals.html
+share/doc/gconf/gconf-gconf-listeners.html
+share/doc/gconf/gconf-gconf-locale.html
+share/doc/gconf/gconf-gconf-schema.html
+share/doc/gconf/gconf-gconf-sources.html
+share/doc/gconf/gconf-gconf-value.html
+share/doc/gconf/gconf-gconf.html
+share/doc/gconf/gconf-internals-reference.html
+share/doc/gconf/gconf-reference.html
+share/doc/gconf/gconf.devhelp
+share/doc/gconf/gconftool.html
+share/doc/gconf/home.png
+share/doc/gconf/index.html
+share/doc/gconf/index.sgml
+share/doc/gconf/left.png
+share/doc/gconf/right.png
+share/doc/gconf/up.png
share/locale/am/LC_MESSAGES/GConf2.mo
share/locale/ar/LC_MESSAGES/GConf2.mo
share/locale/az/LC_MESSAGES/GConf2.mo
@@ -29,6 +66,7 @@ share/locale/cy/LC_MESSAGES/GConf2.mo
share/locale/da/LC_MESSAGES/GConf2.mo
share/locale/de/LC_MESSAGES/GConf2.mo
share/locale/el/LC_MESSAGES/GConf2.mo
+share/locale/en_GB/LC_MESSAGES/GConf2.mo
share/locale/es/LC_MESSAGES/GConf2.mo
share/locale/eu/LC_MESSAGES/GConf2.mo
share/locale/fa/LC_MESSAGES/GConf2.mo
@@ -37,11 +75,13 @@ share/locale/fr/LC_MESSAGES/GConf2.mo
share/locale/ga/LC_MESSAGES/GConf2.mo
share/locale/gl/LC_MESSAGES/GConf2.mo
share/locale/hi/LC_MESSAGES/GConf2.mo
+share/locale/hr/LC_MESSAGES/GConf2.mo
share/locale/hu/LC_MESSAGES/GConf2.mo
share/locale/id/LC_MESSAGES/GConf2.mo
share/locale/it/LC_MESSAGES/GConf2.mo
share/locale/ja/LC_MESSAGES/GConf2.mo
share/locale/ko/LC_MESSAGES/GConf2.mo
+share/locale/lt/LC_MESSAGES/GConf2.mo
share/locale/lv/LC_MESSAGES/GConf2.mo
share/locale/mk/LC_MESSAGES/GConf2.mo
share/locale/ml/LC_MESSAGES/GConf2.mo
@@ -61,6 +101,7 @@ share/locale/sq/LC_MESSAGES/GConf2.mo
share/locale/sr/LC_MESSAGES/GConf2.mo
share/locale/sr@Latn/LC_MESSAGES/GConf2.mo
share/locale/sv/LC_MESSAGES/GConf2.mo
+share/locale/ta/LC_MESSAGES/GConf2.mo
share/locale/tr/LC_MESSAGES/GConf2.mo
share/locale/uk/LC_MESSAGES/GConf2.mo
share/locale/vi/LC_MESSAGES/GConf2.mo
@@ -68,8 +109,8 @@ share/locale/yi/LC_MESSAGES/GConf2.mo
share/locale/zh_CN/LC_MESSAGES/GConf2.mo
share/locale/zh_TW/LC_MESSAGES/GConf2.mo
share/sgml/gconf/gconf-1.0.dtd
-@dirrm share/doc/gconf
@dirrm share/sgml/gconf
+@dirrm share/doc/gconf
@dirrm lib/GConf/2
@dirrm include/gconf/2/gconf
@dirrm include/gconf/2