aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /devel/gconf
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
Notes
Diffstat (limited to 'devel/gconf')
-rw-r--r--devel/gconf/Makefile15
-rw-r--r--devel/gconf/files/patch-ab19
-rw-r--r--devel/gconf/pkg-plist15
3 files changed, 4 insertions, 45 deletions
diff --git a/devel/gconf/Makefile b/devel/gconf/Makefile
index b1966b2f565a..0942f6960dd9 100644
--- a/devel/gconf/Makefile
+++ b/devel/gconf/Makefile
@@ -16,28 +16,21 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile \
- oaf.0:${PORTSDIR}/devel/oaf \
db3.2:${PORTSDIR}/databases/db3
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack glib12 gtk12 oaf libxml orbit
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-
-post-install:
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/apps
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/schemas/apps
.include <bsd.port.mk>
diff --git a/devel/gconf/files/patch-ab b/devel/gconf/files/patch-ab
deleted file mode 100644
index 032c7e5eab94..000000000000
--- a/devel/gconf/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile.in.orig Mon May 14 13:07:48 2001
-+++ Makefile.in Mon May 21 23:29:41 2001
-@@ -37,3 +37,3 @@
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/pkgconfig
- pkgincludedir = $(includedir)/@PACKAGE@
-@@ -144,3 +144,3 @@
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(pkglibdir)
- pkgconfig_DATA = gconf.pc gconfgtk.pc
-@@ -476,4 +476,4 @@
- install-data-local:
-- -mkdir -p $(DESTDIR)$(datadir)/aclocal
-- $(INSTALL_DATA) gconf.m4 $(DESTDIR)$(datadir)/aclocal/gconf-$(MAJOR_VERSION).m4
-+ -mkdir -p $(DESTDIR)$(prefix)/share/aclocal
-+ $(INSTALL_DATA) gconf.m4 $(DESTDIR)$(prefix)/share/aclocal/gconf-$(MAJOR_VERSION).m4
- @echo "**** NOTE ****"
diff --git a/devel/gconf/pkg-plist b/devel/gconf/pkg-plist
index 1194779e1795..a34b17e3c391 100644
--- a/devel/gconf/pkg-plist
+++ b/devel/gconf/pkg-plist
@@ -61,18 +61,3 @@ share/locale/zh_CN/LC_MESSAGES/GConf.mo
@dirrm include/gconf/1/gconf
@dirrm include/gconf/1
@dirrm etc/gconf/1
-@exec /bin/mkdir -p %D/etc/gconf/gconf.xml.defaults/apps
-@exec /bin/mkdir -p %D/etc/gconf/gconf.xml.defaults/schemas/apps
-@unexec /bin/rmdir %D/lib/GConf 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/include/gconf 2>/dev/null || /usr/bin/true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/apps/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/schemas/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/schemas/apps/%%gconf.xml 2>/dev/null || true
-@unexec /bin/rmdir %D/etc/gconf/schemas 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.mandatory 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/schemas/apps 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/schemas 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/apps 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf 2>/dev/null || /usr/bin/true