aboutsummaryrefslogtreecommitdiff
path: root/devel/gcvs/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-03-31 11:42:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-03-31 11:42:00 +0000
commit510a40326405f58793d94403263d20c16d3d6c09 (patch)
treef9e65ef448608c75631215b57b1117b8c3214f90 /devel/gcvs/Makefile
parent42e0c7c84e3b4b2d0c259ae3aab83389ab705e31 (diff)
downloadports-510a40326405f58793d94403263d20c16d3d6c09.tar.gz
ports-510a40326405f58793d94403263d20c16d3d6c09.zip
Notes
Diffstat (limited to 'devel/gcvs/Makefile')
-rw-r--r--devel/gcvs/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
new file mode 100644
index 000000000000..db35fe848438
--- /dev/null
+++ b/devel/gcvs/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gvcs
+# Date Created: 28 Mar 2001
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gcvs
+PORTVERSION= 1.0a7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cvsgui
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+BUILD_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --with-tclinclude=${LOCALBASE}/include/tcl8.3
+CONFIGURE_ARGS+= --with-tcllib=${LOCALBASE}/lib/tcl8.3
+LIBS+= -lgnugetopt
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib/ ${LIBS}"
+MAN= cvs.1 cvs.5 cvsbug.8
+
+.include <bsd.port.mk>