aboutsummaryrefslogtreecommitdiff
path: root/devel/gcvs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-11-22 22:27:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-11-22 22:27:29 +0000
commita28acc2928274d9611dcd26224698b08c1caf31b (patch)
tree15bca7999952e7e761849fe0586359115f00ee53 /devel/gcvs
parent30b5dd545d4fdcfdc21942393e8815509097b0fa (diff)
downloadports-a28acc2928274d9611dcd26224698b08c1caf31b.tar.gz
ports-a28acc2928274d9611dcd26224698b08c1caf31b.zip
Notes
Diffstat (limited to 'devel/gcvs')
-rw-r--r--devel/gcvs/Makefile8
-rw-r--r--devel/gcvs/files/patch-common-UCvsFiles.cpp13
-rw-r--r--devel/gcvs/files/patch-common_AboutDlg.cpp16
-rw-r--r--devel/gcvs/files/patch-common_AppGlue.h13
-rw-r--r--devel/gcvs/files/patch-common_ImportDlg.cpp26
-rw-r--r--devel/gcvs/files/patch-common_ImportFilterDlg.cpp11
-rw-r--r--devel/gcvs/files/patch-common_LineCmd.cpp11
-rw-r--r--devel/gcvs/files/patch-common_LogDlg.cpp38
-rw-r--r--devel/gcvs/files/patch-common_MultiString.cpp11
-rw-r--r--devel/gcvs/files/patch-common_MultiString.h20
-rw-r--r--devel/gcvs/files/patch-common_Persistent.h15
-rw-r--r--devel/gcvs/files/patch-common_UCvsApp.cpp11
-rw-r--r--devel/gcvs/files/patch-common_UpdateDlg.cpp29
-rw-r--r--devel/gcvs/files/patch-common_cvsgui_process.cpp11
-rw-r--r--devel/gcvs/files/patch-common_getopt.c11
-rw-r--r--devel/gcvs/files/patch-cvsunix-configure.in29
-rw-r--r--devel/gcvs/files/patch-cvsunix-lib_regex.c11
-rw-r--r--devel/gcvs/files/patch-rf_uevent.cpp63
-rw-r--r--devel/gcvs/files/patch-rf_umain.h20
-rw-r--r--devel/gcvs/files/patch-rf_ustr.cpp10
-rw-r--r--devel/gcvs/files/patch-rf_ustr.h20
-rw-r--r--devel/gcvs/files/patch-rf_utoolbar.cpp28
-rw-r--r--devel/gcvs/files/patch-rf_utoolbar.h11
-rw-r--r--devel/gcvs/files/patch-rf_uwidget.cpp168
-rw-r--r--devel/gcvs/files/patch-rf_uwidget.h11
25 files changed, 603 insertions, 12 deletions
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index c96450c15a2b..539a07e48121 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -33,10 +33,4 @@ MAN8= cvsbug.8
INFO= cvs cvsclient
USE_AUTOTOOLS= automake:15:env autoconf:261:env
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/gcvs/files/patch-common-UCvsFiles.cpp b/devel/gcvs/files/patch-common-UCvsFiles.cpp
index 5e3a1be42966..2a80abfe30fe 100644
--- a/devel/gcvs/files/patch-common-UCvsFiles.cpp
+++ b/devel/gcvs/files/patch-common-UCvsFiles.cpp
@@ -1,5 +1,14 @@
---- common/UCvsFiles.cpp.orig Tue Aug 13 13:46:40 2002
-+++ common/UCvsFiles.cpp Sun Aug 24 13:47:21 2003
+--- common/UCvsFiles.cpp.orig 2002-08-13 13:46:40.000000000 +0200
++++ common/UCvsFiles.cpp 2007-11-22 21:01:27.000000000 +0100
+@@ -201,7 +201,7 @@
+
+ #define NUM_COLUMNS 7
+
+-static char *_gszColumnLabel[NUM_COLUMNS] =
++static const char *_gszColumnLabel[NUM_COLUMNS] =
+ {
+ "Name", "Rev.", "Option", "Status", "Tag", "Date", "Conflict"
+ };
@@ -1214,7 +1214,7 @@
{
UStr uppath, filename;
diff --git a/devel/gcvs/files/patch-common_AboutDlg.cpp b/devel/gcvs/files/patch-common_AboutDlg.cpp
new file mode 100644
index 000000000000..54c48fc832b3
--- /dev/null
+++ b/devel/gcvs/files/patch-common_AboutDlg.cpp
@@ -0,0 +1,16 @@
+--- common/AboutDlg.cpp.orig 2007-11-13 22:57:56.000000000 +0100
++++ common/AboutDlg.cpp 2007-11-13 22:59:13.000000000 +0100
+@@ -290,11 +290,11 @@
+ void AboutDialog(void)
+ {
+ void *wid = UCreate_AboutDlg();
+- UStr appText = UCvsApp::gApp->GetAppName();
++ const UStr appText = UCvsApp::gApp->GetAppName();
+
+ UAboutDlg *dlg = new UAboutDlg ();
+ UEventSendMessage(dlg->GetWidID(), EV_INIT_WIDGET, kUMainWidget, wid);
+- UEventSendMessage(dlg->GetWidID(), EV_SETTEXT, kUMainWidget, appText);
++ UEventSendMessage(dlg->GetWidID(), EV_SETTEXT, kUMainWidget, (const char *)appText);
+
+ bool res = false;
+
diff --git a/devel/gcvs/files/patch-common_AppGlue.h b/devel/gcvs/files/patch-common_AppGlue.h
new file mode 100644
index 000000000000..ca2b706f9c5f
--- /dev/null
+++ b/devel/gcvs/files/patch-common_AppGlue.h
@@ -0,0 +1,13 @@
+--- common/AppGlue.h.orig 2007-11-13 22:34:29.000000000 +0100
++++ common/AppGlue.h 2007-11-13 22:34:36.000000000 +0100
+@@ -30,8 +30,8 @@
+ class CCvsConsole
+ {
+ public:
+- virtual long cvs_out(char *txt, long len) = 0L;
+- virtual long cvs_err(char *txt, long len) = 0L;
++ virtual long cvs_out(char *txt, long len) = 0;
++ virtual long cvs_err(char *txt, long len) = 0;
+ };
+
+ #define errInternal -99
diff --git a/devel/gcvs/files/patch-common_ImportDlg.cpp b/devel/gcvs/files/patch-common_ImportDlg.cpp
new file mode 100644
index 000000000000..cb97c73ca138
--- /dev/null
+++ b/devel/gcvs/files/patch-common_ImportDlg.cpp
@@ -0,0 +1,26 @@
+--- common/ImportDlg.cpp.orig 2007-11-13 22:38:26.000000000 +0100
++++ common/ImportDlg.cpp 2007-11-13 22:49:01.000000000 +0100
+@@ -51,20 +51,20 @@
+ #include "PromptFiles.h"
+ #include "TextBinary.h"
+
+-static char *sDefReleases[] =
++static const char * const sDefReleases[] =
+ {
+ "V10",
+ "V101",
+ 0L
+ };
+
+-static char *sDefVendors[] =
++static const char * const sDefVendors[] =
+ {
+ "GNU",
+ 0L
+ };
+
+-static char *sDefModuleNames[] =
++static const char * const sDefModuleNames[] =
+ {
+ "Module",
+ "Project",
diff --git a/devel/gcvs/files/patch-common_ImportFilterDlg.cpp b/devel/gcvs/files/patch-common_ImportFilterDlg.cpp
new file mode 100644
index 000000000000..4ae691662f4f
--- /dev/null
+++ b/devel/gcvs/files/patch-common_ImportFilterDlg.cpp
@@ -0,0 +1,11 @@
+--- common/ImportFilterDlg.cpp.orig 2007-11-13 22:52:32.000000000 +0100
++++ common/ImportFilterDlg.cpp 2007-11-13 22:53:30.000000000 +0100
+@@ -892,7 +892,7 @@
+
+ #define NUM_COLUMNS 3
+
+-static char *_gszColumnLabel[NUM_COLUMNS] =
++static const char *_gszColumnLabel[NUM_COLUMNS] =
+ {
+ "Entry state", "Entry description", "Entry kind"
+ };
diff --git a/devel/gcvs/files/patch-common_LineCmd.cpp b/devel/gcvs/files/patch-common_LineCmd.cpp
new file mode 100644
index 000000000000..e1d825a610d2
--- /dev/null
+++ b/devel/gcvs/files/patch-common_LineCmd.cpp
@@ -0,0 +1,11 @@
+--- common/LineCmd.cpp.orig 2007-11-13 23:00:05.000000000 +0100
++++ common/LineCmd.cpp 2007-11-13 23:00:24.000000000 +0100
+@@ -49,7 +49,7 @@
+ # include "UCvsDialogs.h"
+ #endif
+
+-char *sDefPrevCvsCmd[] =
++const char *sDefPrevCvsCmd[] =
+ {
+ "cvs --help-options",
+ "cvs --help-commands",
diff --git a/devel/gcvs/files/patch-common_LogDlg.cpp b/devel/gcvs/files/patch-common_LogDlg.cpp
new file mode 100644
index 000000000000..08f2b96254f5
--- /dev/null
+++ b/devel/gcvs/files/patch-common_LogDlg.cpp
@@ -0,0 +1,38 @@
+--- common/LogDlg.cpp.orig 2007-11-13 23:54:34.000000000 +0100
++++ common/LogDlg.cpp 2007-11-13 23:54:59.000000000 +0100
+@@ -57,7 +57,7 @@
+ #include "CvsPrefs.h"
+ #include "MultiString.h"
+
+-char *sDefLogTagNames[] =
++const char *sDefLogTagNames[] =
+ {
+ "1.32:1.35",
+ "1.32:",
+@@ -67,7 +67,7 @@
+ 0L
+ };
+
+-char *sDefLogDateNames[] =
++const char *sDefLogDateNames[] =
+ {
+ ">1998-3-24",
+ "<1998-1-24",
+@@ -76,7 +76,7 @@
+ 0L
+ };
+
+-char *sDefLogStateNames[] =
++const char *sDefLogStateNames[] =
+ {
+ "mystate",
+ "dead",
+@@ -85,7 +85,7 @@
+ 0L
+ };
+
+-char *sDefLogUserNames[] =
++const char *sDefLogUserNames[] =
+ {
+ "johna",
+ "garyb",
diff --git a/devel/gcvs/files/patch-common_MultiString.cpp b/devel/gcvs/files/patch-common_MultiString.cpp
new file mode 100644
index 000000000000..6bb6adec4823
--- /dev/null
+++ b/devel/gcvs/files/patch-common_MultiString.cpp
@@ -0,0 +1,11 @@
+--- common/MultiString.cpp.orig 2007-11-13 23:07:12.000000000 +0100
++++ common/MultiString.cpp 2007-11-13 23:07:34.000000000 +0100
+@@ -40,7 +40,7 @@
+ #endif /* WIN32 */
+
+ template<class T>
+-TMString<T>::TMString(unsigned int maxstr, const char *uniqueName, char * const *defaultStr,
++TMString<T>::TMString(unsigned int maxstr, const char *uniqueName, const char * const *defaultStr,
+ kClassPersistent pclass) : CPersistent(uniqueName, pclass), fMaxStr(maxstr)
+ {
+ if(defaultStr != 0L)
diff --git a/devel/gcvs/files/patch-common_MultiString.h b/devel/gcvs/files/patch-common_MultiString.h
new file mode 100644
index 000000000000..bb123e1b77ca
--- /dev/null
+++ b/devel/gcvs/files/patch-common_MultiString.h
@@ -0,0 +1,20 @@
+--- common/MultiString.h.orig 2007-11-13 22:48:04.000000000 +0100
++++ common/MultiString.h 2007-11-13 22:50:02.000000000 +0100
+@@ -95,7 +95,7 @@
+ typedef NAMESPACE(std) vector<T> list_t;
+
+ TMString(unsigned int maxstr, const char *uniqueName,
+- char * const *defaultStr = 0L, kClassPersistent pclass = kNoClass);
++ const char * const *defaultStr = NULL, kClassPersistent pclass = kNoClass);
+ // defaultStr is a null terminated set of strings
+
+ virtual ~TMString();
+@@ -134,7 +134,7 @@
+ UDECLARE_DYNAMIC(CMString)
+ public:
+ CMString(unsigned int maxstr, const char *uniqueName,
+- char * const *defaultStr = 0L, kClassPersistent pclass = kNoClass) :
++ const char * const *defaultStr = NULL, kClassPersistent pclass = kNoClass) :
+ TMString<CStr>(maxstr, uniqueName, defaultStr, pclass)
+ {
+ }
diff --git a/devel/gcvs/files/patch-common_Persistent.h b/devel/gcvs/files/patch-common_Persistent.h
new file mode 100644
index 000000000000..94c64e3bbe3c
--- /dev/null
+++ b/devel/gcvs/files/patch-common_Persistent.h
@@ -0,0 +1,15 @@
+--- common/Persistent.h.orig 2007-11-13 22:33:34.000000000 +0100
++++ common/Persistent.h 2007-11-13 22:33:49.000000000 +0100
+@@ -47,9 +47,9 @@
+ CPersistent(const char *uniqueName, kClassPersistent pclass);
+ virtual ~CPersistent();
+
+- virtual unsigned int SizeOf(void) const = 0L;
+- virtual const void *GetData(void) const = 0L;
+- virtual void SetData(const void *ptr, unsigned int size) = 0L;
++ virtual unsigned int SizeOf(void) const = 0;
++ virtual const void *GetData(void) const = 0;
++ virtual void SetData(const void *ptr, unsigned int size) = 0;
+ // virtual access
+
+ static void SaveAll(void);
diff --git a/devel/gcvs/files/patch-common_UCvsApp.cpp b/devel/gcvs/files/patch-common_UCvsApp.cpp
new file mode 100644
index 000000000000..0c91e589d0f4
--- /dev/null
+++ b/devel/gcvs/files/patch-common_UCvsApp.cpp
@@ -0,0 +1,11 @@
+--- common/UCvsApp.cpp.orig 2007-11-22 20:23:41.000000000 +0100
++++ common/UCvsApp.cpp 2007-11-22 20:24:43.000000000 +0100
+@@ -364,7 +364,7 @@
+ res = read (parent_comm_pipes[0], &child_pid, sizeof (child_pid));
+ if (res != sizeof (child_pid))
+ {
+- g_message ("res is %d instead of %d", res,
++ g_message ("res is %d instead of %ld", res,
+ sizeof (child_pid));
+ child_pid = -1; /* really weird things happened */
+ }
diff --git a/devel/gcvs/files/patch-common_UpdateDlg.cpp b/devel/gcvs/files/patch-common_UpdateDlg.cpp
new file mode 100644
index 000000000000..08e3d34db333
--- /dev/null
+++ b/devel/gcvs/files/patch-common_UpdateDlg.cpp
@@ -0,0 +1,29 @@
+--- common/UpdateDlg.cpp.orig 2007-11-13 23:56:27.000000000 +0100
++++ common/UpdateDlg.cpp 2007-11-13 23:56:46.000000000 +0100
+@@ -56,7 +56,7 @@
+ # endif
+ #endif /* WIN32 */
+
+-char *sDefTagNames[] =
++const char *sDefTagNames[] =
+ {
+ "1.1",
+ "1.6.2.4",
+@@ -65,7 +65,7 @@
+ 0L
+ };
+
+-char *sDefDateNames[] =
++const char *sDefDateNames[] =
+ {
+ "1998-3",
+ "1998-3-24",
+@@ -76,7 +76,7 @@
+ 0L
+ };
+
+-char *sDefRevDateNames[] =
++const char *sDefRevDateNames[] =
+ {
+ "1.1",
+ "1.6.2.4",
diff --git a/devel/gcvs/files/patch-common_cvsgui_process.cpp b/devel/gcvs/files/patch-common_cvsgui_process.cpp
new file mode 100644
index 000000000000..b9b5aaa98ff8
--- /dev/null
+++ b/devel/gcvs/files/patch-common_cvsgui_process.cpp
@@ -0,0 +1,11 @@
+--- common/cvsgui_process.cpp.orig 2007-11-22 20:25:42.000000000 +0100
++++ common/cvsgui_process.cpp 2007-11-22 20:26:39.000000000 +0100
+@@ -899,7 +899,7 @@
+ CvsProcessCallbacks *callbacks = sigtt_cvs_process->callbacks;
+ // killing the cvs process avoids getting stuck in a SIGSTOP
+ cvs_process_destroy (sigtt_cvs_process);
+- callbacks->consoleerr(SIGTT_ERR, strlen(SIGTT_ERR));
++ callbacks->consoleerr((char *)SIGTT_ERR, strlen(SIGTT_ERR));
+ }
+ sigtt_cvs_process = NULL;
+ }
diff --git a/devel/gcvs/files/patch-common_getopt.c b/devel/gcvs/files/patch-common_getopt.c
new file mode 100644
index 000000000000..625c292a0aff
--- /dev/null
+++ b/devel/gcvs/files/patch-common_getopt.c
@@ -0,0 +1,11 @@
+--- common/getopt.c.orig 2007-11-13 23:33:47.000000000 +0100
++++ common/getopt.c 2007-11-13 23:34:27.000000000 +0100
+@@ -509,7 +509,7 @@
+ const struct option *pfound = NULL;
+ int exact = 0;
+ int ambig = 0;
+- int indfound;
++ int indfound = 0;
+ int option_index;
+
+ for (nameend = nextchar; *nameend && *nameend != '='; nameend++)
diff --git a/devel/gcvs/files/patch-cvsunix-configure.in b/devel/gcvs/files/patch-cvsunix-configure.in
index af3824b87088..1303440aaf0a 100644
--- a/devel/gcvs/files/patch-cvsunix-configure.in
+++ b/devel/gcvs/files/patch-cvsunix-configure.in
@@ -1,5 +1,5 @@
---- cvsunix/configure.in.orig Wed Nov 22 16:09:07 2006
-+++ cvsunix/configure.in Wed Nov 22 16:10:02 2006
+--- cvsunix/configure.in.orig 2001-03-06 20:23:49.000000000 +0100
++++ cvsunix/configure.in 2007-11-22 20:55:15.000000000 +0100
@@ -178,7 +178,7 @@
# the user's setting for LDFLAGS
hold_ldflags=$LDFLAGS
@@ -9,7 +9,19 @@
LDFLAGS=$hold_ldflags
if test -n "$krb_incdir"; then
includeopt="${includeopt} -I$krb_incdir"
-@@ -212,7 +212,7 @@
+@@ -202,27 +202,22 @@
+
+ hold_cppflags=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS -I$GSSAPI/include "
+-AC_CHECK_HEADERS(krb5.h gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
++AC_CHECK_HEADERS(krb5.h gssapi/gssapi.h gssapi/gssapi_generic.h)
+ CPPFLAGS=$hold_cppflags
+
+ if test "$ac_cv_header_krb5_h" = "yes" &&
+- (test "$ac_cv_header_gssapi_h" = "yes" ||
+- test "$ac_cv_header_gssapi_gssapi_h" = "yes"); then
++ test "$ac_cv_header_gssapi_gssapi_h" = "yes"; then
+ AC_DEFINE(HAVE_GSSAPI)
includeopt="${includeopt} -I$GSSAPI/include"
# FIXME: This is ugly, but these things don't seem to be standardized.
if test "$ac_cv_header_gssapi_h" = "yes"; then
@@ -18,3 +30,14 @@
else
LIBS="$LIBS -L$GSSAPI/lib -lgssapi_krb5 -lkrb5 -lcrypto -lcom_err"
fi
+ save_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="-I$GSSAPI/include $CPPFLAGS"
+- if test "$ac_cv_header_gssapi_h" = "yes"; then
+- AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
+- else
+- AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi/gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
+- fi
++ AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi/gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
+ CPPFLAGS=$save_CPPFLAGS
+ # This is necessary on Irix 5.3, in order to link against libkrb5 --
+ # there, an_to_ln.o refers to things defined only in -lgen.
diff --git a/devel/gcvs/files/patch-cvsunix-lib_regex.c b/devel/gcvs/files/patch-cvsunix-lib_regex.c
new file mode 100644
index 000000000000..7abc15e4cf02
--- /dev/null
+++ b/devel/gcvs/files/patch-cvsunix-lib_regex.c
@@ -0,0 +1,11 @@
+--- cvsunix/lib/regex.c.orig 2007-11-22 20:19:42.000000000 +0100
++++ cvsunix/lib/regex.c 2007-11-22 20:32:54.000000000 +0100
+@@ -4909,7 +4909,7 @@
+ /* Compare that many; failure if mismatch, else move
+ past them. */
+ if (RE_TRANSLATE_P (translate)
+- ? bcmp_translate (d, d2, mcnt, translate)
++ ? bcmp_translate ((unsigned char *)d, (unsigned char *)d2, mcnt, translate)
+ : bcmp (d, d2, mcnt))
+ goto fail;
+ d += mcnt, d2 += mcnt;
diff --git a/devel/gcvs/files/patch-rf_uevent.cpp b/devel/gcvs/files/patch-rf_uevent.cpp
new file mode 100644
index 000000000000..7cb77c073f42
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_uevent.cpp
@@ -0,0 +1,63 @@
+--- rf/uevent.cpp.orig 2001-09-19 07:13:09.000000000 +0200
++++ rf/uevent.cpp 2007-11-22 20:00:49.000000000 +0100
+@@ -196,7 +196,7 @@
+ int(UCmdTarget::*pfni_VP)(void *);
+ };
+
+-int UEventSendMessage(int wid, int/*UEventType*/ evt, int arg1, void *arg2)
++int UEventSendMessage(int wid, int/*UEventType*/ evt, int arg1, const void *arg2)
+ {
+ if(sTurnOffDispatching)
+ return 0;
+@@ -320,7 +320,7 @@
+ targets.erase(i);
+ }
+
+-int UCmdTarget::UDispatchMessage(int/*UEventType*/ evt, int arg1, void *arg2, UDispatchInfo & dispatchInfo)
++int UCmdTarget::UDispatchMessage(int/*UEventType*/ evt, int arg1, const void *arg2, UDispatchInfo & dispatchInfo)
+ {
+ const UMSGMAP* themap;
+ const UMSGMAP_ENTRY *entries;
+@@ -357,13 +357,13 @@
+ (this->*mmf.pfnV_V)();
+ break;
+ case epV_VP:
+- (this->*mmf.pfnV_VP)(arg2);
++ (this->*mmf.pfnV_VP)((void *)arg2);
+ break;
+ case epV_iVP:
+- (this->*mmf.pfnV_iVP)(arg1, arg2);
++ (this->*mmf.pfnV_iVP)(arg1, (void *)arg2);
+ break;
+ case epV_IVP:
+- (this->*mmf.pfnV_iVP)(UHIWORD(arg1), arg2);
++ (this->*mmf.pfnV_iVP)(UHIWORD(arg1), (void *)arg2);
+ break;
+ case epV_i:
+ (this->*mmf.pfnV_i)(arg1);
+@@ -375,10 +375,10 @@
+ (this->*mmf.pfnV_ii)(ULOWORD(arg1), UHIWORD(arg1));
+ break;
+ case epV_iii:
+- (this->*mmf.pfnV_iii)(ULOWORD(arg1), UHIWORD(arg1), (int)arg2);
++ (this->*mmf.pfnV_iii)(ULOWORD(arg1), UHIWORD(arg1), (size_t)arg2);
+ break;
+ case epV_iiVP:
+- (this->*mmf.pfnV_iiVP)(ULOWORD(arg1), UHIWORD(arg1), arg2);
++ (this->*mmf.pfnV_iiVP)(ULOWORD(arg1), UHIWORD(arg1), (void *)arg2);
+ break;
+ case epi_ii:
+ res = (this->*mmf.pfni_ii)(ULOWORD(arg1), UHIWORD(arg1));
+@@ -390,10 +390,10 @@
+ res = (this->*mmf.pfni_V)();
+ break;
+ case epi_iVP:
+- res = (this->*mmf.pfni_iVP)(arg1, arg2);
++ res = (this->*mmf.pfni_iVP)(arg1, (void *)arg2);
+ break;
+ case epi_VP:
+- res = (this->*mmf.pfni_VP)(arg2);
++ res = (this->*mmf.pfni_VP)((void *)arg2);
+ break;
+ default:
+ UAppConsole("Unknown event cast : %d\n", entries->nSig);
diff --git a/devel/gcvs/files/patch-rf_umain.h b/devel/gcvs/files/patch-rf_umain.h
new file mode 100644
index 000000000000..2b567cc16ded
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_umain.h
@@ -0,0 +1,20 @@
+--- rf/umain.h.orig 2002-01-02 17:46:33.000000000 +0100
++++ rf/umain.h 2007-11-14 00:02:57.000000000 +0100
+@@ -690,7 +690,7 @@
+ } UDispatchInfo;
+
+ //! dispatch an event using the static message table.
+- virtual int UDispatchMessage(int/*UEventType*/ evt, int arg1, void *arg2, UDispatchInfo & dispatchInfo);
++ virtual int UDispatchMessage(int/*UEventType*/ evt, int arg1, const void *arg2, UDispatchInfo & dispatchInfo);
+
+ inline int GetWidID(void) const { return m_widid; }
+ private:
+@@ -969,7 +969,7 @@
+ extern "C" {
+ #endif
+
+-UEXPORT int UEventSendMessage(int wid, int/*UEventType*/ evt, int arg1, void *arg2);
++UEXPORT int UEventSendMessage(int wid, int/*UEventType*/ evt, int arg1, const void *arg2);
+ /* send a message to a pseudo-widget */
+
+ UEXPORT int UEventSendMessageExt(int wid, int/*UEventType*/ evt, int arg1, void *arg2, int * handledFlag);
diff --git a/devel/gcvs/files/patch-rf_ustr.cpp b/devel/gcvs/files/patch-rf_ustr.cpp
new file mode 100644
index 000000000000..47ac45516bba
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_ustr.cpp
@@ -0,0 +1,10 @@
+--- rf/ustr.cpp.orig 2007-11-13 23:46:12.000000000 +0100
++++ rf/ustr.cpp 2007-11-13 23:46:29.000000000 +0100
+@@ -428,4 +428,5 @@
+ newvalue[len] = '\0';
+
+ return newvalue;
+-}
+\ No newline at end of file
++}
++
diff --git a/devel/gcvs/files/patch-rf_ustr.h b/devel/gcvs/files/patch-rf_ustr.h
new file mode 100644
index 000000000000..f602276b8f09
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_ustr.h
@@ -0,0 +1,20 @@
+--- rf/ustr.h.orig 2007-11-13 22:31:20.000000000 +0100
++++ rf/ustr.h 2007-11-13 22:32:08.000000000 +0100
+@@ -175,13 +175,13 @@
+ //! concatenate
+ UStr & operator<<(int addToStr);
+ //! concatenate
+- UStr & UStr::operator+=(int addToStr);
++ UStr & operator+=(int addToStr);
+ //! concatenate
+- UStr & UStr::operator+=(char *addToStr);
++ UStr & operator+=(char *addToStr);
+ //! concatenate
+- UStr & UStr::operator+=(const char *addToStr);
++ UStr & operator+=(const char *addToStr);
+ //! concatenate
+- UStr & UStr::operator+=(const UStr & addToStr);
++ UStr & operator+=(const UStr & addToStr);
+
+ //! compare
+ inline int compare(const char *thestr) const { return strcmp(*this, thestr); }
diff --git a/devel/gcvs/files/patch-rf_utoolbar.cpp b/devel/gcvs/files/patch-rf_utoolbar.cpp
new file mode 100644
index 000000000000..156657b503d2
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_utoolbar.cpp
@@ -0,0 +1,28 @@
+--- rf/utoolbar.cpp.orig 2002-06-15 19:49:37.000000000 +0200
++++ rf/utoolbar.cpp 2007-11-14 00:09:12.000000000 +0100
+@@ -736,14 +736,14 @@
+ delete m_winInfo;
+ }
+
+-int UToolbar::UDispatchMessage(int/*UEventType*/ evt, int arg1, void *arg2, UDispatchInfo & dispatchInfo)
++int UToolbar::UDispatchMessage(int/*UEventType*/ evt, int arg1, const void *arg2, UDispatchInfo & dispatchInfo)
+ {
+ if(evt == EV_CMD)
+ {
+ WININFO *info = m_winInfo;
+ if(info != 0L)
+ {
+- int index;
++ int index = 0;
+ std::vector<TbEntry *>::iterator f = info->Search(arg1, &index);
+ if(f != info->entries.end())
+ {
+@@ -772,7 +772,7 @@
+ if(info == 0L)
+ return;
+
+- int index;
++ int index = 0;
+ std::vector<TbEntry *>::iterator f = info->Search(cmd, &index);
+ if(f == info->entries.end())
+ return;
diff --git a/devel/gcvs/files/patch-rf_utoolbar.h b/devel/gcvs/files/patch-rf_utoolbar.h
new file mode 100644
index 000000000000..726a5ebffd6a
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_utoolbar.h
@@ -0,0 +1,11 @@
+--- rf/utoolbar.h.orig 2007-11-14 00:07:09.000000000 +0100
++++ rf/utoolbar.h 2007-11-14 00:07:18.000000000 +0100
+@@ -85,7 +85,7 @@
+ UToolbar(int widid);
+ virtual ~UToolbar();
+
+- virtual int UDispatchMessage(int/*UEventType*/ evt, int arg1, void *arg2, UDispatchInfo & dispatchInfo);
++ virtual int UDispatchMessage(int/*UEventType*/ evt, int arg1, const void *arg2, UDispatchInfo & dispatchInfo);
+
+ protected:
+ ev_msg void OnDestroy();
diff --git a/devel/gcvs/files/patch-rf_uwidget.cpp b/devel/gcvs/files/patch-rf_uwidget.cpp
new file mode 100644
index 000000000000..2fdabd535ed0
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_uwidget.cpp
@@ -0,0 +1,168 @@
+--- rf/uwidget.cpp.orig 2003-01-14 19:07:42.000000000 +0100
++++ rf/uwidget.cpp 2007-11-22 20:06:28.000000000 +0100
+@@ -231,23 +231,23 @@
+
+ static void gtkclicked(GtkButton *button, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ UEventSendMessage(widid, EV_CMD, cmdid, 0L);
+ }
+
+ static void gtkmenuitemactivate(GtkMenuItem *menuitem, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ UEventSendMessage(widid, EV_CMD, cmdid, 0L);
+ }
+
+ static void gtkselectclist(GtkWidget *clist, gint row, gint column,
+ GdkEventButton *event, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ gchar *text;
+ gtk_clist_get_text(GTK_CLIST(clist), row, column, &text);
+ UEventSendMessage(widid, EV_LIST_SELECTING, UMAKEINT(cmdid, row), text);
+@@ -255,15 +255,15 @@
+
+ static void gtkselectclistcolumn(GtkCList *clist, gint column, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ UEventSendMessage(widid, EV_LIST_SELCOLUMN, UMAKEINT(cmdid, column), 0L);
+ }
+
+ static gint gtkclistdblclick(GtkWidget *widget, GdkEventButton *event, gpointer data)
+ {
+- int widid = ULOWORD((int)data);
+- int cmdid = UHIWORD((int)data);
++ int widid = ULOWORD((size_t)data);
++ int cmdid = UHIWORD((size_t)data);
+ if (event->type == GDK_2BUTTON_PRESS)
+ {
+ UEventSendMessage(widid, EV_LIST_DBLCLICK, cmdid, 0L);
+@@ -274,8 +274,8 @@
+
+ static void gtkcomboclicked(GtkWidget *widget, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+
+ GtkList *list = GTK_LIST(widget->parent);
+ GList *selection = list->selection;
+@@ -320,8 +320,8 @@
+
+ static void gtkmenuactivated(GtkWidget *widget, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+
+ UStr selTxt;
+
+@@ -392,7 +392,7 @@
+ static void dataForeach(GQuark key_id, gpointer data, gpointer user_data)
+ {
+ const char *str = g_quark_to_string(key_id);
+- int id = (int)user_data;
++ size_t id = (size_t)user_data;
+ int cmd;
+ if(matchToken(str, cmd))
+ {
+@@ -514,32 +514,32 @@
+
+ static void gtktreeexpand(GtkWidget *item, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ g_assert(GTK_IS_TREE_ITEM(item));
+ UEventSendMessage(widid, EV_TREE_EXPANDING, UMAKEINT(cmdid, 0), item);
+ }
+
+ static void gtktreecollapse(GtkWidget *item, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ g_assert(GTK_IS_TREE_ITEM(item));
+ UEventSendMessage(widid, EV_TREE_EXPANDING, UMAKEINT(cmdid, 1), item);
+ }
+
+ static void gtktreeselect(GtkWidget *item, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ g_assert(GTK_IS_TREE_ITEM(item));
+ UEventSendMessage(widid, EV_TREE_SELECTING, UMAKEINT(cmdid, 0), item);
+ }
+
+ static void gtktreedeselect(GtkWidget *item, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+ g_assert(GTK_IS_TREE_ITEM(item));
+ UEventSendMessage(widid, EV_TREE_SELECTING, UMAKEINT(cmdid, 1), item);
+ }
+@@ -661,8 +661,8 @@
+ gint page_num,
+ gpointer data)
+ {
+- int widid = ULOWORD((int)data);
+- int cmdid = UHIWORD((int)data);
++ int widid = ULOWORD((size_t)data);
++ int cmdid = UHIWORD((size_t)data);
+
+ UEventSendMessage(widid, EV_PAGE_CHANGED, UMAKEINT(cmdid, page_num), 0L);
+ }
+@@ -682,8 +682,8 @@
+
+ static gint gtkexposeevent(GtkWidget *widget, GdkEvent *event, gpointer user_data)
+ {
+- int widid = ULOWORD((int)user_data);
+- int cmdid = UHIWORD((int)user_data);
++ int widid = ULOWORD((size_t)user_data);
++ int cmdid = UHIWORD((size_t)user_data);
+
+ UEventSendMessage(widid, EV_CUSTOM_DRAW, cmdid, event);
+ return TRUE;
+@@ -782,7 +782,7 @@
+ m_listeners.push_back(listener);
+ }
+
+-int UWidget::UDispatchMessage(int/*UEventType*/ evt, int arg1, void *arg2, UDispatchInfo & dispatchInfo)
++int UWidget::UDispatchMessage(int/*UEventType*/ evt, int arg1, const void *arg2, UDispatchInfo & dispatchInfo)
+ {
+ std::vector<UCmdTarget *>::iterator i;
+ for(i = m_listeners.begin(); i != m_listeners.end(); ++i)
+@@ -3136,10 +3136,10 @@
+ if(!GTK_IS_CLIST(w))
+ return;
+
+- gchar *emptyTxts[] = {"", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", ""};
++ const gchar *emptyTxts[] = {"", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", ""};
+
+ GtkCList *list = GTK_CLIST(w);
+- *num = gtk_clist_append (list, emptyTxts);
++ *num = gtk_clist_append (list, (gchar **)emptyTxts);
+ #endif
+ #if qMacAPP
+ TView *view = (TView *)w;
diff --git a/devel/gcvs/files/patch-rf_uwidget.h b/devel/gcvs/files/patch-rf_uwidget.h
new file mode 100644
index 000000000000..32ccca0377d8
--- /dev/null
+++ b/devel/gcvs/files/patch-rf_uwidget.h
@@ -0,0 +1,11 @@
+--- rf/uwidget.h.orig 2007-11-13 23:19:17.000000000 +0100
++++ rf/uwidget.h 2007-11-13 23:19:38.000000000 +0100
+@@ -119,7 +119,7 @@
+ virtual void AddListener(UCmdTarget * listener);
+
+ //! this is overided in order to broadcast to the listeners
+- virtual int UDispatchMessage(int/*UEventType*/ evt, int arg1, void *arg2, UDispatchInfo & dispatchInfo);
++ virtual int UDispatchMessage(int/*UEventType*/ evt, int arg1, const void *arg2, UDispatchInfo & dispatchInfo);
+
+ //! return a sub-widget as inserted by EV_INIT_WIDGET
+ //! \arg \c cmd the sub-widget identifier.