aboutsummaryrefslogtreecommitdiff
path: root/devel/gcvs
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-27 08:30:27 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-27 08:30:27 +0000
commitea6fe4fa96a1fa12c1a658b50293cc2dc3519f91 (patch)
treed81ad163416620edc5e9827dac85b659c9ec16dc /devel/gcvs
parentbcab33f9faeb1ae53659829bf26d7596060fdd4c (diff)
downloadports-ea6fe4fa96a1fa12c1a658b50293cc2dc3519f91.tar.gz
ports-ea6fe4fa96a1fa12c1a658b50293cc2dc3519f91.zip
Notes
Diffstat (limited to 'devel/gcvs')
-rw-r--r--devel/gcvs/Makefile6
-rw-r--r--devel/gcvs/files/patch-common_CommitDlg.cpp11
2 files changed, 12 insertions, 5 deletions
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index 3f89579884dc..984a32b9cdc8 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -13,10 +13,7 @@ COMMENT= High-end interface client for CVS
LICENSE= GPLv2
USE_GNOME= gtk12
-USE_TCL_BUILD= yes
-USE_TCL_WRAPPER=yes
-USE_TK_WRAPPER= yes
-USE_GMAKE= yes
+USES+= gmake tk:wrapper
USE_AUTOTOOLS= aclocal autoheader automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --force --copy --gnu
@@ -26,7 +23,6 @@ CONFIGURE_ARGS= --with-tclinclude=${TCL_INCLUDEDIR} \
--with-tcllib=${TCL_LIBDIR}
EXTRACT_AFTER_ARGS=--exclude cvsunix --exclude 'getline.[ch]' --exclude 'getopt*.[ch]'
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -E '/get(line|opt1?)\.[ch]/d' \
${WRKSRC}/common/Makefile.am
diff --git a/devel/gcvs/files/patch-common_CommitDlg.cpp b/devel/gcvs/files/patch-common_CommitDlg.cpp
new file mode 100644
index 000000000000..7a01ce3ea7e0
--- /dev/null
+++ b/devel/gcvs/files/patch-common_CommitDlg.cpp
@@ -0,0 +1,11 @@
+--- common/CommitDlg.cpp.orig 2013-09-27 10:14:52.000000000 +0200
++++ common/CommitDlg.cpp 2013-09-27 10:17:47.000000000 +0200
+@@ -22,6 +22,8 @@
+ * CommitDlg.cpp : the cvs commit dialog
+ */
+
++#define _WITH_GETLINE
++#include <stdio.h>
+ #include "stdafx.h"
+
+ #ifdef WIN32