aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb66
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2017-08-23 11:33:26 +0000
committerRene Ladan <rene@FreeBSD.org>2017-08-23 11:33:26 +0000
commita91d5178df4114be26eeba0ff55a2128df04df82 (patch)
tree057be916dadedc782d9c9c5e63bb95bb20bbc4b1 /devel/gdb66
parent6503031fc4196da04cf2e3f18690c3738a58fc12 (diff)
downloadports-a91d5178df4114be26eeba0ff55a2128df04df82.tar.gz
ports-a91d5178df4114be26eeba0ff55a2128df04df82.zip
Notes
Diffstat (limited to 'devel/gdb66')
-rw-r--r--devel/gdb66/Makefile117
-rw-r--r--devel/gdb66/distinfo4
-rw-r--r--devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk-hooks.c50
-rw-r--r--devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk.c58
-rw-r--r--devel/gdb66/files/itcl33-patch197
-rw-r--r--devel/gdb66/files/patch-gdb-amd64fbsd-nat.c15
-rw-r--r--devel/gdb66/files/patch-itcl11
-rw-r--r--devel/gdb66/files/patch-libiberty-basename11
-rw-r--r--devel/gdb66/files/patch-unified25
-rw-r--r--devel/gdb66/pkg-descr4
-rw-r--r--devel/gdb66/pkg-plist253
11 files changed, 0 insertions, 745 deletions
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
deleted file mode 100644
index 90fd2c8e58fc..000000000000
--- a/devel/gdb66/Makefile
+++ /dev/null
@@ -1,117 +0,0 @@
-# Created by: David O'Brien <obrien@NUXI.com>
-# $FreeBSD$
-
-PORTNAME= gdb
-PORTVERSION= 6.6
-PORTREVISION?= 6
-CATEGORIES= devel
-MASTER_SITES= GNU/gdb/ \
- http://aldan.algebra.com/~mi/:gdbtk
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
-
-MAINTAINER= mi@aldan.algebra.com
-COMMENT?= GNU GDB of newer version than comes with the system
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2017-08-23
-BROKEN_powerpc= Does not configure
-BROKEN_powerpc64= Does not build
-
-PKGNAMESUFFIX= 66
-
-OPTIONS_DEFINE= INSIGHT
-INSIGHT_DESC= Tcl/Tk GUI (experimental!)
-
-CONFLICTS?= gdb-[7-9]*
-USE_GCC= any
-USES= gettext iconv gmake readline tar:bzip2
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
-CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
- --disable-werror \
- --enable-target=all \
- --enable-tui ${ICONV_CONFIGURE_ARG}
-# remove consecutive blanks, which causes configure to fail
-CFLAGS!= echo ${CFLAGS}|sed -e 's/ / /g'
-CFLAGS+= -DRL_NO_COMPAT
-EXCLUDE= dejagnu expect readline sim texinfo intl
-EXTRACT_AFTER_ARGS= ${EXCLUDE:S/^/--exclude /}
-VER= ${PORTVERSION:S/.//}
-PLIST_SUB= VER=${VER}
-
-.include <bsd.port.options.mk>
-
-.if !exists(/usr/lib/libreadline.so)
-CFLAGS+= -Dreadline_echoing_p=_rl_echoing_p
-.endif
-
-.if ${PORT_OPTIONS:MINSIGHT}
-PKGNAMESUFFIX= -insight
-USES+= tk
-LIB_DEPENDS= libitk.so:x11-toolkits/itk
-RUN_DEPENDS= iwidgets>0:x11-toolkits/iwidgets
-DISTFILES+= gdbtk-6.6${EXTRACT_SUFX}:gdbtk
-PLIST_SUB+= INSIGHT=''
-EXTRA_PATCHES= ${FILESDIR}/itcl33-patch \
- ${FILESDIR}/extra-gdb-gdbtk-generic-gdbtk.c \
- ${FILESDIR}/extra-gdb-gdbtk-generic-gdbtk-hooks.c
-CONFIGURE_ARGS+=--enable-gdbtk \
- --with-tclconfig=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}/generic \
- --with-tkconfig=${TK_LIBDIR} \
- --with-tkinclude=${TK_INCLUDEDIR}/generic \
- --with-itclconfig=${LOCALBASE}/lib/itcl3.4 \
- --with-itkconfig=${LOCALBASE}/lib/itk3.3
-
-pre-everything::
- #
- # The Tk-based GUI (Insight) is patched to work with [incr tcl]
- # version 3.3 and is currently experimental. Bug reports should
- # be accompanied by patches.
- #
-
-pre-configure:
- ${MKDIR} ${WRKSRC}/itcl/generic
- ${LN} -s ${LOCALBASE}/include/itk3.3/*.h ${WRKSRC}/itcl/generic/
- ${LN} -s ${LOCALBASE}/include/itcl3.4/*.h ${WRKSRC}/itcl/generic/
-.else
-PLIST_SUB+= INSIGHT='@comment '
-CONFLICTS+= gdb-insight*
-.endif
-
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's/$$/ [GDB v${PORTVERSION} for FreeBSD]/' \
- ${WRKSRC}/gdb/version.in
- @${REINPLACE_CMD} -e 's/^READLINE/#READLINE/' \
- -e 's/^readline/#readline/' \
- -e 's,^LIBICONV =.*,LIBICONV=-L${LOCALBASE}/lib ${ICONV_LIB},' \
- ${WRKSRC}/gdb/Makefile.in
- ${ECHO} 'READLINE = -lreadline' >> ${WRKSRC}/gdb/Makefile.in
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${STAGEDIR}${PREFIX}/bin/gdb${VER}
- ${LN} -sf gdb${VER} ${STAGEDIR}${PREFIX}/bin/gdbtui${VER}
- ${INSTALL_MAN} ${WRKSRC}/gdb/gdb.1 ${STAGEDIR}${PREFIX}/man/man1/gdb${VER}.1
-.if ${PORT_OPTIONS:MINSIGHT}
- ${LN} -sf gdb${VER} ${STAGEDIR}${PREFIX}/bin/insight
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/redhat/gui
- ${CP} -p ${WRKSRC}/libgui/library/*.tcl \
- ${WRKSRC}/libgui/library/tclIndex \
- ${STAGEDIR}${PREFIX}/share/redhat/gui/
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/insight1.0
- ${CP} -Rp ${WRKSRC}/gdb/gdbtk/library/*.tcl \
- ${WRKSRC}/gdb/gdbtk/library/*.itcl \
- ${WRKSRC}/gdb/gdbtk/library/*.ith \
- ${WRKSRC}/gdb/gdbtk/library/*.itb \
- ${WRKSRC}/gdb/gdbtk/library/help \
- ${WRKSRC}/gdb/gdbtk/library/images* \
- ${WRKSRC}/gdb/gdbtk/library/tclIndex \
- ${STAGEDIR}${PREFIX}/lib/insight1.0
-.endif
-
-.include <bsd.port.mk>
diff --git a/devel/gdb66/distinfo b/devel/gdb66/distinfo
deleted file mode 100644
index 2923ca9746ab..000000000000
--- a/devel/gdb66/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (gdb-6.6.tar.bz2) = 6e602987298db5ddb479bbb84ce653eabd9c304957a49552245f65cdc70d43bd
-SIZE (gdb-6.6.tar.bz2) = 14535755
-SHA256 (gdbtk-6.6.tar.bz2) = 7dbbcb530f59ad93fd1566c38a29c4ff682243948297549ac37161427bdba9d8
-SIZE (gdbtk-6.6.tar.bz2) = 845174
diff --git a/devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk-hooks.c b/devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk-hooks.c
deleted file mode 100644
index 29796d8c7ae6..000000000000
--- a/devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk-hooks.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- gdb/gdbtk/generic/gdbtk-hooks.c.orig 2013-07-15 11:47:33.000000000 +0200
-+++ gdb/gdbtk/generic/gdbtk-hooks.c 2013-07-15 11:48:41.000000000 +0200
-@@ -254,13 +254,13 @@
- actual_len = 0;
- }
- else
-- actual_len = strlen (gdbtk_interp->result);
-+ actual_len = strlen (Tcl_GetStringResult(gdbtk_interp));
-
- /* Truncate the string if it is too big for the caller's buffer. */
- if (actual_len >= sizeof_buf)
- actual_len = sizeof_buf - 1;
-
-- memcpy (buf, gdbtk_interp->result, actual_len);
-+ memcpy (buf, Tcl_GetStringResult(gdbtk_interp), actual_len);
- buf[actual_len] = '\0';
- return actual_len;
- }
-@@ -505,11 +505,11 @@
-
- if (result == TCL_OK)
- {
-- return (xstrdup (gdbtk_interp->result));
-+ return (xstrdup (Tcl_GetStringResult(gdbtk_interp)));
- }
- else
- {
-- gdbtk_fputs (gdbtk_interp->result, gdb_stdout);
-+ gdbtk_fputs (Tcl_GetStringResult(gdbtk_interp), gdb_stdout);
- gdbtk_fputs ("\n", gdb_stdout);
- return (NULL);
- }
-@@ -633,7 +633,7 @@
- report_error ();
- free(buf);
-
-- return atoi (gdbtk_interp->result);
-+ return atoi (Tcl_GetStringResult(gdbtk_interp));
- }
-
-
-@@ -686,7 +686,7 @@
- gdbtk_two_elem_cmd ("gdbtk_tcl_query", buf);
- free(buf);
-
-- val = atol (gdbtk_interp->result);
-+ val = atol (Tcl_GetStringResult(gdbtk_interp));
- return val;
- }
-
diff --git a/devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk.c b/devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk.c
deleted file mode 100644
index 93029ba6d8c5..000000000000
--- a/devel/gdb66/files/extra-gdb-gdbtk-generic-gdbtk.c
+++ /dev/null
@@ -1,58 +0,0 @@
---- gdb/gdbtk/generic/gdbtk.c.orig 2013-07-15 11:44:12.000000000 +0200
-+++ gdb/gdbtk/generic/gdbtk.c 2013-07-15 11:45:50.000000000 +0200
-@@ -468,7 +468,7 @@
- Tcl_Free ((char *) exec_path);
-
- if (Tcl_Init (gdbtk_interp) != TCL_OK)
-- error ("Tcl_Init failed: %s", gdbtk_interp->result);
-+ error ("Tcl_Init failed: %s", Tcl_GetStringResult(gdbtk_interp));
-
- /* Set up some globals used by gdb to pass info to gdbtk
- for start up options and the like */
-@@ -486,23 +486,23 @@
-
- /* Initialize the Paths variable. */
- if (ide_initialize_paths (gdbtk_interp, "") != TCL_OK)
-- error ("ide_initialize_paths failed: %s", gdbtk_interp->result);
-+ error ("ide_initialize_paths failed: %s", Tcl_GetStringResult(gdbtk_interp));
-
- if (Tk_Init (gdbtk_interp) != TCL_OK)
-- error ("Tk_Init failed: %s", gdbtk_interp->result);
-+ error ("Tk_Init failed: %s", Tcl_GetStringResult(gdbtk_interp));
-
- if (Itcl_Init (gdbtk_interp) == TCL_ERROR)
-- error ("Itcl_Init failed: %s", gdbtk_interp->result);
-+ error ("Itcl_Init failed: %s", Tcl_GetStringResult(gdbtk_interp));
- Tcl_StaticPackage (gdbtk_interp, "Itcl", Itcl_Init,
- (Tcl_PackageInitProc *) NULL);
-
- if (Itk_Init (gdbtk_interp) == TCL_ERROR)
-- error ("Itk_Init failed: %s", gdbtk_interp->result);
-+ error ("Itk_Init failed: %s", Tcl_GetStringResult(gdbtk_interp));
- Tcl_StaticPackage (gdbtk_interp, "Itk", Itk_Init,
- (Tcl_PackageInitProc *) NULL);
-
- if (Tktable_Init (gdbtk_interp) != TCL_OK)
-- error ("Tktable_Init failed: %s", gdbtk_interp->result);
-+ error ("Tktable_Init failed: %s", Tcl_GetStringResult(gdbtk_interp));
-
- Tcl_StaticPackage (gdbtk_interp, "Tktable", Tktable_Init,
- (Tcl_PackageInitProc *) NULL);
-@@ -540,7 +540,7 @@
-
- if (Gdbtk_Init (gdbtk_interp) != TCL_OK)
- {
-- error ("Gdbtk_Init failed: %s", gdbtk_interp->result);
-+ error ("Gdbtk_Init failed: %s", Tcl_GetStringResult(gdbtk_interp));
- }
-
- Tcl_StaticPackage (gdbtk_interp, "Insight", Gdbtk_Init, NULL);
-@@ -719,7 +719,7 @@
-
- retval = Tcl_Eval (gdbtk_interp, cmd);
-
-- result = xstrdup (gdbtk_interp->result);
-+ result = xstrdup (Tcl_GetStringResult(gdbtk_interp));
-
- old_chain = make_cleanup (free, result);
-
diff --git a/devel/gdb66/files/itcl33-patch b/devel/gdb66/files/itcl33-patch
deleted file mode 100644
index f45871586dcb..000000000000
--- a/devel/gdb66/files/itcl33-patch
+++ /dev/null
@@ -1,197 +0,0 @@
---- gdb/gdbtk/library/tfind_args.tcl Sun Feb 6 19:19:42 2000
-+++ gdb/gdbtk/library/tfind_args.tcl Wed May 17 00:11:49 2006
-@@ -29,9 +29,10 @@
- # ----------------------------------------------------------------------
-
--itcl_class TfindArgs {
-+itcl::class TfindArgs {
- # ------------------------------------------------------------------
- # CONSTRUCTOR - create new tfind arguments dialog
- # ------------------------------------------------------------------
-- constructor {config} {
-+ constructor args {
-+ eval configure $args
- #
- # Create a window with the same name as this object
---- gdb/gdbtk/library/ehandler.itb Tue Oct 15 17:19:51 2002
-+++ gdb/gdbtk/library/ehandler.itb Wed May 17 00:12:55 2006
-@@ -23,5 +23,5 @@
-
- # invoke event handlers
-- foreach w [itcl_info objects -isa GDBEventHandler] {
-+ foreach w [itcl::find objects -isa GDBEventHandler] {
- dbug I "posting event \"$handler\" to \"$w\""
- if {[catch {$w $handler $event}]} {
---- gdb/gdbtk/library/managedwin.itb Fri Aug 27 19:13:14 2004
-+++ gdb/gdbtk/library/managedwin.itb Wed May 17 00:13:32 2006
-@@ -76,5 +76,5 @@
- itcl::body ManagedWin::window_instance {ins} {
- set win_instance $ins
-- foreach obj [itcl_info objects -isa ManagedWin] {
-+ foreach obj [itcl::find objects -isa ManagedWin] {
- debug "$obj ManagedWin::_wname"
- $obj window_name ""
-@@ -134,5 +134,5 @@
-
- # call the reconfig method for each object
-- foreach obj [itcl_info objects -isa ManagedWin] {
-+ foreach obj [itcl::find objects -isa ManagedWin] {
- if {[catch {$obj reconfig} msg]} {
- dbug W "reconfig failed for $obj - $msg"
-@@ -148,5 +148,5 @@
- itcl::body ManagedWin::shutdown {} {
- set activeWins {}
-- foreach win [itcl_info objects -isa ManagedWin] {
-+ foreach win [itcl::find objects -isa ManagedWin] {
- if {![$win isa ModalDialog] && ![$win _ignore_on_save]} {
- set g [wm geometry [winfo toplevel [namespace tail $win]]]
-@@ -221,5 +221,5 @@
- if {!$force} {
- # check all windows for one of this type
-- foreach obj [itcl_info objects -isa ManagedWin] {
-+ foreach obj [itcl::find objects -isa ManagedWin] {
- if {[$obj isa $class]} {
- $obj reveal
-@@ -364,5 +364,5 @@
- debug "$win"
- set res ""
-- foreach obj [itcl_info objects -isa ManagedWin] {
-+ foreach obj [itcl::find objects -isa ManagedWin] {
- if {[$obj isa $win]} {
- lappend res $obj
---- libgui/library/balloon.tcl Mon Feb 10 04:21:40 2003
-+++ libgui/library/balloon.tcl Thu Jun 28 15:39:09 2007
-@@ -8,34 +8,34 @@
- # * Likewise, balloon positioning on Windows is a hack.
-
--itcl_class Balloon {
-+itcl::class Balloon {
- # Name of associated global variable which should be set whenever
- # the help is shown.
-- public variable {}
-+ public variable variable {}
-
- # Name of associated toplevel. Private variable.
-- protected _top {}
-+ protected variable _top {}
-
- # This is non-empty if there is an after script pending. Private
- # method.
-- protected _after_id {}
-+ protected variable _after_id {}
-
- # This is an array mapping window name to help text.
-- protected _help_text
-+ protected variable _help_text
-
- # This is an array mapping window name to notification proc.
-- protected _notifiers
-+ protected variable _notifiers
-
- # This is set to the name of the parent widget whenever the mouse is
- # in a widget with balloon help.
-- protected _active {}
-+ protected variable _active {}
-
- # This is true when we're already calling a notification proc.
- # Private variable.
-- protected _in_notifier 0
-+ protected variable _in_notifier 0
-
- # This holds the parent of the most recently entered widget. It is
- # used to determine when the user is moving through a toolbar.
- # Private variable.
-- protected _recent_parent {}
-+ protected variable _recent_parent {}
-
- constructor {top} {
---- libgui/library/cframe.tcl Sat Sep 8 18:34:46 2001
-+++ libgui/library/cframe.tcl Thu Jun 28 15:39:50 2007
-@@ -3,5 +3,5 @@
- # Written by Tom Tromey <tromey@cygnus.com>.
-
--itcl_class Checkframe {
-+itcl::class Checkframe {
- inherit Widgetframe
-
-@@ -14,5 +14,5 @@
- # trace when the variable changes (or is deleted). Private
- # variable.
-- protected _saved_variable {}
-+ protected variable _saved_variable {}
-
- # The checkbutton variable.
-@@ -45,5 +45,5 @@
- # This holds a list of all widgets which should be immune to
- # enabling/disabling. Private variable.
-- protected _avoid {}
-+ protected variable _avoid {}
-
- constructor {config} {
---- libgui/library/lframe.tcl Sat Sep 8 18:34:46 2001
-+++ libgui/library/lframe.tcl Thu Jun 28 15:32:04 2007
-@@ -3,5 +3,5 @@
- # Written by Tom Tromey <tromey@cygnus.com>.
-
--itcl_class Labelledframe {
-+itcl::class Labelledframe {
- inherit Widgetframe
-
---- libgui/library/multibox.tcl Sat Sep 8 18:34:46 2001
-+++ libgui/library/multibox.tcl Thu Jun 28 15:39:58 2007
-@@ -7,5 +7,5 @@
- # * Should support itemcget, itemconfigure.
-
--itcl_class Multibox {
-+itcl::class Multibox {
- # The selection mode.
- public selectmode browse {
-@@ -20,5 +20,5 @@
- # This is a list of all the listbox widgets we've created. Private
- # variable.
-- protected _listboxen {}
-+ protected variable _listboxen {}
-
- # Tricky: take the class bindings for the Listbox widget and turn
---- libgui/library/sendpr.tcl Tue Feb 5 18:16:14 2002
-+++ libgui/library/sendpr.tcl Thu Jun 28 15:32:04 2007
-@@ -14,5 +14,5 @@
- defarray SENDPR_state
-
--itcl_class Sendpr {
-+itcl::class Sendpr {
- inherit Ide_window
-
---- libgui/library/ventry.tcl Sat Sep 8 18:34:46 2001
-+++ libgui/library/ventry.tcl Thu Jun 28 15:32:04 2007
-@@ -3,5 +3,5 @@
- # Written by Tom Tromey <tromey@cygnus.com>.
-
--itcl_class Validated_entry {
-+itcl::class Validated_entry {
- # The validation command. It is passed the contents of the entry.
- # It should throw an error if there is a problem; the error text
---- libgui/library/wframe.tcl Sat Sep 8 18:34:46 2001
-+++ libgui/library/wframe.tcl Thu Jun 28 15:40:07 2007
-@@ -3,5 +3,5 @@
- # Written by Tom Tromey <tromey@cygnus.com>.
-
--itcl_class Widgetframe {
-+itcl::class Widgetframe {
- # Where to put the widget. For now, we don't support many anchors.
- # Augment as you like.
-@@ -15,5 +15,5 @@
- # The name of the widget to put on the frame. This is set by some
- # subclass calling the _add method. Private variable.
-- protected _widget {}
-+ protected variable _widget {}
-
- constructor {config} {
---- libgui/library/pkgIndex.tcl 2003-02-04 02:33:38.000000000 -0500
-+++ libgui/library/pkgIndex.tcl 2010-12-02 23:33:05.000000000 -0500
-@@ -9,4 +9,4 @@
- # full path name of this file's directory.
-
--package ifneeded combobox 2.2.1 [list source [file join $dir combobox.tcl]]
-+package ifneeded combobox 2.3 [list source [file join $dir combobox.tcl]]
- package ifneeded debug 1.0 [list source [file join $dir debug.tcl]]
diff --git a/devel/gdb66/files/patch-gdb-amd64fbsd-nat.c b/devel/gdb66/files/patch-gdb-amd64fbsd-nat.c
deleted file mode 100644
index 0abe97392477..000000000000
--- a/devel/gdb66/files/patch-gdb-amd64fbsd-nat.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- gdb/amd64fbsd-nat.c.orig 2005-12-17 17:33:59.000000000 -0500
-+++ gdb/amd64fbsd-nat.c 2009-09-10 02:29:33.000000000 -0400
-@@ -125,10 +125,12 @@
- regcache_raw_supply (regcache, 13, &pcb->pcb_r13);
- regcache_raw_supply (regcache, 14, &pcb->pcb_r14);
- regcache_raw_supply (regcache, 15, &pcb->pcb_r15);
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 800000
- regcache_raw_supply (regcache, AMD64_DS_REGNUM, &pcb->pcb_ds);
- regcache_raw_supply (regcache, AMD64_ES_REGNUM, &pcb->pcb_es);
- regcache_raw_supply (regcache, AMD64_FS_REGNUM, &pcb->pcb_fs);
- regcache_raw_supply (regcache, AMD64_GS_REGNUM, &pcb->pcb_gs);
-+#endif
-
- return 1;
- }
diff --git a/devel/gdb66/files/patch-itcl b/devel/gdb66/files/patch-itcl
deleted file mode 100644
index 7ae953827d95..000000000000
--- a/devel/gdb66/files/patch-itcl
+++ /dev/null
@@ -1,11 +0,0 @@
-Obtained from gahr@
-
---- gdb/configure 2006-12-17 10:38:59.000000000 -0500
-+++ gdb/configure 2013-05-13 15:40:05.000000000 -0400
-@@ -22084,5 +22084,5 @@
-
-
-- ITCLLIB="${ITCL_BUILD_LIB_SPEC}"
-+ ITCLLIB="${ITCL_LIB_SPEC}"
- ITCL_DEPS="${ITCL_LIB_FULL_PATH}"
- fi
diff --git a/devel/gdb66/files/patch-libiberty-basename b/devel/gdb66/files/patch-libiberty-basename
deleted file mode 100644
index bdc4a4aaacbe..000000000000
--- a/devel/gdb66/files/patch-libiberty-basename
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/libiberty.h
-+++ include/libiberty.h
-@@ -98,7 +98,7 @@
- is 1, we found it so don't provide any declaration at all. */
- #if !HAVE_DECL_BASENAME
- #if defined (__GNU_LIBRARY__ ) || defined (__linux__) || defined (__FreeBSD__) || defined (__OpenBSD__) || defined(__NetBSD__) || defined (__CYGWIN__) || defined (__CYGWIN32__) || defined (__MINGW32__) || defined (HAVE_DECL_BASENAME)
--extern char *basename (const char *);
-+#include <libgen.h>
- #else
- /* Do not allow basename to be used if there is no prototype seen. We
- either need to use the above prototype or have one from
diff --git a/devel/gdb66/files/patch-unified b/devel/gdb66/files/patch-unified
deleted file mode 100644
index 19ef04213ee0..000000000000
--- a/devel/gdb66/files/patch-unified
+++ /dev/null
@@ -1,25 +0,0 @@
---- gdb/gdb.c Thu Feb 13 13:07:24 2003
-+++ gdb/gdb.c Wed May 17 00:24:39 2006
-@@ -23,4 +23,5 @@
- #include "gdb_string.h"
- #include "interps.h"
-+#include <libgen.h>
-
- int
-@@ -31,6 +32,14 @@
- args.argc = argc;
- args.argv = argv;
-- args.use_windows = 0;
-- args.interpreter_p = INTERP_CONSOLE;
-+ if (strncmp(basename(argv[0]), "insight", 7) == 0) {
-+ args.use_windows = 1;
-+ args.interpreter_p = "insight";
-+ } else if (strncmp(basename(argv[0]), "gdbtui", 6) == 0) {
-+ args.use_windows = 0;
-+ args.interpreter_p = INTERP_TUI;
-+ } else {
-+ args.use_windows = 0;
-+ args.interpreter_p = INTERP_CONSOLE;
-+ }
- return gdb_main (&args);
- }
diff --git a/devel/gdb66/pkg-descr b/devel/gdb66/pkg-descr
deleted file mode 100644
index 3baedcf89ab6..000000000000
--- a/devel/gdb66/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-GNU GDB - the version, for which the "Insight" GUI is available.
-
-WWW: http://sourceware.org/insight/
-WWW: http://www.gnu.org/software/gdb/
diff --git a/devel/gdb66/pkg-plist b/devel/gdb66/pkg-plist
deleted file mode 100644
index 76369aa2809c..000000000000
--- a/devel/gdb66/pkg-plist
+++ /dev/null
@@ -1,253 +0,0 @@
-bin/gdb%%VER%%
-bin/gdbtui%%VER%%
-man/man1/gdb%%VER%%.1.gz
-%%INSIGHT%%bin/insight
-%%INSIGHT%%share/redhat/gui/advice.tcl
-%%INSIGHT%%share/redhat/gui/balloon.tcl
-%%INSIGHT%%share/redhat/gui/bbox.tcl
-%%INSIGHT%%share/redhat/gui/bgerror.tcl
-%%INSIGHT%%share/redhat/gui/bindings.tcl
-%%INSIGHT%%share/redhat/gui/canvas.tcl
-%%INSIGHT%%share/redhat/gui/center.tcl
-%%INSIGHT%%share/redhat/gui/cframe.tcl
-%%INSIGHT%%share/redhat/gui/combobox.tcl
-%%INSIGHT%%share/redhat/gui/debug.tcl
-%%INSIGHT%%share/redhat/gui/def.tcl
-%%INSIGHT%%share/redhat/gui/font.tcl
-%%INSIGHT%%share/redhat/gui/gensym.tcl
-%%INSIGHT%%share/redhat/gui/gettext.tcl
-%%INSIGHT%%share/redhat/gui/hooks.tcl
-%%INSIGHT%%share/redhat/gui/internet.tcl
-%%INSIGHT%%share/redhat/gui/lframe.tcl
-%%INSIGHT%%share/redhat/gui/list.tcl
-%%INSIGHT%%share/redhat/gui/looknfeel.tcl
-%%INSIGHT%%share/redhat/gui/menu.tcl
-%%INSIGHT%%share/redhat/gui/mono.tcl
-%%INSIGHT%%share/redhat/gui/multibox.tcl
-%%INSIGHT%%share/redhat/gui/pane.tcl
-%%INSIGHT%%share/redhat/gui/panedwindow.tcl
-%%INSIGHT%%share/redhat/gui/parse_args.tcl
-%%INSIGHT%%share/redhat/gui/path.tcl
-%%INSIGHT%%share/redhat/gui/pkgIndex.tcl
-%%INSIGHT%%share/redhat/gui/postghost.tcl
-%%INSIGHT%%share/redhat/gui/prefs.tcl
-%%INSIGHT%%share/redhat/gui/print.tcl
-%%INSIGHT%%share/redhat/gui/sendpr.tcl
-%%INSIGHT%%share/redhat/gui/toolbar.tcl
-%%INSIGHT%%share/redhat/gui/topbind.tcl
-%%INSIGHT%%share/redhat/gui/ulset.tcl
-%%INSIGHT%%share/redhat/gui/ventry.tcl
-%%INSIGHT%%share/redhat/gui/wframe.tcl
-%%INSIGHT%%share/redhat/gui/wingrab.tcl
-%%INSIGHT%%share/redhat/gui/tclIndex
-%%INSIGHT%%lib/insight1.0/about.tcl
-%%INSIGHT%%lib/insight1.0/actiondlg.tcl
-%%INSIGHT%%lib/insight1.0/attachdlg.itb
-%%INSIGHT%%lib/insight1.0/attachdlg.ith
-%%INSIGHT%%lib/insight1.0/blockframe.itb
-%%INSIGHT%%lib/insight1.0/blockframe.ith
-%%INSIGHT%%lib/insight1.0/bpwin.itb
-%%INSIGHT%%lib/insight1.0/bpwin.ith
-%%INSIGHT%%lib/insight1.0/browserwin.itb
-%%INSIGHT%%lib/insight1.0/browserwin.ith
-%%INSIGHT%%lib/insight1.0/console.itb
-%%INSIGHT%%lib/insight1.0/console.ith
-%%INSIGHT%%lib/insight1.0/cspref.itb
-%%INSIGHT%%lib/insight1.0/cspref.ith
-%%INSIGHT%%lib/insight1.0/debugwin.itb
-%%INSIGHT%%lib/insight1.0/debugwin.ith
-%%INSIGHT%%lib/insight1.0/download.itb
-%%INSIGHT%%lib/insight1.0/download.ith
-%%INSIGHT%%lib/insight1.0/editor.tcl
-%%INSIGHT%%lib/insight1.0/ehandler.itb
-%%INSIGHT%%lib/insight1.0/ehandler.ith
-%%INSIGHT%%lib/insight1.0/embeddedwin.ith
-%%INSIGHT%%lib/insight1.0/gdbevent.itb
-%%INSIGHT%%lib/insight1.0/gdbevent.ith
-%%INSIGHT%%lib/insight1.0/gdbmenubar.itcl
-%%INSIGHT%%lib/insight1.0/gdbtoolbar.itcl
-%%INSIGHT%%lib/insight1.0/gdbwin.ith
-%%INSIGHT%%lib/insight1.0/globalpref.itb
-%%INSIGHT%%lib/insight1.0/globalpref.ith
-%%INSIGHT%%lib/insight1.0/help/breakpoint.html
-%%INSIGHT%%lib/insight1.0/help/browser.html
-%%INSIGHT%%lib/insight1.0/help/console.html
-%%INSIGHT%%lib/insight1.0/help/debug.html
-%%INSIGHT%%lib/insight1.0/help/gbl_pref.html
-%%INSIGHT%%lib/insight1.0/help/help.html
-%%INSIGHT%%lib/insight1.0/help/images/browser1.png
-%%INSIGHT%%lib/insight1.0/help/images/browser2.png
-%%INSIGHT%%lib/insight1.0/help/images/frame_info.gif
-%%INSIGHT%%lib/insight1.0/help/images/insightbwr.png
-%%INSIGHT%%lib/insight1.0/help/images/mem_menu.gif
-%%INSIGHT%%lib/insight1.0/help/images/mem_popup.gif
-%%INSIGHT%%lib/insight1.0/help/images/mem_pref.gif
-%%INSIGHT%%lib/insight1.0/help/images/reg.png
-%%INSIGHT%%lib/insight1.0/help/images/reg_menu.png
-%%INSIGHT%%lib/insight1.0/help/images/src_bal.gif
-%%INSIGHT%%lib/insight1.0/help/images/src_bp_bal.gif
-%%INSIGHT%%lib/insight1.0/help/images/src_bpop.gif
-%%INSIGHT%%lib/insight1.0/help/images/src_menu.gif
-%%INSIGHT%%lib/insight1.0/help/images/src_pop.gif
-%%INSIGHT%%lib/insight1.0/help/images/src_stat.gif
-%%INSIGHT%%lib/insight1.0/help/images/src_thread.gif
-%%INSIGHT%%lib/insight1.0/help/images/src_toolbar.gif
-%%INSIGHT%%lib/insight1.0/help/images/watch.png
-%%INSIGHT%%lib/insight1.0/help/index.html
-%%INSIGHT%%lib/insight1.0/help/license.html
-%%INSIGHT%%lib/insight1.0/help/locals.html
-%%INSIGHT%%lib/insight1.0/help/memory.html
-%%INSIGHT%%lib/insight1.0/help/register.html
-%%INSIGHT%%lib/insight1.0/help/session.html
-%%INSIGHT%%lib/insight1.0/help/source.html
-%%INSIGHT%%lib/insight1.0/help/src_pref.html
-%%INSIGHT%%lib/insight1.0/help/stack.html
-%%INSIGHT%%lib/insight1.0/help/target.html
-%%INSIGHT%%lib/insight1.0/help/thread.html
-%%INSIGHT%%lib/insight1.0/help/trace/console.html
-%%INSIGHT%%lib/insight1.0/help/trace/gbl_pref.html
-%%INSIGHT%%lib/insight1.0/help/trace/help.html
-%%INSIGHT%%lib/insight1.0/help/trace/index.toc
-%%INSIGHT%%lib/insight1.0/help/trace/license.html
-%%INSIGHT%%lib/insight1.0/help/trace/locals.html
-%%INSIGHT%%lib/insight1.0/help/trace/memory.html
-%%INSIGHT%%lib/insight1.0/help/trace/reg_pref.html
-%%INSIGHT%%lib/insight1.0/help/trace/register.html
-%%INSIGHT%%lib/insight1.0/help/trace/source.html
-%%INSIGHT%%lib/insight1.0/help/trace/src_pref.html
-%%INSIGHT%%lib/insight1.0/help/trace/stack.html
-%%INSIGHT%%lib/insight1.0/help/trace/target.html
-%%INSIGHT%%lib/insight1.0/help/trace/tdump.html
-%%INSIGHT%%lib/insight1.0/help/trace/tp.html
-%%INSIGHT%%lib/insight1.0/help/trace/tracedlg.html
-%%INSIGHT%%lib/insight1.0/help/trace/watch.html
-%%INSIGHT%%lib/insight1.0/help/watch.html
-%%INSIGHT%%lib/insight1.0/helpviewer.tcl
-%%INSIGHT%%lib/insight1.0/images/Movie_off.gif
-%%INSIGHT%%lib/insight1.0/images/Movie_on.gif
-%%INSIGHT%%lib/insight1.0/images/bottom.gif
-%%INSIGHT%%lib/insight1.0/images/bp.gif
-%%INSIGHT%%lib/insight1.0/images/check.gif
-%%INSIGHT%%lib/insight1.0/images/console.gif
-%%INSIGHT%%lib/insight1.0/images/continue.gif
-%%INSIGHT%%lib/insight1.0/images/down.gif
-%%INSIGHT%%lib/insight1.0/images/edit.gif
-%%INSIGHT%%lib/insight1.0/images/finish.gif
-%%INSIGHT%%lib/insight1.0/images/gdbtk_icon.gif
-%%INSIGHT%%lib/insight1.0/images/help.gif
-%%INSIGHT%%lib/insight1.0/images/home.gif
-%%INSIGHT%%lib/insight1.0/images/icons.txt
-%%INSIGHT%%lib/insight1.0/images/insight.gif
-%%INSIGHT%%lib/insight1.0/images/less.gif
-%%INSIGHT%%lib/insight1.0/images/memory.gif
-%%INSIGHT%%lib/insight1.0/images/more.gif
-%%INSIGHT%%lib/insight1.0/images/next.gif
-%%INSIGHT%%lib/insight1.0/images/next_check.gif
-%%INSIGHT%%lib/insight1.0/images/next_frame.gif
-%%INSIGHT%%lib/insight1.0/images/next_hit.gif
-%%INSIGHT%%lib/insight1.0/images/next_line.gif
-%%INSIGHT%%lib/insight1.0/images/nexti.gif
-%%INSIGHT%%lib/insight1.0/images/open.gif
-%%INSIGHT%%lib/insight1.0/images/prev_hit.gif
-%%INSIGHT%%lib/insight1.0/images/reg.gif
-%%INSIGHT%%lib/insight1.0/images/rewind.gif
-%%INSIGHT%%lib/insight1.0/images/run.gif
-%%INSIGHT%%lib/insight1.0/images/run_expt.gif
-%%INSIGHT%%lib/insight1.0/images/src.gif
-%%INSIGHT%%lib/insight1.0/images/stack.gif
-%%INSIGHT%%lib/insight1.0/images/step.gif
-%%INSIGHT%%lib/insight1.0/images/stepi.gif
-%%INSIGHT%%lib/insight1.0/images/stop.gif
-%%INSIGHT%%lib/insight1.0/images/tdump.gif
-%%INSIGHT%%lib/insight1.0/images/tp.gif
-%%INSIGHT%%lib/insight1.0/images/up.gif
-%%INSIGHT%%lib/insight1.0/images/vars.gif
-%%INSIGHT%%lib/insight1.0/images/watch.gif
-%%INSIGHT%%lib/insight1.0/images/watch_movie.gif
-%%INSIGHT%%lib/insight1.0/images2/Movie_off.gif
-%%INSIGHT%%lib/insight1.0/images2/Movie_on.gif
-%%INSIGHT%%lib/insight1.0/images2/bottom.gif
-%%INSIGHT%%lib/insight1.0/images2/bp.gif
-%%INSIGHT%%lib/insight1.0/images2/check.gif
-%%INSIGHT%%lib/insight1.0/images2/console.gif
-%%INSIGHT%%lib/insight1.0/images2/continue.gif
-%%INSIGHT%%lib/insight1.0/images2/down.gif
-%%INSIGHT%%lib/insight1.0/images2/edit.gif
-%%INSIGHT%%lib/insight1.0/images2/finish.gif
-%%INSIGHT%%lib/insight1.0/images2/function.gif
-%%INSIGHT%%lib/insight1.0/images2/gdbtk_icon.gif
-%%INSIGHT%%lib/insight1.0/images2/help.gif
-%%INSIGHT%%lib/insight1.0/images2/home.gif
-%%INSIGHT%%lib/insight1.0/images2/icons.txt
-%%INSIGHT%%lib/insight1.0/images2/insight.gif
-%%INSIGHT%%lib/insight1.0/images2/less.gif
-%%INSIGHT%%lib/insight1.0/images2/memory.gif
-%%INSIGHT%%lib/insight1.0/images2/more.gif
-%%INSIGHT%%lib/insight1.0/images2/next.gif
-%%INSIGHT%%lib/insight1.0/images2/next_check.gif
-%%INSIGHT%%lib/insight1.0/images2/next_frame.gif
-%%INSIGHT%%lib/insight1.0/images2/next_hit.gif
-%%INSIGHT%%lib/insight1.0/images2/next_line.gif
-%%INSIGHT%%lib/insight1.0/images2/nexti.gif
-%%INSIGHT%%lib/insight1.0/images2/open.gif
-%%INSIGHT%%lib/insight1.0/images2/prev_hit.gif
-%%INSIGHT%%lib/insight1.0/images2/reg.gif
-%%INSIGHT%%lib/insight1.0/images2/rewind.gif
-%%INSIGHT%%lib/insight1.0/images2/run.gif
-%%INSIGHT%%lib/insight1.0/images2/run_expt.gif
-%%INSIGHT%%lib/insight1.0/images2/src.gif
-%%INSIGHT%%lib/insight1.0/images2/stack.gif
-%%INSIGHT%%lib/insight1.0/images2/step.gif
-%%INSIGHT%%lib/insight1.0/images2/stepi.gif
-%%INSIGHT%%lib/insight1.0/images2/stop.gif
-%%INSIGHT%%lib/insight1.0/images2/target.gif
-%%INSIGHT%%lib/insight1.0/images2/tdump.gif
-%%INSIGHT%%lib/insight1.0/images2/tp.gif
-%%INSIGHT%%lib/insight1.0/images2/up.gif
-%%INSIGHT%%lib/insight1.0/images2/vars.gif
-%%INSIGHT%%lib/insight1.0/images2/watch.gif
-%%INSIGHT%%lib/insight1.0/images2/watch_movie.gif
-%%INSIGHT%%lib/insight1.0/interface.tcl
-%%INSIGHT%%lib/insight1.0/ipc.tcl
-%%INSIGHT%%lib/insight1.0/ipcpref.itb
-%%INSIGHT%%lib/insight1.0/ipcpref.ith
-%%INSIGHT%%lib/insight1.0/kod.itb
-%%INSIGHT%%lib/insight1.0/kod.ith
-%%INSIGHT%%lib/insight1.0/locals.tcl
-%%INSIGHT%%lib/insight1.0/main.tcl
-%%INSIGHT%%lib/insight1.0/managedwin.itb
-%%INSIGHT%%lib/insight1.0/managedwin.ith
-%%INSIGHT%%lib/insight1.0/mempref.itb
-%%INSIGHT%%lib/insight1.0/mempref.ith
-%%INSIGHT%%lib/insight1.0/memwin.itb
-%%INSIGHT%%lib/insight1.0/memwin.ith
-%%INSIGHT%%lib/insight1.0/modal.tcl
-%%INSIGHT%%lib/insight1.0/pluginwin.itcl
-%%INSIGHT%%lib/insight1.0/prefs.tcl
-%%INSIGHT%%lib/insight1.0/process.itb
-%%INSIGHT%%lib/insight1.0/process.ith
-%%INSIGHT%%lib/insight1.0/regwin.itb
-%%INSIGHT%%lib/insight1.0/regwin.ith
-%%INSIGHT%%lib/insight1.0/session.tcl
-%%INSIGHT%%lib/insight1.0/srcbar.itcl
-%%INSIGHT%%lib/insight1.0/srcpref.itb
-%%INSIGHT%%lib/insight1.0/srcpref.ith
-%%INSIGHT%%lib/insight1.0/srctextwin.itb
-%%INSIGHT%%lib/insight1.0/srctextwin.ith
-%%INSIGHT%%lib/insight1.0/srcwin.itb
-%%INSIGHT%%lib/insight1.0/srcwin.ith
-%%INSIGHT%%lib/insight1.0/stackwin.itb
-%%INSIGHT%%lib/insight1.0/stackwin.ith
-%%INSIGHT%%lib/insight1.0/targetselection.itb
-%%INSIGHT%%lib/insight1.0/targetselection.ith
-%%INSIGHT%%lib/insight1.0/tdump.tcl
-%%INSIGHT%%lib/insight1.0/tfind_args.tcl
-%%INSIGHT%%lib/insight1.0/toplevelwin.ith
-%%INSIGHT%%lib/insight1.0/tracedlg.tcl
-%%INSIGHT%%lib/insight1.0/tty.tcl
-%%INSIGHT%%lib/insight1.0/util.tcl
-%%INSIGHT%%lib/insight1.0/vartree.itb
-%%INSIGHT%%lib/insight1.0/vartree.ith
-%%INSIGHT%%lib/insight1.0/warning.tcl
-%%INSIGHT%%lib/insight1.0/watch.tcl
-%%INSIGHT%%lib/insight1.0/tclIndex