aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-05-16 17:07:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-05-16 17:07:13 +0000
commit6cbdcdda6a56dcd2f59b23e2a95eef50b632e524 (patch)
treefbbe696481287f1545985e43c490c2c9e0696050 /devel/gdb
parent7f08a76c7189b6053ad51af961ecfb71df9d6fab (diff)
downloadports-6cbdcdda6a56dcd2f59b23e2a95eef50b632e524.tar.gz
ports-6cbdcdda6a56dcd2f59b23e2a95eef50b632e524.zip
Notes
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile4
-rw-r--r--devel/gdb/distinfo4
-rw-r--r--devel/gdb/files/fbsd-threads.c20
-rw-r--r--devel/gdb/files/patch-bfd-elf32-microblaze.c11
-rw-r--r--devel/gdb/files/patch-bfd-elf32-xtensa.c20
-rw-r--r--devel/gdb/files/patch-gdb-amd64bsd-nat.c36
-rw-r--r--devel/gdb/files/patch-gdb-i386fbsd-tdep.c4
-rw-r--r--devel/gdb/files/patch-opcodes-ia64-asmtab.c66
-rw-r--r--devel/gdb/files/patch-opcodes-tic54x-dis.c105
-rw-r--r--devel/gdb/files/patch-opcodes-v850-dis.c20
10 files changed, 105 insertions, 185 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 7b908c12a1ae..e4d75f81af1d 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= gdb
-PORTVERSION= 7.5.1
-PORTREVISION= 1
+PORTVERSION= 7.6
+#PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
diff --git a/devel/gdb/distinfo b/devel/gdb/distinfo
index 23135fd31abf..f2f6ba7ac235 100644
--- a/devel/gdb/distinfo
+++ b/devel/gdb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdb-7.5.1.tar.bz2) = 070b808d289fa8f0291738eeaccc0cd7700d476998781f572856155240d29d20
-SIZE (gdb-7.5.1.tar.bz2) = 21349391
+SHA256 (gdb-7.6.tar.bz2) = a410e8f35ee70cce83dbbf1da9e2a8373f271ac0e4b71db4336ae293fc7bdf1b
+SIZE (gdb-7.6.tar.bz2) = 24333590
diff --git a/devel/gdb/files/fbsd-threads.c b/devel/gdb/files/fbsd-threads.c
index ec884dae9623..ad54a8f2c838 100644
--- a/devel/gdb/files/fbsd-threads.c
+++ b/devel/gdb/files/fbsd-threads.c
@@ -338,7 +338,7 @@ extract_func_ptr(void *value)
return (extract_typed_address
((gdb_byte *)value,
- builtin_type (target_gdbarch)->builtin_func_ptr));
+ builtin_type (target_gdbarch ())->builtin_func_ptr));
}
static CORE_ADDR
@@ -347,7 +347,7 @@ extract_data_ptr(void *value)
return (extract_typed_address
((gdb_byte *)value,
- builtin_type (target_gdbarch)->builtin_data_ptr));
+ builtin_type (target_gdbarch ())->builtin_data_ptr));
}
static td_err_e
@@ -363,10 +363,10 @@ enable_thread_event (td_thragent_t *thread_agent, int event, CORE_ADDR *bp)
/* Set up the breakpoint. */
(*bp) = (gdbarch_convert_from_func_ptr_addr
- (target_gdbarch,
+ (target_gdbarch (),
extract_func_ptr(&notify.u.bptaddr),
&current_target));
- create_thread_event_breakpoint (target_gdbarch, (*bp));
+ create_thread_event_breakpoint (target_gdbarch (), (*bp));
return TD_OK;
}
@@ -1537,7 +1537,7 @@ ps_lgetregs (struct ps_prochandle *ph, lwpid_t lwpid, prgregset_t gregset)
old_chain = save_inferior_ptid ();
inferior_ptid = BUILD_LWP (lwpid, ph->pid);
- regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch);
+ regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch ());
target_fetch_registers (regcache, -1);
fill_gregset (regcache, gregset, -1);
@@ -1553,7 +1553,7 @@ ps_lsetregs (struct ps_prochandle *ph, lwpid_t lwpid, const prgregset_t gregset)
old_chain = save_inferior_ptid ();
inferior_ptid = BUILD_LWP (lwpid, ph->pid);
- regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch);
+ regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch ());
supply_gregset (regcache, gregset);
target_store_registers (regcache, -1);
@@ -1569,7 +1569,7 @@ ps_lgetfpregs (struct ps_prochandle *ph, lwpid_t lwpid, prfpregset_t *fpregset)
old_chain = save_inferior_ptid ();
inferior_ptid = BUILD_LWP (lwpid, ph->pid);
- regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch);
+ regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch ());
target_fetch_registers (regcache, -1);
fill_fpregset (regcache, fpregset, -1);
@@ -1586,7 +1586,7 @@ ps_lsetfpregs (struct ps_prochandle *ph, lwpid_t lwpid,
old_chain = save_inferior_ptid ();
inferior_ptid = BUILD_LWP (lwpid, ph->pid);
- regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch);
+ regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch ());
supply_fpregset (regcache, fpregset);
target_store_registers (regcache, -1);
@@ -1603,7 +1603,7 @@ ps_lgetxmmregs (struct ps_prochandle *ph, lwpid_t lwpid, char *xmmregs)
old_chain = save_inferior_ptid ();
inferior_ptid = BUILD_LWP (lwpid, ph->pid);
- regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch);
+ regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch ());
target_fetch_registers (regcache, -1);
i387_collect_fxsave (regcache, -1, xmmregs);
@@ -1620,7 +1620,7 @@ ps_lsetxmmregs (struct ps_prochandle *ph, lwpid_t lwpid,
old_chain = save_inferior_ptid ();
inferior_ptid = BUILD_LWP (lwpid, ph->pid);
- regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch);
+ regcache = get_thread_arch_regcache (inferior_ptid, target_gdbarch ());
i387_supply_fxsave (regcache, -1, xmmregs);
target_store_registers (regcache, -1);
diff --git a/devel/gdb/files/patch-bfd-elf32-microblaze.c b/devel/gdb/files/patch-bfd-elf32-microblaze.c
deleted file mode 100644
index 22a199f2fb16..000000000000
--- a/devel/gdb/files/patch-bfd-elf32-microblaze.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- bfd/elf32-microblaze.c.orig 2013-03-07 10:01:47.000000000 +0100
-+++ bfd/elf32-microblaze.c 2013-03-07 10:02:54.000000000 +0100
-@@ -1741,7 +1741,7 @@
- for (isym = isymbuf; isym < isymend; isym++)
- {
- if (isym->st_shndx == shndx)
-- isym->st_value =- calc_fixup (isym->st_value, sec);
-+ isym->st_value = -calc_fixup (isym->st_value, sec);
- }
-
- /* Now adjust the global symbols defined in this section. */
diff --git a/devel/gdb/files/patch-bfd-elf32-xtensa.c b/devel/gdb/files/patch-bfd-elf32-xtensa.c
deleted file mode 100644
index e7611391eaed..000000000000
--- a/devel/gdb/files/patch-bfd-elf32-xtensa.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- bfd/elf32-xtensa.c.orig 2013-03-07 10:08:58.000000000 +0100
-+++ bfd/elf32-xtensa.c 2013-03-07 10:11:40.000000000 +0100
-@@ -6075,7 +6075,7 @@
- release_internal_relocs (sec_cache->sec, sec_cache->relocs);
- if (sec_cache->ptbl)
- free (sec_cache->ptbl);
-- memset (sec_cache, 0, sizeof (sec_cache));
-+ memset (sec_cache, 0, sizeof (*sec_cache));
- }
- }
-
-@@ -6117,7 +6117,7 @@
-
- /* Fill in the new section cache. */
- clear_section_cache (sec_cache);
-- memset (sec_cache, 0, sizeof (sec_cache));
-+ memset (sec_cache, 0, sizeof (*sec_cache));
-
- sec_cache->sec = sec;
- sec_cache->contents = contents;
diff --git a/devel/gdb/files/patch-gdb-amd64bsd-nat.c b/devel/gdb/files/patch-gdb-amd64bsd-nat.c
new file mode 100644
index 000000000000..50d2be8e96e5
--- /dev/null
+++ b/devel/gdb/files/patch-gdb-amd64bsd-nat.c
@@ -0,0 +1,36 @@
+--- gdb/amd64bsd-nat.c.orig 2013-04-09 16:45:15.000000000 +0200
++++ gdb/amd64bsd-nat.c 2013-04-09 18:53:22.000000000 +0200
+@@ -29,6 +29,7 @@
+ #include <sys/types.h>
+ #include <sys/ptrace.h>
+ #include <machine/reg.h>
++#include <machine/psl.h>
+
+ #include "amd64-tdep.h"
+ #include "amd64-nat.h"
+@@ -81,14 +82,24 @@
+
+ if (regnum == -1 || amd64_native_gregset_supplies_p (gdbarch, regnum))
+ {
+- struct reg regs;
++ struct reg regs, oldregs;
+
++ memset( &regs, 0, sizeof(struct reg));
++ memset( &oldregs, 0, sizeof(struct reg));
+ if (ptrace (PT_GETREGS, PIDGET (inferior_ptid),
+ (PTRACE_TYPE_ARG3) &regs, 0) == -1)
+ perror_with_name (_("Couldn't get registers"));
+
++ ptrace (PT_GETREGS, PIDGET (inferior_ptid),
++ (PTRACE_TYPE_ARG3) &oldregs, 0);
+ amd64_collect_native_gregset (regcache, &regs, regnum);
+
++ if( (regs.r_rflags ^ oldregs.r_rflags ) & ~PSL_USERCHANGE) {
++ //printf("regs.r_rflags = 0x%8.8lX\n", regs.r_rflags );
++ //printf("oldregs.r_rflags = 0x%8.8lX\n", oldregs.r_rflags );
++ regs.r_rflags ^= (regs.r_rflags ^ oldregs.r_rflags ) & ~PSL_USERCHANGE;
++ //printf(" allowed regs.r_rflags = 0x%8.8X\n", regs.r_rflags );
++ }
+ if (ptrace (PT_SETREGS, PIDGET (inferior_ptid),
+ (PTRACE_TYPE_ARG3) &regs, 0) == -1)
+ perror_with_name (_("Couldn't write registers"));
diff --git a/devel/gdb/files/patch-gdb-i386fbsd-tdep.c b/devel/gdb/files/patch-gdb-i386fbsd-tdep.c
index 2256796de096..f6a1c1d59046 100644
--- a/devel/gdb/files/patch-gdb-i386fbsd-tdep.c
+++ b/devel/gdb/files/patch-gdb-i386fbsd-tdep.c
@@ -15,7 +15,7 @@
-i386fbsd_supply_uthread (struct regcache *regcache,
- int regnum, CORE_ADDR addr)
-{
-- char buf[4];
+- gdb_byte buf[4];
- int i;
-
- gdb_assert (regnum >= -1);
@@ -35,7 +35,7 @@
-i386fbsd_collect_uthread (const struct regcache *regcache,
- int regnum, CORE_ADDR addr)
-{
-- char buf[4];
+- gdb_byte buf[4];
- int i;
-
- gdb_assert (regnum >= -1);
diff --git a/devel/gdb/files/patch-opcodes-ia64-asmtab.c b/devel/gdb/files/patch-opcodes-ia64-asmtab.c
index b005bbcc643c..e7a7d4ed5790 100644
--- a/devel/gdb/files/patch-opcodes-ia64-asmtab.c
+++ b/devel/gdb/files/patch-opcodes-ia64-asmtab.c
@@ -1,37 +1,37 @@
---- opcodes/ia64-asmtab.c.orig 2008-08-28 16:07:49.000000000 +0200
-+++ opcodes/ia64-asmtab.c 2013-03-13 16:40:09.000000000 +0100
-@@ -101,7 +101,7 @@
+--- opcodes/ia64-asmtab.c.orig 2013-04-28 14:55:03.000000000 +0200
++++ opcodes/ia64-asmtab.c 2013-04-28 14:56:48.000000000 +0200
+@@ -102,7 +102,7 @@
{ "CPUID#", 7, 0, 5, -1, NULL, },
- { "CR[CMCV]", 28, 0, 3, 74, NULL, },
- { "CR[DCR]", 28, 0, 3, 0, NULL, },
-- { "CR[EOI]", 28, 0, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI Ð CR67)\" on page 2:119", },
-+ { "CR[EOI]", 28, 0, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI CR67)\" on page 2:119", },
- { "CR[GPTA]", 28, 0, 3, 9, NULL, },
- { "CR[IFA]", 28, 0, 1, 20, NULL, },
- { "CR[IFA]", 28, 0, 3, 20, NULL, },
-@@ -123,13 +123,13 @@
- { "CR[ITM]", 28, 0, 3, 1, NULL, },
- { "CR[ITV]", 28, 0, 3, 72, NULL, },
- { "CR[IVA]", 28, 0, 4, 2, NULL, },
-- { "CR[IVR]", 28, 0, 7, 65, "SC Section 5.8.3.2, \"External Interrupt Vector Register (IVR Ð CR65)\" on page 2:118", },
-- { "CR[LID]", 28, 0, 7, 64, "SC Section 5.8.3.1, \"Local ID (LID Ð CR64)\" on page 2:117", },
-+ { "CR[IVR]", 28, 0, 7, 65, "SC Section 5.8.3.2, \"External Interrupt Vector Register (IVR CR65)\" on page 2:118", },
-+ { "CR[LID]", 28, 0, 7, 64, "SC Section 5.8.3.1, \"Local ID (LID CR64)\" on page 2:117", },
+ { "CR[CMCV]", 29, 0, 3, 74, NULL, },
+ { "CR[DCR]", 29, 0, 3, 0, NULL, },
+- { "CR[EOI]", 29, 0, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI Ð CR67)\" on page 2:119", },
++ { "CR[EOI]", 29, 0, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI CR67)\" on page 2:119", },
+ { "CR[GPTA]", 29, 0, 3, 9, NULL, },
+ { "CR[IFA]", 29, 0, 1, 20, NULL, },
+ { "CR[IFA]", 29, 0, 3, 20, NULL, },
+@@ -124,13 +124,13 @@
+ { "CR[ITM]", 29, 0, 3, 1, NULL, },
+ { "CR[ITV]", 29, 0, 3, 72, NULL, },
+ { "CR[IVA]", 29, 0, 4, 2, NULL, },
+- { "CR[IVR]", 29, 0, 7, 65, "SC Section 5.8.3.2, \"External Interrupt Vector Register (IVR Ð CR65)\" on page 2:118", },
+- { "CR[LID]", 29, 0, 7, 64, "SC Section 5.8.3.1, \"Local ID (LID Ð CR64)\" on page 2:117", },
++ { "CR[IVR]", 29, 0, 7, 65, "SC Section 5.8.3.2, \"External Interrupt Vector Register (IVR CR65)\" on page 2:118", },
++ { "CR[LID]", 29, 0, 7, 64, "SC Section 5.8.3.1, \"Local ID (LID CR64)\" on page 2:117", },
{ "CR[LRR%], % in 0 - 1", 10, 0, 3, -1, NULL, },
- { "CR[PMV]", 28, 0, 3, 73, NULL, },
- { "CR[PTA]", 28, 0, 3, 8, NULL, },
- { "CR[TPR]", 28, 0, 3, 66, NULL, },
-- { "CR[TPR]", 28, 0, 7, 66, "SC Section 5.8.3.3, \"Task Priority Register (TPR Ð CR66)\" on page 2:119", },
-+ { "CR[TPR]", 28, 0, 7, 66, "SC Section 5.8.3.3, \"Task Priority Register (TPR CR66)\" on page 2:119", },
- { "CR[TPR]", 28, 0, 1, 66, NULL, },
+ { "CR[PMV]", 29, 0, 3, 73, NULL, },
+ { "CR[PTA]", 29, 0, 3, 8, NULL, },
+ { "CR[TPR]", 29, 0, 3, 66, NULL, },
+- { "CR[TPR]", 29, 0, 7, 66, "SC Section 5.8.3.3, \"Task Priority Register (TPR Ð CR66)\" on page 2:119", },
++ { "CR[TPR]", 29, 0, 7, 66, "SC Section 5.8.3.3, \"Task Priority Register (TPR CR66)\" on page 2:119", },
+ { "CR[TPR]", 29, 0, 1, 66, NULL, },
{ "CR%, % in 3-7, 10-15, 18, 28-63, 75-79, 82-127", 11, 0, 0, -1, NULL, },
- { "DBR#", 12, 0, 2, -1, NULL, },
-@@ -303,7 +303,7 @@
+ { "DAHR%, % in 0-7", 12, 0, 1, -1, NULL, },
+@@ -305,7 +305,7 @@
{ "CPUID#", 7, 1, 0, -1, NULL, },
- { "CR[CMCV]", 28, 1, 2, 74, NULL, },
- { "CR[DCR]", 28, 1, 2, 0, NULL, },
-- { "CR[EOI]", 28, 1, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI Ð CR67)\" on page 2:119", },
-+ { "CR[EOI]", 28, 1, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI CR67)\" on page 2:119", },
- { "CR[GPTA]", 28, 1, 2, 9, NULL, },
- { "CR[IFA]", 28, 1, 2, 20, NULL, },
- { "CR[IFS]", 28, 1, 2, 23, NULL, },
+ { "CR[CMCV]", 29, 1, 2, 74, NULL, },
+ { "CR[DCR]", 29, 1, 2, 0, NULL, },
+- { "CR[EOI]", 29, 1, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI Ð CR67)\" on page 2:119", },
++ { "CR[EOI]", 29, 1, 7, 67, "SC Section 5.8.3.4, \"End of External Interrupt Register (EOI CR67)\" on page 2:119", },
+ { "CR[GPTA]", 29, 1, 2, 9, NULL, },
+ { "CR[IFA]", 29, 1, 2, 20, NULL, },
+ { "CR[IFS]", 29, 1, 2, 23, NULL, },
diff --git a/devel/gdb/files/patch-opcodes-tic54x-dis.c b/devel/gdb/files/patch-opcodes-tic54x-dis.c
deleted file mode 100644
index 98aa8638a3d5..000000000000
--- a/devel/gdb/files/patch-opcodes-tic54x-dis.c
+++ /dev/null
@@ -1,105 +0,0 @@
---- opcodes/tic54x-dis.c.orig 2013-03-07 10:46:52.000000000 +0100
-+++ opcodes/tic54x-dis.c 2013-03-07 12:05:19.000000000 +0100
-@@ -168,14 +168,9 @@
- }
-
- int
--print_instruction (info, memaddr, opcode, tm_name, tm_operands, size, ext)
-- disassemble_info *info;
-- bfd_vma memaddr;
-- unsigned short opcode;
-- const char *tm_name;
-- const enum optype tm_operands[];
-- int size;
-- int ext;
-+print_instruction (disassemble_info * info, bfd_vma memaddr,
-+ unsigned short opcode, const char *tm_name,
-+ const enum optype tm_operands[], int size, int ext)
- {
- static int n;
- /* string storage for multiple operands */
-@@ -468,6 +463,7 @@
- return 1;
- }
-
-+/*
- static int
- print_parallel_instruction (info, memaddr, opcode, ptm, size)
- disassemble_info *info;
-@@ -475,6 +471,11 @@
- unsigned short opcode;
- const insn_template *ptm;
- int size;
-+*/
-+static int
-+print_parallel_instruction (disassemble_info *info,
-+ bfd_vma memaddr, unsigned short opcode,
-+ const insn_template * ptm, int size)
- {
- print_instruction (info, memaddr, opcode,
- ptm->name, ptm->operand_types, size, 0);
-@@ -484,10 +485,8 @@
- }
-
- static int
--sprint_dual_address (info, buf, code)
-- disassemble_info *info ATTRIBUTE_UNUSED;
-- char buf[];
-- unsigned short code;
-+sprint_dual_address ( disassemble_info *info ATTRIBUTE_UNUSED,
-+ char buf[], unsigned short code)
- {
- const char *formats[] = {
- "*ar%d",
-@@ -499,10 +498,8 @@
- }
-
- static int
--sprint_indirect_address (info, buf, opcode)
-- disassemble_info *info ATTRIBUTE_UNUSED;
-- char buf[];
-- unsigned short opcode;
-+sprint_indirect_address (disassemble_info * info ATTRIBUTE_UNUSED,
-+ char buf[], unsigned short opcode)
- {
- const char *formats[] = {
- "*ar%d",
-@@ -522,10 +519,8 @@
- }
-
- static int
--sprint_direct_address (info, buf, opcode)
-- disassemble_info *info ATTRIBUTE_UNUSED;
-- char buf[];
-- unsigned short opcode;
-+sprint_direct_address ( disassemble_info *info ATTRIBUTE_UNUSED,
-+ char buf[], unsigned short opcode)
- {
- /* FIXME -- look up relocation if available */
- return sprintf (buf, "DP+0x%02x", (int) (opcode & 0x7F));
-@@ -552,10 +547,8 @@
- }
-
- static int
--sprint_cc2 (info, buf, opcode)
-- disassemble_info *info ATTRIBUTE_UNUSED;
-- char *buf;
-- unsigned short opcode;
-+sprint_cc2 (disassemble_info *info ATTRIBUTE_UNUSED,
-+ char *buf, unsigned short opcode)
- {
- const char *cc2[] = {
- "??", "??", "ageq", "alt", "aneq", "aeq", "agt", "aleq",
-@@ -565,10 +558,8 @@
- }
-
- static int
--sprint_condition (info, buf, opcode)
-- disassemble_info *info ATTRIBUTE_UNUSED;
-- char *buf;
-- unsigned short opcode;
-+sprint_condition (disassemble_info *info ATTRIBUTE_UNUSED,
-+ char *buf, unsigned short opcode)
- {
- char *start = buf;
- const char *cmp[] = {
diff --git a/devel/gdb/files/patch-opcodes-v850-dis.c b/devel/gdb/files/patch-opcodes-v850-dis.c
new file mode 100644
index 000000000000..5cbc2683d4d6
--- /dev/null
+++ b/devel/gdb/files/patch-opcodes-v850-dis.c
@@ -0,0 +1,20 @@
+--- opcodes/v850-dis.c.orig 2013-01-24 12:14:05.000000000 +0100
++++ opcodes/v850-dis.c 2013-04-29 10:10:25.000000000 +0200
+@@ -73,7 +73,7 @@
+ "chbwbd", "cibid", "cibiwbd", "cibwbd", "cfald", "cistd", "cildd"
+ };
+
+-static const int const v850_cacheop_codes[] =
++static const int v850_cacheop_codes[] =
+ {
+ 0x00, 0x20, 0x40, 0x60, 0x61, 0x04, 0x06,
+ 0x07, 0x24, 0x26, 0x27, 0x44, 0x64, 0x65, -1
+@@ -82,7 +82,7 @@
+ static const char *const v850_prefop_names[] =
+ { "prefi", "prefd" };
+
+-static const int const v850_prefop_codes[] =
++static const int v850_prefop_codes[] =
+ { 0x00, 0x04, -1};
+
+ static void