aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-18 06:34:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-18 06:34:51 +0000
commiteadf4c39211bb3fa96410c6ba440ca2eeeb3cbe8 (patch)
tree914fcc2092d32351616eb94bc0eaab17fd28bc9b /devel/gdb
parent5630a04733689166c12baf27112bf8fae3e079c2 (diff)
Notes
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index a849595929dc..1c74d06ee71b 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -1,5 +1,5 @@
# ex:ts=8
-# Ports collection makefile for: GDB 7.1
+# Ports collection makefile for: GDB 7.3.x
# Date created: 16 November 2010
# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
#
@@ -42,7 +42,8 @@ ONLY_FOR_ARCHS= i386 amd64 # untested elsewhere, might work
OPTIONS= DEBUG "Build with debugging symbols" off \
EXPAT "Enable XML parsing for metadata" off \
- PYTHON "Enable Python support" off
+ PYTHON "Enable Python support" off \
+ THREAD "Enable Thread support" on
.include <bsd.port.options.mk>
@@ -83,7 +84,9 @@ CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's/$$/ [GDB v${PORTVERSION} for FreeBSD]/' \
${WRKSRC}/gdb/version.in
- @${CP} ${FILESDIR}/fbsd-threads.c ${WRKSRC}/gdb
+.if !defined(WITHOUT_THREAD)
+ @${CP} ${FILESDIR}/fbsd-threads.c ${WRKSRC}/gdb/
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/gdb${VER}