aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2013-09-26 02:30:22 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2013-09-26 02:30:22 +0000
commitde7c4f8ba0a941405d042951bc8f7c827da39069 (patch)
tree8007fa385911c68a3958d5f7469e6eccd6e2fba4 /devel/gdb
parentc44d6234b5a5b1cbac1fb820d2be49d3fa331c98 (diff)
downloadports-de7c4f8ba0a941405d042951bc8f7c827da39069.tar.gz
ports-de7c4f8ba0a941405d042951bc8f7c827da39069.zip
Notes
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile7
-rw-r--r--devel/gdb/distinfo4
-rw-r--r--devel/gdb/files/extrapatch-gdb-Makefile.in4
-rw-r--r--devel/gdb/files/extrapatch-gdb-configure.tgt2
-rw-r--r--devel/gdb/files/patch-include-cgen-basic-ops.h43
-rw-r--r--devel/gdb/pkg-plist4
6 files changed, 56 insertions, 8 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 2891212f178a..8b0067f8d641 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gdb
-PORTVERSION= 7.6
+PORTVERSION= 7.6.1
#PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
@@ -14,8 +14,8 @@ LICENSE= GPLv3
USE_BZIP2= yes
USE_CSTD= gnu89
-USE_GMAKE= yes
-USES= iconv
+#USE_GMAKE= yes
+USES= iconv gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
@@ -129,6 +129,7 @@ post-install:
.if ${PORT_OPTIONS:MPYTHON}
${CHMOD} u+w ${PREFIX}/share/gdb${VER}/python/gdb/*.py*
${CHMOD} u+w ${PREFIX}/share/gdb${VER}/python/gdb/command/*.py*
+ ${CHMOD} u+w ${PREFIX}/share/gdb${VER}/python/gdb/function/*.py*
.endif
.include <bsd.port.post.mk>
diff --git a/devel/gdb/distinfo b/devel/gdb/distinfo
index f2f6ba7ac235..6873de1f1e8d 100644
--- a/devel/gdb/distinfo
+++ b/devel/gdb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdb-7.6.tar.bz2) = a410e8f35ee70cce83dbbf1da9e2a8373f271ac0e4b71db4336ae293fc7bdf1b
-SIZE (gdb-7.6.tar.bz2) = 24333590
+SHA256 (gdb-7.6.1.tar.bz2) = e3dfa38a14a5457f9b8b26f7b5080ba5491bd10ae4d69bfe357cea87b7d162e4
+SIZE (gdb-7.6.1.tar.bz2) = 24338919
diff --git a/devel/gdb/files/extrapatch-gdb-Makefile.in b/devel/gdb/files/extrapatch-gdb-Makefile.in
index 0e1632e6373a..a441bddbe1ad 100644
--- a/devel/gdb/files/extrapatch-gdb-Makefile.in
+++ b/devel/gdb/files/extrapatch-gdb-Makefile.in
@@ -19,7 +19,7 @@
nbsd-tdep.o obsd-tdep.o \
sol2-tdep.o \
solib-frv.o solib-irix.o solib-svr4.o \
-@@ -1164,7 +1164,7 @@
+@@ -1173,7 +1174,7 @@
# Removing the old gdb first works better if it is running, at least on SunOS.
gdb$(EXEEXT): gdb.o $(LIBGDB_OBS) $(ADD_DEPS) $(CDEPS) $(TDEPLIBS)
rm -f gdb$(EXEEXT)
@@ -28,7 +28,7 @@
-o gdb$(EXEEXT) gdb.o $(LIBGDB_OBS) \
$(TDEPLIBS) $(TUI_LIBRARY) $(CLIBS) $(LOADLIBES)
-@@ -1429,7 +1429,7 @@
+@@ -1442,7 +1443,7 @@
armnbsd-nat.c armbsd-tdep.c armnbsd-tdep.c armobsd-tdep.c \
avr-tdep.c \
bfin-linux-tdep.c bfin-tdep.c \
diff --git a/devel/gdb/files/extrapatch-gdb-configure.tgt b/devel/gdb/files/extrapatch-gdb-configure.tgt
index 5b40cdfd4810..c143206fe4d2 100644
--- a/devel/gdb/files/extrapatch-gdb-configure.tgt
+++ b/devel/gdb/files/extrapatch-gdb-configure.tgt
@@ -25,5 +25,5 @@
- bsd-uthread.o solib-svr4.o"
+ fbsd-threads.o solib-svr4.o"
;;
- x86_64-*-mingw*)
+ x86_64-*-mingw* | x86_64-*-cygwin*)
# Target: MingW/amd64
diff --git a/devel/gdb/files/patch-include-cgen-basic-ops.h b/devel/gdb/files/patch-include-cgen-basic-ops.h
new file mode 100644
index 000000000000..30c9f2ec399c
--- /dev/null
+++ b/devel/gdb/files/patch-include-cgen-basic-ops.h
@@ -0,0 +1,43 @@
+--- include/cgen/basic-ops.h.orig 2013-03-07 17:31:21.000000000 +0100
++++ include/cgen/basic-ops.h 2013-03-07 17:31:28.000000000 +0100
+@@ -24,11 +24,16 @@
+
+ #include <assert.h>
+
+-#if defined (__GNUC__) && ! defined (SEMOPS_DEFINE_INLINE)
++#if defined (__GNUC__) && ! defined (SEMOPS_DEFINE_INLINE) && ! defined (__clang__)
+ #define SEMOPS_DEFINE_INLINE
+ #define SEMOPS_INLINE extern inline
+ #else
+-#define SEMOPS_INLINE
++# if defined (__clang__) && ! defined (SEMOPS_DEFINE_INLINE)
++# define SEMOPS_DEFINE_INLINE
++# define SEMOPS_INLINE static inline
++# else
++# define SEMOPS_INLINE
++# endif
+ #endif
+
+ /* These don't really have a mode. */
+@@ -295,11 +300,16 @@
+ significant and word number 0 is the most significant word.
+ ??? May also wish an endian-dependent version. Later. */
+
+-QI SUBWORDSIQI (SI, int);
+-HI SUBWORDSIHI (SI, int);
+-QI SUBWORDDIQI (DI, int);
+-HI SUBWORDDIHI (DI, int);
+-SI SUBWORDDISI (DI, int);
++#if defined (__clang__) && defined (SEMOPS_DEFINE_INLINE)
++#define SEMOPS_STATIC static
++#else
++#define SEMOPS_STATIC
++#endif
++SEMOPS_STATIC QI SUBWORDSIQI (SI, int);
++SEMOPS_STATIC HI SUBWORDSIHI (SI, int);
++SEMOPS_STATIC QI SUBWORDDIQI (DI, int);
++SEMOPS_STATIC HI SUBWORDDIHI (DI, int);
++SEMOPS_STATIC SI SUBWORDDISI (DI, int);
+
+ #ifdef SEMOPS_DEFINE_INLINE
+
diff --git a/devel/gdb/pkg-plist b/devel/gdb/pkg-plist
index 8044d0aab361..55d5944b09e9 100644
--- a/devel/gdb/pkg-plist
+++ b/devel/gdb/pkg-plist
@@ -9,6 +9,10 @@ bin/gdb%%VER%%
%%PYTHON%%share/gdb%%VER%%/python/gdb/command/pretty_printers.py
%%PYTHON%%share/gdb%%VER%%/python/gdb/command/prompt.py
%%PYTHON%%share/gdb%%VER%%/python/gdb/command/explore.py
+%%PYTHON%%share/gdb%%VER%%/python/gdb/command/type_printers.py
+%%PYTHON%%share/gdb%%VER%%/python/gdb/function/__init__.py
+%%PYTHON%%share/gdb%%VER%%/python/gdb/function/strfns.py
+%%PYTHON%%@dirrm share/gdb%%VER%%/python/gdb/function
%%PYTHON%%@dirrm share/gdb%%VER%%/python/gdb/command
%%PYTHON%%@dirrm share/gdb%%VER%%/python/gdb
%%PYTHON%%@dirrm share/gdb%%VER%%/python