aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-08-03 02:00:58 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-08-03 02:00:58 +0000
commit89ab1cda2cc44381bd86bcaa7750730a0e76110b (patch)
tree19588e0124af54f40cd54a91ccfd127cbf4ab343 /devel/gdb
parent3acab9b1fb4f8ebdbf168490133083afd22336f6 (diff)
downloadports-89ab1cda2cc44381bd86bcaa7750730a0e76110b.tar.gz
ports-89ab1cda2cc44381bd86bcaa7750730a0e76110b.zip
Notes
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile5
-rw-r--r--devel/gdb/files/fbsd-threads.c8
2 files changed, 8 insertions, 5 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 710dbf349cd3..3acae5070a06 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdb
PORTVERSION= 7.4.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= GNU
@@ -38,7 +38,8 @@ MAN1= gdb${VER}.1
ONLY_FOR_ARCHS= i386 amd64 # untested elsewhere, might work
-# Forcing to use the readline.6
+# Forcing to use the readline from ports (readline in FreeBSD world is not
+# compatible anymore).
LIB_DEPENDS+= readline:${PORTSDIR}/devel/readline
CFLAGS+= -isystem ${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/gdb/files/fbsd-threads.c b/devel/gdb/files/fbsd-threads.c
index cc8a2901c2c1..cf33b641d888 100644
--- a/devel/gdb/files/fbsd-threads.c
+++ b/devel/gdb/files/fbsd-threads.c
@@ -1,4 +1,4 @@
-/* $FreeBSD: /tmp/pcvs/ports/devel/gdb/files/fbsd-threads.c,v 1.4 2012-06-23 09:12:05 scheidell Exp $ */
+/* $FreeBSD$ */
/* FreeBSD libthread_db assisted debugging support.
Copyright 1999, 2000, 2001 Free Software Foundation, Inc.
@@ -747,8 +747,10 @@ fbsd_thread_wait (struct target_ops *ops,
*/
if (!fbsd_thread_alive (ops, inferior_ptid) && !ptid_equal(inferior_ptid, ret))
{
- delete_thread (inferior_ptid);
+ ptid_t save_ptid;
+ save_ptid = inferior_ptid;
inferior_ptid = ret;
+ delete_thread (save_ptid);
}
}
@@ -1176,7 +1178,7 @@ tsd_cb (thread_key_t key, void (*destructor)(void *), void *ignore)
else
name = SYMBOL_PRINT_NAME (ms);
- printf_filtered ("Destructor %p <%s>\n", destructor, name);
+ printf_filtered ("Key %d, destructor %p <%s>\n", key, destructor, name);
return 0;
}