aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2012-08-27 16:10:54 +0000
committerKoop Mast <kwm@FreeBSD.org>2012-08-27 16:10:54 +0000
commitd35acc5f42732bdc127e8758b825f87e2441bb56 (patch)
treeca6087039820fe20ac2ca5caa756a7963f7d9235 /devel/gdb
parentbbd8af8aa8925e1bd7d06dfa0f2c4579796e0b1d (diff)
Don't allow files to be extracted with 0666 permissions.
Readd a patch that fixes thread support Correct configure test so it detects r_fs and r_gs fields of struct reg. This fixes thread support on i386 10-current. Fix a segmentation fault on the amd64 architecture PR: ports/171109 [2], ports/171086 [1] Reported by: Arrowdodger <6yearold@gmail.com> [2] Submitted by: maintainer [2], Tijl Coosemans <tijl@coosemans.org> [1]
Notes
Notes: svn path=/head/; revision=303232
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile4
-rw-r--r--devel/gdb/files/extrapatch-gdb-Makefile.in11
-rw-r--r--devel/gdb/files/patch-gdb-amd64-nat.h12
-rw-r--r--devel/gdb/files/patch-gdb-configure22
4 files changed, 35 insertions, 14 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 09d9a9804ee1..561653efbfe1 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gdb
PORTVERSION= 7.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
@@ -30,7 +31,8 @@ CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect readline sim texinfo intl
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - ${EXCLUDE:S/^/--exclude /}
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXCLUDE:S/^/--exclude /} \
+ --no-same-owner --no-same-permissions
VER= ${PORTVERSION:S/.//g}
PLIST_SUB= VER=${VER}
MAN1= gdb${VER}.1
diff --git a/devel/gdb/files/extrapatch-gdb-Makefile.in b/devel/gdb/files/extrapatch-gdb-Makefile.in
index 1f06679e0068..b2f6c4c24e75 100644
--- a/devel/gdb/files/extrapatch-gdb-Makefile.in
+++ b/devel/gdb/files/extrapatch-gdb-Makefile.in
@@ -1,5 +1,5 @@
--- gdb/Makefile.in.orig 2012-07-02 17:29:33.000000000 +0200
-+++ gdb/Makefile.in 2012-08-22 16:50:26.000000000 +0200
++++ gdb/Makefile.in 2012-08-26 21:01:45.589052997 +0200
@@ -572,7 +572,7 @@
xstormy16-tdep.o \
xtensa-config.o xtensa-tdep.o xtensa-linux-tdep.o \
@@ -18,6 +18,15 @@
mdebugread.h m88k-tdep.h stabsread.h hppa-linux-offsets.h linux-fork.h \
ser-unix.h inf-ptrace.h terminal.h ui-out.h frame-base.h \
f-lang.h dwarf2loc.h value.h sparc-tdep.h defs.h target-descriptions.h \
+@@ -1164,7 +1164,7 @@
+ # Removing the old gdb first works better if it is running, at least on SunOS.
+ gdb$(EXEEXT): gdb.o $(LIBGDB_OBS) $(ADD_DEPS) $(CDEPS) $(TDEPLIBS)
+ rm -f gdb$(EXEEXT)
+- $(CC_LD) $(INTERNAL_LDFLAGS) $(WIN32LDAPP) \
++ $(CC_LD) $(INTERNAL_LDFLAGS) $(WIN32LDAPP) -Wl,-E \
+ -o gdb$(EXEEXT) gdb.o $(LIBGDB_OBS) \
+ $(TDEPLIBS) $(TUI_LIBRARY) $(CLIBS) $(LOADLIBES)
+
@@ -1429,7 +1429,7 @@
armnbsd-nat.c armbsd-tdep.c armnbsd-tdep.c armobsd-tdep.c \
avr-tdep.c \
diff --git a/devel/gdb/files/patch-gdb-amd64-nat.h b/devel/gdb/files/patch-gdb-amd64-nat.h
deleted file mode 100644
index 8222cbf6f813..000000000000
--- a/devel/gdb/files/patch-gdb-amd64-nat.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- gdb/amd64-nat.h.orig 2011-09-23 01:36:54.874780473 +0100
-+++ gdb/amd64-nat.h 2011-09-23 01:28:46.964218514 +0100
-@@ -50,9 +50,4 @@
- extern void amd64_collect_native_gregset (const struct regcache *regcache,
- void *gregs, int regnum);
-
--/* Create a prototype *BSD/amd64 target. The client can override it
-- with local methods. */
--
--extern struct target_ops *amd64bsd_target (void);
--
- #endif /* amd64-nat.h */
diff --git a/devel/gdb/files/patch-gdb-configure b/devel/gdb/files/patch-gdb-configure
new file mode 100644
index 000000000000..288eb57dad0b
--- /dev/null
+++ b/devel/gdb/files/patch-gdb-configure
@@ -0,0 +1,22 @@
+--- gdb/configure.orig 2012-08-24 14:03:52.000000000 +0200
++++ gdb/configure 2012-08-24 14:05:06.000000000 +0200
+@@ -10590,7 +10590,8 @@
+
+ # See if <machine/reg.h> supports the %fs and %gs i386 segment registers.
+ # Older i386 BSD's don't have the r_fs and r_gs members of `struct reg'.
+-ac_fn_c_check_member "$LINENO" "struct reg" "r_fs" "ac_cv_member_struct_reg_r_fs" "#include <machine/reg.h>
++ac_fn_c_check_member "$LINENO" "struct reg" "r_fs" "ac_cv_member_struct_reg_r_fs" "#include <sys/types.h>
++#include <machine/reg.h>
+ "
+ if test "x$ac_cv_member_struct_reg_r_fs" = x""yes; then :
+
+@@ -10600,7 +10601,8 @@
+
+
+ fi
+-ac_fn_c_check_member "$LINENO" "struct reg" "r_gs" "ac_cv_member_struct_reg_r_gs" "#include <machine/reg.h>
++ac_fn_c_check_member "$LINENO" "struct reg" "r_gs" "ac_cv_member_struct_reg_r_gs" "#include <sys/types.h>
++#include <machine/reg.h>
+ "
+ if test "x$ac_cv_member_struct_reg_r_gs" = x""yes; then :
+