aboutsummaryrefslogtreecommitdiff
path: root/devel/gdcm
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-06-15 16:02:22 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-06-15 16:02:22 +0000
commit42deab0664e17127bf1fa8784caec073f8224de2 (patch)
tree0e41bce8e3f17952621c501231afc3b60afb26c5 /devel/gdcm
parent9df690bf43779ecd1c10e56462dd24f117295dd2 (diff)
downloadports-42deab0664e17127bf1fa8784caec073f8224de2.tar.gz
ports-42deab0664e17127bf1fa8784caec073f8224de2.zip
Notes
Diffstat (limited to 'devel/gdcm')
-rw-r--r--devel/gdcm/Makefile12
-rw-r--r--devel/gdcm/pkg-plist20
2 files changed, 32 insertions, 0 deletions
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index ee770b03a68d..cac318f8430a 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -12,11 +12,23 @@ MASTER_SITES= SF/gdcm/gdcm%202.x/GDCM%20${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Grassroots DICOM library
+OPTIONS= VTK "Build the VTK bindings" off
+
USE_BZIP2= yes
USE_CMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib \
${PREFIX}/lib/gdcm-${GDCM_MAJ}
+.include <bsd.port.options.mk>
+
+.if defined(WITH_VTK)
+LIB_DEPENDS+= vtkHybrid.5:${PORTSDIR}/math/vtk5
+CMAKE_ARGS+= -DGDCM_USE_VTK:BOOL=YES
+PLIST_SUB+= VTK=""
+.else
+PLIST_SUB+= VTK="@comment "
+.endif
+
GDCM_MAJ= 2.0
GDCM_MIN= 17
diff --git a/devel/gdcm/pkg-plist b/devel/gdcm/pkg-plist
index 50042fb3234a..324bfd05e80b 100644
--- a/devel/gdcm/pkg-plist
+++ b/devel/gdcm/pkg-plist
@@ -7,6 +7,8 @@ bin/gdcmimg
bin/gdcmconv
bin/gdcmtar
bin/gdcminfo
+%%VTK%%bin/gdcm2vtk
+%%VTK%%bin/gdcmviewer
include/gdcm-2.0/gdcmASN1.h
include/gdcm-2.0/gdcmAnonymizeEvent.h
include/gdcm-2.0/gdcmAnonymizer.h
@@ -287,6 +289,21 @@ include/gdcm-2.0/gdcmopenjpeg/t2.h
include/gdcm-2.0/gdcmopenjpeg/tcd.h
include/gdcm-2.0/gdcmopenjpeg/tgt.h
include/gdcm-2.0/zipstreamimpl.h
+%%VTK%%include/gdcm-2.0/vtkGDCMImageReader.h
+%%VTK%%include/gdcm-2.0/vtkGDCMImageWriter.h
+%%VTK%%include/gdcm-2.0/vtkGDCMMedicalImageProperties.h
+%%VTK%%include/gdcm-2.0/vtkGDCMPolyDataReader.h
+%%VTK%%include/gdcm-2.0/vtkGDCMPolyDataWriter.h
+%%VTK%%include/gdcm-2.0/vtkGDCMTesting.h
+%%VTK%%include/gdcm-2.0/vtkGDCMThreadedImageReader.h
+%%VTK%%include/gdcm-2.0/vtkGDCMThreadedImageReader2.h
+%%VTK%%include/gdcm-2.0/vtkImageColorViewer.h
+%%VTK%%include/gdcm-2.0/vtkImageMapToColors16.h
+%%VTK%%include/gdcm-2.0/vtkImageMapToWindowLevelColors2.h
+%%VTK%%include/gdcm-2.0/vtkImagePlanarComponentsToComponents.h
+%%VTK%%include/gdcm-2.0/vtkImageRGBToYBR.h
+%%VTK%%include/gdcm-2.0/vtkImageYBRToRGB.h
+%%VTK%%include/gdcm-2.0/vtkLookupTable16.h
lib/gdcm-2.0/GDCMConfig.cmake
lib/gdcm-2.0/GDCMConfigVersion.cmake
lib/gdcm-2.0/GDCMTargets-%%CMAKE_BUILD_TYPE%%.cmake
@@ -334,6 +351,9 @@ lib/libgdcmuuid.so.%%GDCM_MAJ%%.%%GDCM_MIN%%
lib/libgdcmzlib.so
lib/libgdcmzlib.so.%%GDCM_MAJ%%
lib/libgdcmzlib.so.%%GDCM_MAJ%%.%%GDCM_MIN%%
+%%VTK%%lib/libvtkgdcm.so
+%%VTK%%lib/libvtkgdcm.so.%%GDCM_MAJ%%
+%%VTK%%lib/libvtkgdcm.so.%%GDCM_MAJ%%.%%GDCM_MIN%%
%%DATADIR%%/XML/CSAHeader.xml
%%DATADIR%%/XML/DICOMV3.xml
%%DATADIR%%/XML/Part3.xml