aboutsummaryrefslogtreecommitdiff
path: root/devel/gdcm
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-04-11 08:45:24 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-04-11 08:45:24 +0000
commitaba4671a98621a66941816a3d8b0c4dfb92fd6ca (patch)
tree52fee0a6ccc8badd6f804f51a410b1f88dfef6e2 /devel/gdcm
parentc5569783bdee1084b70d5401db26f219788cd263 (diff)
downloadports-aba4671a98621a66941816a3d8b0c4dfb92fd6ca.tar.gz
ports-aba4671a98621a66941816a3d8b0c4dfb92fd6ca.zip
Notes
Diffstat (limited to 'devel/gdcm')
-rw-r--r--devel/gdcm/Makefile41
-rw-r--r--devel/gdcm/distinfo4
-rw-r--r--devel/gdcm/pkg-plist1
3 files changed, 32 insertions, 14 deletions
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index 2e5e40caf0c5..11eb4401909e 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -12,12 +12,23 @@ COMMENT= Grassroots DICOM library
LIB_DEPENDS= libopenjpeg.so:${PORTSDIR}/graphics/openjpeg \
libexpat.so:${PORTSDIR}/textproc/expat2
-OPTIONS_DEFINE= VTK DOCS
+OPTIONS_DEFINE= DOCS
OPTIONS_UNSET= DOCS
-VTK_DESC= Build with VTK bindings
+OPTIONS_RADIO= VTK
+OPTIONS_RADIO_VTK= VTK5 VTK6
+VTK5_DESC= Build VTK 5 integration classes
+VTK6_DESC= Build VTK 6 integration classes
-USE_BZIP2= yes
-USES= cmake:outsource
+# Change this when updating the port
+GDCM_MAJOR= 2
+GDCM_MINOR= 4
+GDCM_PATCH= 2
+
+# Change this whenever VTK is updated
+VTK5_VERSION= 5.10
+VTK6_VERSION= 6.1
+
+USES= cmake:outsource tar:bzip2
USE_OPENSSL= yes
USE_LDCONFIG= ${PREFIX}/lib
CFLAGS+= -I${LOCALBASE}/include
@@ -33,18 +44,24 @@ CMAKE_ARGS+= -DGDCM_PDF_DOCUMENTATION:BOOL=NO \
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MVTK}
-LIB_DEPENDS+= libvtkHybrid.so.5:${PORTSDIR}/math/vtk5
-CMAKE_ARGS+= -DGDCM_USE_VTK:BOOL=YES
+.if ${PORT_OPTIONS:MVTK5}
+LIB_DEPENDS+= libvtkHybrid.so:${PORTSDIR}/math/vtk5
+CMAKE_ARGS+= -DGDCM_USE_VTK:BOOL=YES \
+ -DVTK_DIR:PATH=${LOCALBASE}/lib/vtk-${VTK5_VERSION}
+.endif
+
+.if ${PORT_OPTIONS:MVTK6}
+LIB_DEPENDS+= libvtkCommonCore-${VTK6_VERSION}.so:${PORTSDIR}/math/vtk6
+CMAKE_ARGS+= -DGDCM_USE_VTK:BOOL=YES \
+ -DVTK_DIR:PATH=${LOCALBASE}/lib/vtk-${VTK6_VERSION}
+.endif
+
+.if ${PORT_OPTIONS:MVTK5} || ${PORT_OPTIONS:MVTK6}
PLIST_SUB+= VTK=""
.else
-PLIST_SUB+= VTK="@comment "
+PLIST_SUB+= VTK="@comment "
.endif
-GDCM_MAJOR= 2
-GDCM_MINOR= 4
-GDCM_PATCH= 1
-
PLIST_SUB+= GDCM_MAJOR="${GDCM_MAJOR}" \
GDCM_MINOR="${GDCM_MINOR}" \
GDCM_PATCH="${GDCM_PATCH}"
diff --git a/devel/gdcm/distinfo b/devel/gdcm/distinfo
index 613011313ce9..093a31f0c233 100644
--- a/devel/gdcm/distinfo
+++ b/devel/gdcm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdcm-2.4.1.tar.bz2) = 57da8d4dc9d9d149e5d857453e9471598ae39414bbac74b31129c2b7cdb6cb0f
-SIZE (gdcm-2.4.1.tar.bz2) = 4376426
+SHA256 (gdcm-2.4.2.tar.bz2) = fe2f8b1a206912d4fc83ed5de4e5eedaa08e2f32b295b13407c8b27c1bef5d11
+SIZE (gdcm-2.4.2.tar.bz2) = 4401949
diff --git a/devel/gdcm/pkg-plist b/devel/gdcm/pkg-plist
index 01905c483b00..7d00bf719dae 100644
--- a/devel/gdcm/pkg-plist
+++ b/devel/gdcm/pkg-plist
@@ -394,6 +394,7 @@ include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/socketxx/sockstream.h
include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/socketxx/sockunix.h
include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/zipstreamimpl.h
%%VTK%%include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/vtkGDCMImageReader.h
+%%VTK%%include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/vtkGDCMImageReader2.h
%%VTK%%include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/vtkGDCMImageWriter.h
%%VTK%%include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/vtkGDCMMedicalImageProperties.h
%%VTK%%include/gdcm-%%GDCM_MAJOR%%.%%GDCM_MINOR%%/vtkGDCMPolyDataReader.h