aboutsummaryrefslogtreecommitdiff
path: root/devel/geany-plugin-vc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-10-06 18:20:59 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-10-06 18:20:59 +0000
commit4bc8c29c2acf8465d737d4783b4a14ed81f408c0 (patch)
treebb9cd056f32028e9b8981c76a677f75c753b3e93 /devel/geany-plugin-vc
parent8f78d3a36f21d1755786be71c9ec19d8def1f0a8 (diff)
downloadports-4bc8c29c2acf8465d737d4783b4a14ed81f408c0.tar.gz
ports-4bc8c29c2acf8465d737d4783b4a14ed81f408c0.zip
Notes
Diffstat (limited to 'devel/geany-plugin-vc')
-rw-r--r--devel/geany-plugin-vc/Makefile27
-rw-r--r--devel/geany-plugin-vc/pkg-descr6
-rw-r--r--devel/geany-plugin-vc/pkg-plist10
3 files changed, 43 insertions, 0 deletions
diff --git a/devel/geany-plugin-vc/Makefile b/devel/geany-plugin-vc/Makefile
new file mode 100644
index 000000000000..f606257199bb
--- /dev/null
+++ b/devel/geany-plugin-vc/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= geany-plugin
+PORTVERSION= ${GEANY_VER}
+CATEGORIES= devel
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
+
+GEANY_PLUGIN= vc
+GEANY_PLUGIN_DIR= geanyvc
+
+OPTIONS_DEFINE= GTKSPELL
+OPTIONS_DEFAULT= GTKSPELL
+GTKSPELL_DESC= Spell checking support via GtkSpell
+
+.include "${.CURDIR}/../geany-plugins/files/Makefile.common"
+# bsd.port.options.mk is already included
+
+.if ${PORT_OPTIONS:MGTKSPELL}
+LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
+CONFIGURE_ARGS+= --enable-gtkspell
+.else
+CONFIGURE_ARGS+= --disable-gtkspell
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/geany-plugin-vc/pkg-descr b/devel/geany-plugin-vc/pkg-descr
new file mode 100644
index 000000000000..974f0786bfa8
--- /dev/null
+++ b/devel/geany-plugin-vc/pkg-descr
@@ -0,0 +1,6 @@
+GeanyVC is plugin that provides a uniform way of accessing the
+different version-control systems inside Geany IDE. Only small
+subset of vc is implemented, but, hey, you don't need anything
+besides diff, log, status, revert and commit most time.
+
+WWW: http://plugins.geany.org/geanyvc.html
diff --git a/devel/geany-plugin-vc/pkg-plist b/devel/geany-plugin-vc/pkg-plist
new file mode 100644
index 000000000000..07c86fce8c68
--- /dev/null
+++ b/devel/geany-plugin-vc/pkg-plist
@@ -0,0 +1,10 @@
+lib/geany/geanyvc.a
+lib/geany/geanyvc.la
+lib/geany/geanyvc.so
+%%DOCSDIR%%/geanyvc/AUTHORS
+%%DOCSDIR%%/geanyvc/COPYING
+%%DOCSDIR%%/geanyvc/ChangeLog
+%%DOCSDIR%%/geanyvc/NEWS
+%%DOCSDIR%%/geanyvc/README
+@dirrm %%DOCSDIR%%/geanyvc
+@dirrmtry %%DOCSDIR%%