aboutsummaryrefslogtreecommitdiff
path: root/devel/geany-plugins
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-10-06 18:20:59 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-10-06 18:20:59 +0000
commit4bc8c29c2acf8465d737d4783b4a14ed81f408c0 (patch)
treebb9cd056f32028e9b8981c76a677f75c753b3e93 /devel/geany-plugins
parent8f78d3a36f21d1755786be71c9ec19d8def1f0a8 (diff)
downloadports-4bc8c29c2acf8465d737d4783b4a14ed81f408c0.tar.gz
ports-4bc8c29c2acf8465d737d4783b4a14ed81f408c0.zip
Notes
Diffstat (limited to 'devel/geany-plugins')
-rw-r--r--devel/geany-plugins/Makefile218
-rw-r--r--devel/geany-plugins/distinfo4
-rw-r--r--devel/geany-plugins/files/Makefile.common50
-rw-r--r--devel/geany-plugins/files/bsd.geany-plugins.mk41
-rw-r--r--devel/geany-plugins/files/patch-wscript11
-rw-r--r--devel/geany-plugins/pkg-descr9
6 files changed, 115 insertions, 218 deletions
diff --git a/devel/geany-plugins/Makefile b/devel/geany-plugins/Makefile
index a2707690cc5b..01a854dbdf3e 100644
--- a/devel/geany-plugins/Makefile
+++ b/devel/geany-plugins/Makefile
@@ -1,213 +1,35 @@
-# New ports collection Makefile for: geany-plugins
-# Date Created: 24 May 2010
-# Whom: Aldis Berjoza <aldis@bsdroot.lv>
-#
+# Created by: Aldis Berjoza <aldis@bsdroot.lv>
# $FreeBSD$
-#
PORTNAME= geany-plugins
-PORTVERSION= 0.19
+PORTVERSION= ${GEANY_VER}
CATEGORIES= devel
-MASTER_SITES= http://plugins.geany.org/geany-plugins/
+DISTFILES= # none
-MAINTAINER= ar@null.lv
-COMMENT= Plugins for lightweight editor - geany
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Geany plugins (meta port)
-BUILD_DEPENDS= geany:${PORTSDIR}/devel/geany
-RUN_DEPENDS= geany:${PORTSDIR}/devel/geany
+NO_BUILD= yes
-BROKEN= does not compile
+.include "${.CURDIR}/files/bsd.geany-plugins.mk"
-USE_GMAKE= yes
-USE_GNOME= gtk20
-USE_BZIP2= yes
-USE_PYTHON_BUILD= 2.6+
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-OPTIONS= GEANY_ADDONS "ADDONS" on \
- GEANY_GEANYDOC "GEANYDOC" on \
- GEANY_GEANYGDB "GDB support (broken)" off \
- GEANY_GEANYLATEX "Improve work with LaTeX" on \
- GEANY_GEANYLIPSUM "GEANYLIPSUM" on \
- GEANY_GEANYLUA "LUA support (broken)" off \
- GEANY_GEANYPRJ "Alternative project management" on \
- GEANY_GEANYSENDMAIL "Sending mail from geany" on \
- GEANY_GEANYVC "Version-control systems support" on \
- GEANY_SHIFTCOLUMN "SHIFTCOLUMN" on \
- GEANY_SPELLCHECK "Spellchecker support" on \
- GEANY_CODENAV "Siwtch between header and source" on \
- GEANY_INSERTNUM "geanyinsertnum" on \
- GEANY_GEANYEXTRASEL "geanyextrasel" on \
- GEANY_TREEBROWSER "Tree Browser" on \
- GEANY_PRETTYPRINTER "Pretty-printer" on
-
-.include <bsd.port.pre.mk>
-PLUGINS=
-
-.if !defined(WITHOUT_GEANY_TREEBROWSER)
-BUILD_PLUGINS+= ,treebrowser
-PLUGINS+= treebrowser.so
-.endif
-
-.if !defined(WITHOUT_GEANY_CODENAV)
-BUILD_PLUGINS+= ,codenav
-PLUGINS+= codenav.so
-.endif
-
-.if !defined(WITHOUT_GEANY_INSERTNUM)
-BUILD_PLUGINS+= ,geanyinsertnum
-PLUGINS+= geanyinsertnum.so
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYEXTRASEL)
-BUILD_PLUGINS+= ,geanyextrasel
-PLUGINS+= geanyextrasel.so
-.endif
-
-.if !defined(WITHOUT_GEANY_PRETTYPRINTER)
-BUILD_PLUGINS+= ,pretty-printer
-PLUGINS+= pretty-printer.so
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYDOC)
-BUILD_PLUGINS+= ,geanydoc
-PLUGINS+= geanydoc.so
-.endif
-
-.if !defined(WITHOUT_GEANY_ADDONS)
-BUILD_PLUGINS+= ,addons
-PLUGINS+= addons.so
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYGDB)
-# handle geanygdb manually
-BROKEN= geanygdb plugins doesn't work
-BUILD_PLUGINS+= ,geanygdb
-PLIST_FILES+= lib/geany/geanygdb.so \
- libexec/geany-plugins/geanygdb/ttyhelper
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYLATEX)
-BUILD_PLUGINS+= ,geanylatex
-PLUGINS+= geanylatex.so
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYLIPSUM)
-BUILD_PLUGINS+= ,geanylipsum
-PLUGINS+= geanylipsum.so
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYLUA)
-# I will handle geanulua manually
-BUILD_PLUGINS+= ,geanylua
-USE_LUA= 5.1
-PLIST_FILES+= lib/geany/geanylua.so \
- lib/geany-plugins/geanylua/libgeanylua.so \
- share/doc/geany-plugins/geanylua/geanylua-input.html \
- share/doc/geany-plugins/geanylua/geanylua-ref.html \
- share/doc/geany-plugins/geanylua/geanylua-index.html \
- share/doc/geany-plugins/geanylua/geanylua-intro.html \
- share/doc/geany-plugins/geanylua/geanylua-keys.html \
- share/doc/geany-plugins/geanylua/geanylua-keyfile.html \
- share/doc/geany-plugins/geanylua/luarefv51.html \
- share/geany-plugins/geanylua/dialogs/complex-dialog.lua \
- share/geany-plugins/geanylua/dialogs/basic-dialogs.lua \
- share/geany-plugins/geanylua/edit/select-block.lua \
- share/geany-plugins/geanylua/edit/proper-case.lua \
- share/geany-plugins/geanylua/edit/right-trim.lua \
- share/geany-plugins/geanylua/edit/calculator.lua \
- share/geany-plugins/geanylua/edit/lua-replace.lua \
- share/geany-plugins/geanylua/edit/reverse.lua \
- share/geany-plugins/geanylua/info/show-filename.lua \
- share/geany-plugins/geanylua/info/about.lua \
- share/geany-plugins/geanylua/info/list-open-files.lua \
- share/geany-plugins/geanylua/info/file-informa\tion.lua \
- share/geany-plugins/geanylua/info/app-information.lua \
- share/geany-plugins/geanylua/scripting/show-examples.lua \
- share/geany-plugins/geanylua/scripting/open-script.lua \
- share/geany-plugins/geanylua/scripting/help.lua \
- share/geany-plugins/geanylua/scripting/rebuild-menu.lua \
- share/geany-plugins/geanylua/work/03.install-test-script.lua \
- share/geany-plugins/geanylua/work/02.run-test-script.lua \
- share/geany-plugins/geanylua/work/01.edit-test-script.lua
-PLIST_DIRS+= lib/geany-plugins/geanylua \
- lib/geany-plugins \
- share/doc/geany-plugins/geanylua \
- share/doc/geany-plugins \
- share/geany-plugins/geanylua/dialogs \
- share/geany-plugins/geanylua/edit \
- share/geany-plugins/geanylua/info \
- share/geany-plugins/geanylua/scripting \
- share/geany-plugins/geanylua/work \
- share/geany-plugins/geanylua \
- share/geany-plugins
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYPRJ)
-BUILD_PLUGINS+= ,geanyprj
-PLUGINS+= geanyprj.so
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYVC)
-BUILD_PLUGINS+= ,geanyvc
-LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
-PLUGINS+= geanyvc.so
-.endif
-
-.if !defined(WITHOUT_GEANY_GEANYSENDMAIL)
-BUILD_PLUGINS+= ,geanysendmail
-PLUGINS+= geanysendmail.so
-.endif
-
-.if !defined(WITHOUT_GEANY_SHIFTCOLUMN)
-BUILD_PLUGINS+= ,shiftcolumn
-PLUGINS+= shiftcolumn.so
-.endif
-
-.if !defined(WITHOUT_GEANY_SPELLCHECK)
-BUILD_PLUGINS+= ,spellcheck
-LIB_DEPENDS+= enchant:${PORTSDIR}/textproc/enchant
-PLUGINS+= spellcheck.so
-.endif
-
-.if !defined(BUILD_PLUGINS)
-IGNORE= no plugins selected
-.endif
-
-.if !defined(WITHOUT_NLS)
-PO_FILES= be ca da de es fr gl ja pt pt_BR ru tr zh_CN
-.for i in ${PO_FILES}
-PLIST_FILES+= share/locale/${i}/LC_MESSAGES/geany-plugins.mo
+.for plugin in ${GEANY_PLUGINS_ALL}
+OPTIONS_DEFINE+= ${plugin:U}
+${plugin:U}_DESC= ${${plugin}_DESC}
+${plugin:U}_DEP= geany-plugin-${plugin}>=0:${PORTSDIR}/devel/geany-plugin-${plugin}
.endfor
-.endif
-.for i in ${PLUGINS}
-PLIST_FILES+= lib/geany/${i}
-.endfor
+.include <bsd.port.options.mk>
-do-configure:
- BUILD_PLUGINS=$(${ECHO} ${BUILD_PLUGINS} | ${SED} -e 's/^,//')
- @${WRKSRC}/waf configure --enable-plugins="${BUILD_PLUGINS}" -b ${WRKSRC}/_build_
+.for opt in ${OPTIONS_DEFINE}
+. if ${PORT_OPTIONS:M${opt}}
+RUN_DEPENDS+= ${${opt}_DEP}
+. endif
+.endfor
do-install:
-.for i in ${PLUGINS}
- @${INSTALL_PROGRAM} ${WRKSRC}/_build_/default/${i} ${PREFIX}/lib/geany/
-.endfor
-.if !defined(WITHOUT_GEANY_GEANYGDB)
- @${MKDIR} ${PREFIX}/libexec/geany-plugins/geanygdb
- @${INSTALL_PROGRAM} ${WRKSRC}/_build_/default/geanygdb.so ${PREFIX}/lib/geany/
- @${INSTALL_PROGRAM} ${WRKSRC}/_build_/default/ttyhelper ${PREFIX}/libexec/geany-plugins/geanygdb/
-.endif
-.if !defined(WITHOUT_GEANY_GEANYLUA)
- @${MKDIR} ${PREFIX}/lib/geany-plugins/geanylua
- @${INSTALL_PROGRAM} ${WRKSRC}/_build_/default/libgeanylua.so ${PREFIX}/lib/geany-plugins/geanylua/
- @${INSTALL_PROGRAM} ${WRKSRC}/_build_/default/geanylua.so ${PREFIX}/lib/geany/
- @(cd ${WRKSRC}/geanylua/examples/ && ${COPYTREE_SHARE} \* ${PREFIX}/share/geany-plugins/geanylua/ "! -name Makefile.in -and ! -name Makefile.am")
- @(cd ${WRKSRC}/geanylua/docs/ && ${COPYTREE_SHARE} \* ${PREFIX}/share/doc/geany-plugins/geanylua/ "! -name Makefile.in -and ! -name Makefile.am")
-.endif
-.if !defined(WITHOUT_NLS)
-.for i in ${PO_FILES}
- @${INSTALL_DATA} ${WRKSRC}/_build_/default/po/${i}.mo ${PREFIX}/share/locale/${i}/LC_MESSAGES/geany-plugins.mo
-.endfor
-.endif
+ ${DO_NADA}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/geany-plugins/distinfo b/devel/geany-plugins/distinfo
index a357302df9a8..07d102e554ee 100644
--- a/devel/geany-plugins/distinfo
+++ b/devel/geany-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (geany-plugins-0.19.tar.bz2) = 41a6ab69ede801d660761c799b64c8d0027d76a1dda584777f4d40e1ba064324
-SIZE (geany-plugins-0.19.tar.bz2) = 842017
+SHA256 (geany-plugins-1.22.tar.bz2) = a0dcf0cb00ac260670ef8fae682aade60c7c3075c88121fd21f3aecdff84e1ce
+SIZE (geany-plugins-1.22.tar.bz2) = 2088130
diff --git a/devel/geany-plugins/files/Makefile.common b/devel/geany-plugins/files/Makefile.common
new file mode 100644
index 000000000000..79e25c08cb77
--- /dev/null
+++ b/devel/geany-plugins/files/Makefile.common
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+.include "${.CURDIR}/../../devel/geany-plugins/files/bsd.geany-plugins.mk"
+
+MASTER_SITES= http://plugins.geany.org/geany-plugins/
+PKGNAMESUFFIX?= -${GEANY_PLUGIN}
+DISTNAME= geany-plugins-${PORTVERSION}
+DISTINFO_FILE= ${.CURDIR}/../../devel/geany-plugins/distinfo
+
+BUILD_DEPENDS+= ${LOCALBASE}/bin/geany:${PORTSDIR}/devel/geany \
+ ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS+= ${LOCALBASE}/bin/geany:${PORTSDIR}/devel/geany
+
+CONFLICTS_INSTALL= geany-plugins-0.*
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS+= libtool
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+USE_GNOME+= gtk20
+
+GEANY_PLUGIN_DIR?= ${GEANY_PLUGIN}
+GEANY_PLUGIN_SWITCH?= --enable-${GEANY_PLUGIN_DIR}
+
+CONFIGURE_ARGS+= ${GEANY_PLUGIN_SWITCH}
+
+BUILD_WRKSRC= ${WRKSRC}/${GEANY_PLUGIN_DIR}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+DATADIR= share/geany-plugins
+DOCSDIR= share/doc/geany-plugins
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+.else
+CONFIGURE_ARGS+= --disable-nls
+.endif
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,/bin/sh,${LOCALBASE}/bin/bash,g' \
+ -e 's,zlib,,g' \
+ ${WRKSRC}/configure
+
+post-configure:
+ ${FIND} ${BUILD_WRKSRC} -name Makefile | ${XARGS} \
+ ${REINPLACE_CMD} -e '/^geanypluginsdir/s,${LOCALBASE},${PREFIX},'
diff --git a/devel/geany-plugins/files/bsd.geany-plugins.mk b/devel/geany-plugins/files/bsd.geany-plugins.mk
new file mode 100644
index 000000000000..c614c3047ec9
--- /dev/null
+++ b/devel/geany-plugins/files/bsd.geany-plugins.mk
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+GEANY_VER= 1.22
+
+GEANY_PLUGINS_ALL= addons codenav debugger devhelp doc extrasel gdb \
+ gendoc geniuspaste gproject insertnum latex lipsum \
+ lua macro miniscript multiterm numberedbookmarks \
+ pg pretty-printer prj sendmail shiftcolumn \
+ spellcheck tableconvert treebrowser updatechecker \
+ vc webhelper xmlsnippets
+
+addons_DESC= various small addons
+codenav_DESC= some facilities for navigating in the code
+debugger_DESC= debugging support (via GDB currently)
+devhelp_DESC= API documentation browser
+doc_DESC= execute command on the word at cursor position
+extrasel_DESC= additional selection tools
+gdb_DESC= debugging support via the GNU Debugger
+gendoc_DESC= generate documentation from the sources comments
+geniuspaste_DESC= pastebins support
+gproject_DESC= extension of Geany's project management
+insertnum_DESC= replaces selection with integer numbers
+latex_DESC= LaTeX support
+lipsum_DESC= Lorem Ipsum generator
+lua_DESC= Lua scripting
+macro_DESC= user defined macros
+miniscript_DESC= pipe text/documents via script (shell, perl, awk, etc.)
+multiterm_DESC= multi-tabbed virtual terminals emulator
+numberedbookmarks_DESC= additional numbered bookmarks
+pg_DESC= encrypt, decrypt and verify signatures with GnuPG
+pretty-printer_DESC= formats XML and make it human-readable
+prj_DESC= alternative project manager
+sendmail_DESC= send a document as attachment
+shiftcolumn_DESC= move blocks of text horizontally
+spellcheck_DESC= spell check via Enchant
+tableconvert_DESC= convert tabulator separated selection into a table
+treebrowser_DESC= alternate file browser
+updatechecker_DESC= check for new version of Geany
+vc_DESC= access to different version-control systems
+webhelper_DESC= web development facilities
+xmlsnippets_DESC= XML/HTML tag autocompletion
diff --git a/devel/geany-plugins/files/patch-wscript b/devel/geany-plugins/files/patch-wscript
deleted file mode 100644
index 5fac4d375a30..000000000000
--- a/devel/geany-plugins/files/patch-wscript
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./wscript.orig 2010-06-10 19:46:27.000000000 +0300
-+++ ./wscript 2010-09-21 08:36:25.926749379 +0300
-@@ -99,7 +99,7 @@
- [ 'geanylua/geanylua.c' ], # the other source files are listed in build_lua()
- [ 'geanylua' ],
- # maybe you need to modify the package name of Lua, try one of these: lua5.1 lua51 lua-5.1
-- [ [ 'lua', '5.1', True ] ]),
-+ [ [ 'lua-5.1', '5.1', True ] ]),
- Plugin('GeanyPrj', None, [ 'geanyprj/src' ]),
- Plugin('Pretty-Printer', None, [ 'pretty-printer/src' ], [ [ 'libxml-2.0', '2.6.27', True ] ]),
- Plugin('TreeBrowser', None, [ 'treebrowser/src' ], [ [ 'gio-2.0', '2.16', False ] ])
diff --git a/devel/geany-plugins/pkg-descr b/devel/geany-plugins/pkg-descr
index 481976ee4666..e9d626cb925e 100644
--- a/devel/geany-plugins/pkg-descr
+++ b/devel/geany-plugins/pkg-descr
@@ -1,8 +1,3 @@
-Geany is a small and lightweight integrated development environment. It was
-developed to provide a small and fast IDE, which has only a few dependencies
-on other packages. Another goal was to be as independent as possible from a
-special Desktop Environment like KDE or GNOME.
+Plenty of plugins for different purposes from the Geany-Plugins project.
-This port contains plugins for geany
-
-WWW: http://plugins.geany.org/
+WWW: http://plugins.geany.org