aboutsummaryrefslogtreecommitdiff
path: root/devel/gearmand/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-01-29 06:58:29 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-01-29 06:58:29 +0000
commit4e943fb464cf880ec700229f4b64378977496432 (patch)
tree97323d33a7e2aea999a1874ef39d1a2d0ce7beb3 /devel/gearmand/Makefile
parentc65bc8cb3c6d8379213b598c86d5fd6cb10e41c2 (diff)
downloadports-4e943fb464cf880ec700229f4b64378977496432.tar.gz
ports-4e943fb464cf880ec700229f4b64378977496432.zip
Notes
Diffstat (limited to 'devel/gearmand/Makefile')
-rw-r--r--devel/gearmand/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
new file mode 100644
index 000000000000..29b19de2c2de
--- /dev/null
+++ b/devel/gearmand/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gearmand
+# Date created: 2009-01-29
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gearmand
+PORTVERSION= 0.2
+CATEGORIES= devel
+MASTER_SITES= http://launchpad.net/gearmand/trunk/${PORTVERSION}/+download/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Gearman C Server and Library
+
+LIB_DEPENDS= event:${PORTSDIR}/devel/libevent \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
+
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFLICTS= p5-Gearman-Server-[0-9]*
+FETCH_ARGS= -pRr
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+USE_RC_SUBR= gearmand.sh
+
+.include <bsd.port.mk>