aboutsummaryrefslogtreecommitdiff
path: root/devel/gearmand
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2013-07-17 18:19:08 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2013-07-17 18:19:08 +0000
commite8bdd4e827eb66e35d6f2ce0b3a2bffd33c1818f (patch)
treed9b38dac9cffd011222c215b148129498160011f /devel/gearmand
parent88f91d3078fc597fb9b656eac3e103f4c1205b9e (diff)
Notes
Diffstat (limited to 'devel/gearmand')
-rw-r--r--devel/gearmand/Makefile11
-rw-r--r--devel/gearmand/distinfo4
-rw-r--r--devel/gearmand/files/patch-configure21
-rw-r--r--devel/gearmand/files/patch-libgearman-server__log.cc11
-rw-r--r--devel/gearmand/files/patch-libgearman-server__plugins__queue__redis__queue.cc17
-rw-r--r--devel/gearmand/files/patch-libtest__lite.h11
6 files changed, 61 insertions, 14 deletions
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index a12f950f6165..a00f017812a3 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: gearmand
-# Date created: 2009-01-29
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= gearmand
-PORTVERSION= 0.41
+PORTVERSION= 1.0.6
CATEGORIES= devel
MASTER_SITES= http://launchpad.net/gearmand/1.0/${PORTVERSION}/+download/
@@ -20,7 +16,7 @@ LIB_DEPENDS= event:${PORTSDIR}/devel/libevent \
uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
execinfo:${PORTSDIR}/devel/libexecinfo
-CONFLICTS= p5-Gearman-Server-1.*
+CONFLICTS= p5-Gearman-Server-1.* gearmand-1.1.*
.if defined(MAINTAINER_MODE) && ${MAINTAINER_MODE:Myes}
UID_FILES= ../../UIDs
@@ -198,6 +194,7 @@ MAN3= gearman_actions_t.3 \
gearman_worker_remove_options.3 \
gearman_worker_remove_servers.3 \
gearman_worker_set_context.3 \
+ gearman_worker_set_identifier.3 \
gearman_worker_set_log_fn.3 \
gearman_worker_set_memory_allocators.3 \
gearman_worker_set_namespace.3 \
diff --git a/devel/gearmand/distinfo b/devel/gearmand/distinfo
index 2b71c8251562..c30754c775fa 100644
--- a/devel/gearmand/distinfo
+++ b/devel/gearmand/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gearmand-0.41.tar.gz) = eda6bc1f66a8f8d66394744b31ea975bd55f7ef2dfcc3698d7f9835a06ceb875
-SIZE (gearmand-0.41.tar.gz) = 851863
+SHA256 (gearmand-1.0.6.tar.gz) = 52def140a4454d9729fbc0444a49f2c54256f6f6e65168461af12256bfd5d115
+SIZE (gearmand-1.0.6.tar.gz) = 935050
diff --git a/devel/gearmand/files/patch-configure b/devel/gearmand/files/patch-configure
index 7726943bf383..40f057f73c04 100644
--- a/devel/gearmand/files/patch-configure
+++ b/devel/gearmand/files/patch-configure
@@ -1,6 +1,6 @@
---- ./configure.orig 2012-10-03 15:37:17.000000000 -0400
-+++ ./configure 2012-10-03 15:37:17.000000000 -0400
-@@ -19021,7 +19021,7 @@
+--- ./configure.orig 2013-07-17 10:46:57.000000000 -0400
++++ ./configure 2013-07-17 10:46:57.000000000 -0400
+@@ -17972,7 +17972,7 @@
else
@@ -9,7 +9,7 @@
CURL_CFLAGS="`$CURL_CONFIG $curl_config_args --cflags`"
-@@ -19031,7 +19031,7 @@
+@@ -17982,7 +17982,7 @@
fi
@@ -18,7 +18,7 @@
CURL_LIBS="`$CURL_CONFIG $curl_config_args --libs`"
-@@ -19842,6 +19842,7 @@
+@@ -18667,6 +18667,7 @@
| sed -e 's/"//'`
if test $ac_sqlite3_version != ""; then
SQLITE3_VERSION=$ac_sqlite3_version
@@ -26,3 +26,14 @@
else
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Cannot find SQLITE_VERSION macro in sqlite3.h header to retrieve SQLite version!" >&5
$as_echo "$as_me: WARNING: Cannot find SQLITE_VERSION macro in sqlite3.h header to retrieve SQLite version!" >&2;}
+@@ -23849,8 +23850,8 @@
+ LIBS="$PTHREAD_LIBS"
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+-ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+-ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
++ac_compile='$CC -c $CFLAGS $CPPFLAGS -Werror conftest.$ac_ext >&5'
++ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS -Werror $LDFLAGS conftest.$ac_ext $LIBS >&5'
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
diff --git a/devel/gearmand/files/patch-libgearman-server__log.cc b/devel/gearmand/files/patch-libgearman-server__log.cc
new file mode 100644
index 000000000000..1c8d605361c0
--- /dev/null
+++ b/devel/gearmand/files/patch-libgearman-server__log.cc
@@ -0,0 +1,11 @@
+--- ./libgearman-server/log.cc.orig 2013-05-04 05:34:54.000000000 -0400
++++ ./libgearman-server/log.cc 2013-07-17 10:46:57.000000000 -0400
+@@ -56,6 +56,8 @@
+
+ #ifdef _WIN32
+ # include <malloc.h>
++#elif defined(__FreeBSD__)
++# include <stdlib.h>
+ #else
+ # include <alloca.h>
+ #endif
diff --git a/devel/gearmand/files/patch-libgearman-server__plugins__queue__redis__queue.cc b/devel/gearmand/files/patch-libgearman-server__plugins__queue__redis__queue.cc
new file mode 100644
index 000000000000..b60177e1f10d
--- /dev/null
+++ b/devel/gearmand/files/patch-libgearman-server__plugins__queue__redis__queue.cc
@@ -0,0 +1,17 @@
+--- ./libgearman-server/plugins/queue/redis/queue.cc.orig 2013-07-17 10:53:36.000000000 -0400
++++ ./libgearman-server/plugins/queue/redis/queue.cc 2013-07-17 10:53:49.000000000 -0400
+@@ -271,14 +271,11 @@
+ assert(fmt_str_length != 1);
+ return gearmand_gerror("snprintf() failed to produce a valud fmt_str for redis key", GEARMAN_QUEUE_ERROR);
+ }
+-#pragma GCC diagnostic push
+-#pragma GCC diagnostic ignored "-Wformat-nonliteral"
+ int ret= sscanf(reply->element[x]->str,
+ fmt_str,
+ prefix,
+ function_name,
+ unique);
+-#pragma GCC diagnostic pop
+ if (ret == 0)
+ {
+ continue;
diff --git a/devel/gearmand/files/patch-libtest__lite.h b/devel/gearmand/files/patch-libtest__lite.h
new file mode 100644
index 000000000000..de7e33b1ff72
--- /dev/null
+++ b/devel/gearmand/files/patch-libtest__lite.h
@@ -0,0 +1,11 @@
+--- ./libtest/lite.h.orig 2013-05-03 00:58:08.000000000 -0400
++++ ./libtest/lite.h 2013-07-17 10:46:57.000000000 -0400
+@@ -53,6 +53,8 @@
+
+ #if defined(WIN32)
+ # include <malloc.h>
++#elif defined(__FreeBSD__)
++# include <stdlib.h>
+ #else
+ # include <alloca.h>
+ #endif