aboutsummaryrefslogtreecommitdiff
path: root/devel/gearmand
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2012-01-16 20:18:06 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2012-01-16 20:18:06 +0000
commit5066df799de5fb60866b980b3a899c08991b10a4 (patch)
treeeee4c74917de207be0f28adb1cda488b29335e50 /devel/gearmand
parent2ba486a5a6c056ab3ab6349e4d48daa9b238b532 (diff)
downloadports-5066df799de5fb60866b980b3a899c08991b10a4.tar.gz
ports-5066df799de5fb60866b980b3a899c08991b10a4.zip
Notes
Diffstat (limited to 'devel/gearmand')
-rw-r--r--devel/gearmand/Makefile3
-rw-r--r--devel/gearmand/files/extra-patch-configure154
-rw-r--r--devel/gearmand/files/patch-configure10
3 files changed, 11 insertions, 156 deletions
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 557ea774aa5b..824662cbc97d 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -224,8 +224,7 @@ CONFIGURE_ARGS+= --disable-libpq
.ifdef(WITH_SQLITE)
BUILD_DEPENDS+= sqlite3>=3.0.0:${PORTSDIR}/databases/sqlite3
LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
-CONFIGURE_ARGS+= --with-sqlite3=${LOCALBASE}/lib
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
+CONFIGURE_ARGS+= --with-sqlite3=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-sqlite3
.endif
diff --git a/devel/gearmand/files/extra-patch-configure b/devel/gearmand/files/extra-patch-configure
deleted file mode 100644
index 538cdefbdf21..000000000000
--- a/devel/gearmand/files/extra-patch-configure
+++ /dev/null
@@ -1,154 +0,0 @@
---- ./configure.orig 2012-01-13 16:41:29.000000000 -0500
-+++ ./configure 2012-01-13 16:43:45.000000000 -0500
-@@ -23333,150 +23333,12 @@
-
- fi
-
--
-- SQLITE3_CFLAGS=""
-- SQLITE3_LDFLAGS=""
-- SQLITE3_VERSION=""
--
-- if test "x$WANT_SQLITE3" = "xyes"; then
--
-- ac_sqlite3_header="sqlite3.h"
--
-- sqlite3_version_req=3.0.0
-- sqlite3_version_req_shorten=`expr $sqlite3_version_req : '\([0-9]*\.[0-9]*\)'`
-- sqlite3_version_req_major=`expr $sqlite3_version_req : '\([0-9]*\)'`
-- sqlite3_version_req_minor=`expr $sqlite3_version_req : '[0-9]*\.\([0-9]*\)'`
-- sqlite3_version_req_micro=`expr $sqlite3_version_req : '[0-9]*\.[0-9]*\.\([0-9]*\)'`
-- if test "x$sqlite3_version_req_micro" = "x" ; then
-- sqlite3_version_req_micro="0"
-- fi
--
-- sqlite3_version_req_number=`expr $sqlite3_version_req_major \* 1000000 \
-- \+ $sqlite3_version_req_minor \* 1000 \
-- \+ $sqlite3_version_req_micro`
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for SQLite3 library >= $sqlite3_version_req" >&5
--$as_echo_n "checking for SQLite3 library >= $sqlite3_version_req... " >&6; }
--
-- if test "$ac_sqlite3_path" != ""; then
-- ac_sqlite3_ldflags="-L$ac_sqlite3_path/lib"
-- ac_sqlite3_cppflags="-I$ac_sqlite3_path/include"
-- else
-- for ac_sqlite3_path_tmp in /usr /usr/local /opt ; do
-- if test -f "$ac_sqlite3_path_tmp/include/$ac_sqlite3_header" \
-- && test -r "$ac_sqlite3_path_tmp/include/$ac_sqlite3_header"; then
-- ac_sqlite3_path=$ac_sqlite3_path_tmp
-- ac_sqlite3_cppflags="-I$ac_sqlite3_path_tmp/include"
-- ac_sqlite3_ldflags="-L$ac_sqlite3_path_tmp/lib"
-- break;
-- fi
-- done
-- fi
--
-- ac_sqlite3_ldflags="$ac_sqlite3_ldflags -lsqlite3"
--
-- saved_CPPFLAGS="$CPPFLAGS"
-- CPPFLAGS="$CPPFLAGS $ac_sqlite3_cppflags"
--
-- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
--ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
--ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
--ac_compiler_gnu=$ac_cv_c_compiler_gnu
--
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
-- #include <sqlite3.h>
--int
--main ()
--{
--
--#if (SQLITE_VERSION_NUMBER >= $sqlite3_version_req_number)
--// Everything is okay
--#else
--# error SQLite version is too old
--#endif
--
--
-- ;
-- return 0;
--}
--
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- success="yes"
--
--else
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: not found" >&5
--$as_echo "not found" >&6; }
-- success="no"
--
--
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
--ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
--ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
--ac_compiler_gnu=$ac_cv_c_compiler_gnu
--
--
-- CPPFLAGS="$saved_CPPFLAGS"
--
-- if test "$success" = "yes"; then
--
-- SQLITE3_CFLAGS="$ac_sqlite3_cppflags"
-- SQLITE3_LDFLAGS="$ac_sqlite3_ldflags"
--
-- ac_sqlite3_header_path="$ac_sqlite3_path/include/$ac_sqlite3_header"
--
-- if test "x$ac_sqlite3_header_path" != "x"; then
-- ac_sqlite3_version=`cat $ac_sqlite3_header_path \
-- | grep '#define.*SQLITE_VERSION.*\"' | sed -e 's/.* "//' \
-- | sed -e 's/"//'`
-- if test $ac_sqlite3_version != ""; then
-- SQLITE3_VERSION=$ac_sqlite3_version
-- else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Cannot find SQLITE_VERSION macro in sqlite3.h header to retrieve SQLite version!" >&5
--$as_echo "$as_me: WARNING: Cannot find SQLITE_VERSION macro in sqlite3.h header to retrieve SQLite version!" >&2;}
-- fi
-- fi
--
--
--
--
--
--$as_echo "#define HAVE_SQLITE3 /**/" >>confdefs.h
--
-- fi
-- fi
--
--if test "x${ac_cv_libsqlite3}" = "xyes"; then :
--
--
- $as_echo "#define HAVE_LIBSQLITE3 1 " >>confdefs.h
-
-
--else
--
-- ac_cv_libsqlite3=no
--
--$as_echo "#define HAVE_LIBSQLITE3 0 " >>confdefs.h
--
--
--fi
-- if test "x${ac_cv_libsqlite3}" = "xyes"; then
- HAVE_LIBSQLITE3_TRUE=
- HAVE_LIBSQLITE3_FALSE='#'
--else
-- HAVE_LIBSQLITE3_TRUE='#'
-- HAVE_LIBSQLITE3_FALSE=
--fi
-+ ac_cv_libsqlite3=yes
-
-
-
diff --git a/devel/gearmand/files/patch-configure b/devel/gearmand/files/patch-configure
new file mode 100644
index 000000000000..aa9346858605
--- /dev/null
+++ b/devel/gearmand/files/patch-configure
@@ -0,0 +1,10 @@
+--- ./configure.orig 2012-01-16 15:07:46.000000000 -0500
++++ ./configure 2012-01-16 15:08:21.000000000 -0500
+@@ -23441,6 +23441,7 @@
+ | sed -e 's/"//'`
+ if test $ac_sqlite3_version != ""; then
+ SQLITE3_VERSION=$ac_sqlite3_version
++ ac_cv_libsqlite3=yes
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: Cannot find SQLITE_VERSION macro in sqlite3.h header to retrieve SQLite version!" >&5
+ $as_echo "$as_me: WARNING: Cannot find SQLITE_VERSION macro in sqlite3.h header to retrieve SQLite version!" >&2;}